1.0.2 "Maui" Released!

Project Announcements. This is read-only, as in... not for problems/bugs/feature request.
Post Reply
Ted
Power Poster
Power Poster
Posts: 3329
Joined: Fri Jun 11, 2004 6:58 pm
Location: Fairless Hills, Pa USA

1.0.2 "Maui" Released!

Post by Ted »

1.0.2 is ready for mass consumption.

You can get the new release from here:

http://dev.cmsmadesimple.org/frs/downlo ... 0.2.tar.gz
http://dev.cmsmadesimple.org/frs/downlo ... -1.0.2.zip

The MD5 sums for these files are:

7b917c5147b129e27361768d5e96db4c  cmsmadesimple-1.0.2.tar.gz
0017ce34a13142fce58a6d16758dd6f1  cmsmadesimple-1.0.2.zip

This is a minor bugfix release.  Updating from 1.0.1 is optional.  It
was released to address various issues, though nothing critical.

The ChangeLog follows below.

Bugs can be submitted to the bug tracker for the CMSMS core at:
http://dev.cmsmadesimple.org/tracker/?a ... unc=browse

Thanks,
The CMS Made Simple team

--------------------8-<-------cut-here---------8-<-----------------------

Version 1.0.2 "Maui" -- Sep 20 2006
-----------------

- Added valid_css tag
- Fix default template prev and next links positions
- Fix the print tag with mod_rewrite
- Fix undefined index during logout
- Fix sitename htmlentities in installer
- Fixes for various issues in the contact form
- Fixes for issues with search with non-English characters
- Various other little fixes


Just a bugfix release.  Now that people are using the system, we're starting to fix some of the smaller ones and making the system a bit more stable.

Enjoy!
ochsner

Re: 1.0.2 "Maui" Released!

Post by ochsner »

The same:

Huh Since the version 1.0 (has now 1.0.1 installed) I cannot arrange the sides any longer, i.e. the menu option “parent” is missing and also “reorder pages”. How can I repair that? Javascript is activated...


Check the Group Permissions, sounds like you're lacking "Modify Page Structure" rights.
This menu option ist missing too....


[gelöscht durch Administrator]
Last edited by ochsner on Thu Sep 21, 2006 5:43 am, edited 1 time in total.
Der Rudi
Forum Members
Forum Members
Posts: 56
Joined: Wed May 17, 2006 7:42 pm

Re: 1.0.2 "Maui" Released!

Post by Der Rudi »

The admin log still is not correct; see attached screenshot. Maybe in the next release?

[gelöscht durch Administrator]
Greg
Power Poster
Power Poster
Posts: 598
Joined: Sun Sep 26, 2004 6:15 pm
Location: Saskatchewan - Canada

Re: 1.0.2 "Maui" Released!

Post by Greg »

Works great !! Up and running on 7 Web Sites.

Thanks Ted and the CMSMS team !
Greg
Tony Cipriani

Re: 1.0.2 "Maui" Released!

Post by Tony Cipriani »

allright.. I have a serious issue with this release.  ???
I have tried to explain what happened in this post.
The rest of the CMS works fine, but I cannot use the listcontent.php , Firefox tries to download the file instead of showing the 'pages' page.


EDIT : solved, did not have anything to do with the CMS apparently.
Last edited by Tony Cipriani on Fri Sep 29, 2006 2:35 pm, edited 1 time in total.
hman

Re: 1.0.2 "Maui" Released!

Post by hman »

I'm having some problems getting the new version to work for me. I was unable to get the upgrade work when I tried that, so I decided to do a clean install with a completely fresh database. Right now it is working, but none of the stylesheets work (including the admin panel). I can see the admin panel, but everything is unstyled, plain HTML. It's the same with my content. Is anyone else having this issue? Any ideas as to how to solve it?
User avatar
Dr.CSS
Moderator
Moderator
Posts: 12675
Joined: Thu Mar 09, 2006 5:32 am
Location: Arizona

Re: 1.0.2 "Maui" Released!

Post by Dr.CSS »

I have a few diff. ver. running on the same server, same domain with sub folders, without a problem some are clean installs some upgrades.

ochsner: your problem may be due to some calls missing in the language file for your lang.
Check ver. CMSMS, PHP, server OS, in System Information page.
Default content http://multiintech.com/defaultcontent/
People are Wonderful
Business is Great
Life is Terrific
Ever wonder what happened to the Album module? Well it is alive and well.
http://album.multiintech.com/
Image
User avatar
CMSMS-Fan
Forum Members
Forum Members
Posts: 76
Joined: Tue Feb 28, 2006 5:35 pm

Re: 1.0.2 "Maui" Released!

Post by CMSMS-Fan »

There is a major issue with this release which has completley trashed my working website.  It installed fine on a test site so I went ahead and updated my main site and it is now trashed it completley.  I have tried a clean install and restore the DB but nothing works.  It would appear that something may have been altered on my server by the install as I can't even go back to 0.13 and restore my DB as 0.13 which has worked well for ages will install but again the admin is not accessable?
The admin panel is not accessable at all and my host is threatening to remove me from their server due to something altering the server settings.  But they don't know what has been altered to cause the problems.
Often Ignored but never forgotten
tsw
Power Poster
Power Poster
Posts: 1408
Joined: Tue Dec 13, 2005 10:50 pm
Location: Finland

Re: 1.0.2 "Maui" Released!

Post by tsw »

CMSMS cant alter server settings.

What errors does it give?

what works and what doesnt?

if you have a full backup of your old site just remove everything from cmsms folder, restore files
drop all cmsms tables from db and restore db
calguy1000
Support Guru
Support Guru
Posts: 8169
Joined: Tue Oct 19, 2004 6:44 pm
Location: Fernie British Columbia, Canada

Re: 1.0.2 "Maui" Released!

Post by calguy1000 »

a) just saying 'it doesn't work for me' doesn't help us to solve your problem, please post more information, maybe a screen capture or two, and a detailed description of exactly what is not working. what the behaviour is, and hopefully any error messages you get.

b) Getting an unstyled admin panel is usually a symptom that PHP has run out of memory, there are lots of threads about this in the forum.  Upgrading your php memory limit will probably solve the issue. 

Looking in your httpd error logs will probably tell you exactly what the issue is.
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.
User avatar
CMSMS-Fan
Forum Members
Forum Members
Posts: 76
Joined: Tue Feb 28, 2006 5:35 pm

Re: 1.0.2 "Maui" Released!

Post by CMSMS-Fan »

Sorry,
I have spent some time looking at the issue and I think it was due to some of the files not being overwritten during the upload of the new files.

a) the sympoms were posted on thread Interresting Warnings....
b) it wasn't that I had an unstyled admin it was that admin was not accessable at all.

I have now got the site up and running but the only way was to delete all CMSMS files from the server, Except config.php.  I uploaded the new files and ran the upgrade.php.  This then worked first time.

The issue I can only assume now was that my server did not overwrite correctly or my ftp was flawed in some way.
Often Ignored but never forgotten
tsw
Power Poster
Power Poster
Posts: 1408
Joined: Tue Dec 13, 2005 10:50 pm
Location: Finland

Re: 1.0.2 "Maui" Released!

Post by tsw »

too many ftp clients refuse to overwrite files correctly...
Piratos

install.php

Post by Piratos »

There is no need for this - you can delete it:

Code: Select all

   /*
      if (isset($gCms->modules['Search']) && isset($gCms->modules['Search']['object']))
      {
         echo '<p>Index Search...';
         
         $modinstance =& $gCms->modules['Search']['object'];
         @$modinstance->Reindex();

         echo "[done]</p>";
      }
      */
benn

Re: 1.0.2 "Maui" Released!

Post by benn »

Cannot upload xml using the new 'Install module via XML file'. Does work on other clients servers but not our own. Can anyone help?

Our server is running php 4.3.3 on Linux
Have tried changing the default_upload_permission to 777 but with no luck.
Have set permissions to 777 on the modules folder, tmp/templates_c, tmp/cache, uploads, uploads/images but still no luck

When I upload an xml file using this new technique I think the files that cms creates are setting the permissions to 755, but not sure.

Please see this thread for more information
http://forum.cmsmadesimple.org/index.php/topic,7334.0.html

Thanks
User avatar
Dr.CSS
Moderator
Moderator
Posts: 12675
Joined: Thu Mar 09, 2006 5:32 am
Location: Arizona

Re: 1.0.2 "Maui" Released!

Post by Dr.CSS »

I updated my 0.13beat4 to stable 1.0.2 and the only thing I had to do was change the RowCounts as explained here...

http://forum.cmsmadesimple.org/http://p ... 014#p39014

I will say that if you used the old default CSSMenu for drop down/fly out style menus it will get over written with a new one that adds the to it so you have to add the call in your style sheet, the actual CSS is in another thread, just do a search.
Check ver. CMSMS, PHP, server OS, in System Information page.
Default content http://multiintech.com/defaultcontent/
People are Wonderful
Business is Great
Life is Terrific
Ever wonder what happened to the Album module? Well it is alive and well.
http://album.multiintech.com/
Image
Post Reply

Return to “Announcements”