<textarea> tag not showing in browser

For discussion and questions related to CMS Specific templates and stylesheets (CSS), and themes. or layout issues. This is not a place for generic "I don't know CSS issues"
Locked
Sendlingur
Forum Members
Forum Members
Posts: 57
Joined: Wed Aug 08, 2018 4:59 pm

<textarea> tag not showing in browser

Post by Sendlingur »

I pasted a form to the <source code> in the content manager.

But the <input> tags are only showing but not the <textarea> tag.

It is almost like the editor is somehow skipping the tag after I paste it to the <source code>. (please see attachment)
here is a pic that shows the &amp;nbsp; that appears were the &lt;textarea&gt; should be.
here is a pic that shows the &nbsp; that appears were the <textarea> should be.
notextarea.PNG (3.58 KiB) Viewed 1174 times
Can someone explain to me why this is happening and is there a solution to this.
scooper
Forum Members
Forum Members
Posts: 239
Joined: Fri Dec 09, 2005 12:36 pm
Location: Marlow, UK

Re: <textarea> tag not showing in browser

Post by scooper »

Assuming you're using TinyMCE (or MicroTiny) ... some older versions of the editor would strip empty tags. So if there's nothing in your textarea to start with that might be the problem.

It's working fine for me here in the latest version though. You should try making sure you're up to date and then try with some placeholder content in the textarea.
User avatar
DIGI3
Dev Team Member
Dev Team Member
Posts: 1030
Joined: Wed Feb 25, 2009 4:25 am
Location: Victoria, BC

Re: <textarea> tag not showing in browser

Post by DIGI3 »

It's also a good idea to not use WYSIWYG on html-heavy pages. Good options are to either disable wysiwyg for that page, or put the form in a generic template and just put the template call in the content instead:

Code: Select all

{include file='cms_template:myformtemplate}
The latter makes it harder for users to accidentally mess up the form, too.
Not getting the answer you need? CMSMS support options
Sendlingur
Forum Members
Forum Members
Posts: 57
Joined: Wed Aug 08, 2018 4:59 pm

Re: <textarea> tag not showing in browser

Post by Sendlingur »

Thank you both for the info. I have everything working as it should now
Locked

Return to “Layout and Design (CSS & HTML)”