[fixed] exported design files without xml extensions

Forum rules
Only administrators can post or move items here.
archeo
Forum Members
Forum Members
Posts: 104
Joined: Tue Oct 21, 2014 12:47 pm
Location: Lorient (France)

[fixed] exported design files without xml extensions

Post by archeo »

Testing the export of design, I found that the exported files had no xml extension except for NCleanBlue design. Does I do any error?
jce76350
Beta Tester
Beta Tester
Posts: 1950
Joined: Mon May 29, 2006 1:20 pm
Location: Rouen

Re: exported design files without xml extensions

Post by jce76350 »

Confirmed in last rev 9734
Jean-Claude Etiemble
User avatar
Rolf
Dev Team Member
Dev Team Member
Posts: 7739
Joined: Wed Apr 23, 2008 7:53 am
Location: The Netherlands

Re: exported design files without xml extensions

Post by Rolf »

jce76350 wrote:Confirmed in last rev 9734
Could you please retest in latest SVN?
Image
- + - + - + - + - + -
Latest CMSMS tutorial: FormBuilder WatchGuard
- + - + - + - + - + -
Did my post help you solving a problem at your (customers) website and it saved you many hours of work?
Great!! Buy me a cup of coffee in return as a small token of appreciation!
archeo
Forum Members
Forum Members
Posts: 104
Joined: Tue Oct 21, 2014 12:47 pm
Location: Lorient (France)

Re: [confirmed] exported design files without xml extensions

Post by archeo »

xml extension only for minimal and ncleanblue (svn 9758),
but there is no menu on all pages except for those using minimal template and ncleanblue template
install : windows seven / wampserver 2.5 / apache 2.4.9 / php 5.5.12 / mysql 5.6.17
jce76350
Beta Tester
Beta Tester
Posts: 1950
Joined: Mon May 29, 2006 1:20 pm
Location: Rouen

Re: [confirmed] exported design files without xml extensions

Post by jce76350 »

I confirm in last rev 9758
No export with xml extension except NCleanBlue and Minimal
Jean-Claude Etiemble
calguy1000
Support Guru
Support Guru
Posts: 8169
Joined: Tue Oct 19, 2004 6:44 pm
Location: Fernie British Columbia, Canada

Re: [confirmed] exported design files without xml extensions

Post by calguy1000 »

I checked the code and it physically adds .xml to the output filename
I tested exporting 2 designs (not NCleanBlue or Minimal) with spaces and other characters in the name, and the extension was there.
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.
jce76350
Beta Tester
Beta Tester
Posts: 1950
Joined: Mon May 29, 2006 1:20 pm
Location: Rouen

Re: [confirmed] exported design files without xml extensions

Post by jce76350 »

test export on Web server PHP 5.17-1~dotdeb.1 SVN 9764
no extension
see
Image
Jean-Claude Etiemble
archeo
Forum Members
Forum Members
Posts: 104
Joined: Tue Oct 21, 2014 12:47 pm
Location: Lorient (France)

Re: [confirmed] exported design files without xml extensions

Post by archeo »

the "save function" is very restrictive, since we can not choose the name of the file ( and the extension), "save as" would be better.
User avatar
Rolf
Dev Team Member
Dev Team Member
Posts: 7739
Joined: Wed Apr 23, 2008 7:53 am
Location: The Netherlands

Re: [confirmed] exported design files without xml extensions

Post by Rolf »

Could you please re-test this issue in the Beta 3 release?

Thanks, Rolf
Image
- + - + - + - + - + -
Latest CMSMS tutorial: FormBuilder WatchGuard
- + - + - + - + - + -
Did my post help you solving a problem at your (customers) website and it saved you many hours of work?
Great!! Buy me a cup of coffee in return as a small token of appreciation!
archeo
Forum Members
Forum Members
Posts: 104
Joined: Tue Oct 21, 2014 12:47 pm
Location: Lorient (France)

Re: [confirmed] exported design files without xml extensions

Post by archeo »

test beta3
configuration
----------------------------------------------

Cms Version: 2.0-beta3

Installed Modules:

AdminSearch: 1.0
CMSContentManager: 1.0
DesignManager: 1.0
FileManager: 1.5
MicroTiny: 2.0
ModuleManager: 2.0
Navigator: 1.0
News: 2.50
Search: 1.50


Config Information:

php_memory_limit:
max_upload_size: 64000000
url_rewriting: none
page_extension:
query_var: page
auto_alias_content: true
locale:
default_encoding: utf-8
admin_encoding: utf-8
set_names: true
timezone: Europe/Paris


Php Information:

phpversion: 5.5.12
md5_function: On (Vrai)
json_function: On (Vrai)
gd_version: 2
tempnam_function: On (Vrai)
magic_quotes_runtime: Off (Faux)
E_STRICT: 0
E_DEPRECATED: 0
test_file_timedifference:
test_db_timedifference:
memory_limit: 128M
max_execution_time: 120
output_buffering: 4096
safe_mode: Off (Faux)
file_uploads: On (Vrai)
post_max_size: 3M
upload_max_filesize: 64M
session_save_path: c:/wamp/tmp (0777)
session_use_cookies: On (Vrai)
xml_function: On (Vrai)
xmlreader_class: On (Vrai)

Server Information:

Server Api: apache2handler
Server Db Type: MySQL (mysqli)
Server Db Version: 5.6.17
Server Db Grants: Trouvé un privilège "GRANT ALL" qui semble être adapté
Server Time Diff: Aucune différence de date du système de fichiers trouvées


----------------------------------------------
WampServer Version 2.5
Windows seven edidition familiale premium service pack 1 (I can send you all the installed programs)
------------------------------------------------
Design export always crashes on adding the extension xml. Design can be imported by adding the xml extension. But the display of the site is not complete : only the "content" is displayed. For example if you have imported css menu + 1column after exported, template and css have a "2" add on it. Replacing methodically template and CSS version imported by the original version, I realized that the css "print2" bugs. This css masks tinks which should not be printed so that only the "content" is displayed. Css imported (print2) therefore no longer distinguish if you are in print or display mode. Yet the two files are exactly the same.
jce76350
Beta Tester
Beta Tester
Posts: 1950
Joined: Mon May 29, 2006 1:20 pm
Location: Rouen

Re: [confirmed] exported design files without xml extensions

Post by jce76350 »

I confirm in beta3 no xml extension except in NCleanBlue and Minimal on WAMP
Jean-Claude Etiemble
archeo
Forum Members
Forum Members
Posts: 104
Joined: Tue Oct 21, 2014 12:47 pm
Location: Lorient (France)

Re: [confirmed] exported design files without xml extensions

Post by archeo »

With the same configuration, I rename "CSSMenu left + 1 column" in "CSSMenu_left_1_column" and the file is save with the extension xml.
HOURA!! :) . Windows does not like blanck space in file names (and that since MSDOS)
EDIT : verification :
ncleanblue is exported without problem,
now import ncleanblue.xml,
you have a new design ncleanblue 1 (with a space),
export ncleanblue 1 : bug : no extension xml
export ncleanblue1 : no bug
replace space by U+00A0 : no bug
What sort of space did you use?
I only remember now (because it's a very old memory dating back 1990) that windows considers some space (decimal code 32) as the end of a file wihout extension. You must use decimal code 255 because MSDOS uses extended ASCII code page 437. In this (old) page decimal code 32 is for cariage return (end of file name). Windows File Manager automaticaly translates "code 32" in "code 255".
Last edited by archeo on Wed Jan 14, 2015 7:16 pm, edited 2 times in total.
jce76350
Beta Tester
Beta Tester
Posts: 1950
Joined: Mon May 29, 2006 1:20 pm
Location: Rouen

Re: [confirmed] exported design files without xml extensions

Post by jce76350 »

Test on Web server 5.5.17-1 Debian and all the export are OK with XML extension.
Jean-Claude Etiemble
archeo
Forum Members
Forum Members
Posts: 104
Joined: Tue Oct 21, 2014 12:47 pm
Location: Lorient (France)

Re: [confirmed] exported design files without xml extensions

Post by archeo »

With "good" exports with xml extension the css "print" does not works correctly.
jce76350
Beta Tester
Beta Tester
Posts: 1950
Joined: Mon May 29, 2006 1:20 pm
Location: Rouen

Re: [confirmed] exported design files without xml extensions

Post by jce76350 »

solved : exported design XML, for me in WAMP and Web server in rev 9803
Jean-Claude Etiemble
Post Reply

Return to “Closed Issues”