• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC


Forum rules


Only administrators can post or move items here.



Post new topic Reply to topic  [ 29 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: [closed] Installation won't start > white screen
PostPosted: Mon May 19, 2014 8:00 am 
Offline
Forum Members
Forum Members

Joined: Tue Apr 02, 2013 1:15 pm
Posts: 23
Location: 's-Hertogenbosch
Hello CMSMS Heroes!

I'm excited to try the Beta version of CMSMS 2.0.

Unfortunately the installation welcome screen isn't showed and gives a white screen.

This is described in the README-PHAR.txt:

Quote:
You should now be presented with a welcome screen. If, instead, you see a white screen it probably means that your
server is running old, or incompatible software and that you may be forced to use the traditional installer.


So I'd checked the requirements with phpinfo();

  1. Required > Present
  2. PHP 5.4.11 > 5.4.27
  3. PHAR > enabled
  4. json > enabled 1.2.1
  5. tokenizer > enabled
  6. xml > active / libxml2 2.9.1
  7. gd > enabled

What am I missing here ? What can I do to make the welcome screen start ?

I added the phpinfo file.


Attachments:
index.zip [15.11 KiB]
Downloaded 109 times


Last edited by brutusmaximus on Tue May 20, 2014 6:10 am, edited 1 time in total.
Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Installation won't start > white screen
PostPosted: Mon May 19, 2014 8:58 am 
Offline
Forum Members
Forum Members

Joined: Tue Apr 02, 2013 1:15 pm
Posts: 23
Location: 's-Hertogenbosch
Error reporting shows:

Fatal error: Uncaught exception 'PharException' with message 'phar "../public_html/cmsms/cmsms-2.0-beta1-install.php" SHA1 signature could not be verified: broken signature' in ..public_html/cmsms/cmsms-2.0-beta1-install.php:14 Stack trace: #0 ../public_html/cmsms/cmsms-2.0-beta1-install.php(14): Phar::webPhar(NULL, 'index.php') #1 {main} thrown in ../public_html/cmsms/cmsms-2.0-beta1-install.php on line 14


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Installation won't start > white screen
PostPosted: Mon May 19, 2014 9:02 am 
Offline
Power Poster
Power Poster

Joined: Wed Jul 04, 2007 3:39 pm
Posts: 315
Same fatal error for me.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Installation won't start > white screen
PostPosted: Mon May 19, 2014 10:19 am 
Offline
Power Poster
Power Poster

Joined: Sat May 05, 2012 7:29 pm
Posts: 404
Location: India
The same here too :-\ ...


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Installation won't start > white screen
PostPosted: Mon May 19, 2014 11:49 am 
Offline
Dev Team Member
Dev Team Member

Joined: Mon Nov 28, 2011 9:29 am
Posts: 3086
Location: The Netherlands
My first and wild guess would be the installed Suhosin extension.

I had some troubles with Zend Guard Loader. After disabling that one, installation completed successfully.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Installation won't start > white screen
PostPosted: Mon May 19, 2014 12:02 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Wed Jul 09, 2008 7:06 am
Posts: 47
Also a white screen for us.

PHP Version 5.5.11


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Installation won't start > white screen
PostPosted: Mon May 19, 2014 12:07 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Sat Feb 27, 2010 2:37 pm
Posts: 193
Location: Finland
Instead of white screen, could you enable PHP error reporting and set it to E_STRICT, this should generate some sort of message whats going wrong

Thanks

UPDATE: brutusmaximus already provided error, you guys could check its the same one.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Installation won't start > white screen
PostPosted: Mon May 19, 2014 12:52 pm 
Offline
Power Poster
Power Poster

Joined: Mon Sep 08, 2008 9:43 am
Posts: 307
I had the same error. Then uploaded the archive in BINARY-Mode per FTP and the error was gone.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Installation won't start > white screen
PostPosted: Mon May 19, 2014 1:04 pm 
Offline
Power Poster
Power Poster

Joined: Wed Jul 04, 2007 3:39 pm
Posts: 315
Yep, that does the trick. If FileZilla is in the 'Transfrer type' > 'Auto' then because of the PHP file extension it gets treated as ASCII. Sure this will be the same for many FTP programs. An update of the README-PHAR.txt should be enough, but I suspect the forum will still get flooded.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Installation won't start > white screen
PostPosted: Mon May 19, 2014 1:07 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Sat Feb 27, 2010 2:37 pm
Posts: 193
Location: Finland
Oh man so its not PHAR installer itself but FTP XD

And agree that this is huge issue.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Installation won't start > white screen
PostPosted: Mon May 19, 2014 1:20 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Tue Oct 19, 2004 6:44 pm
Posts: 8011
Location: Fernie British Columbia, Canada
1. Install instructions explicitly state to expand the zip file ON the server using your web hosts control panel or a better technology than ftp.
2. Please move away from ftp which is probably the worst file transfer mechanism out there.
3. We have stated for YEARS that you should use binary mode to transfer files if you insist on using ftp.

_________________
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Installation won't start > white screen
PostPosted: Mon May 19, 2014 1:45 pm 
Offline
Forum Members
Forum Members

Joined: Tue Apr 02, 2013 1:15 pm
Posts: 23
Location: 's-Hertogenbosch
calguy1000 wrote:
1. Install instructions explicitly state to expand the zip file ON the server using your web hosts control panel or a better technology than ftp.

Yes after checking the instuctions I noticed expanding the package on the server. [edit] found the extract function in the filemanager of direct admin[/edit]

2. Please move away from ftp which is probably the worst file transfer mechanism out there.
- I don't have SSH access, but uploading with my control panel is an option.
3. We have stated for YEARS that you should use binary mode to transfer files if you insist on using ftp.
Then I missed that for a couple of years.



I uploaded the file with my DirectAdmin controlpanel and extracted it with the code above. Without success. I tried it for 4 times.


Last edited by brutusmaximus on Mon May 19, 2014 2:24 pm, edited 1 time in total.

Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Installation won't start > white screen
PostPosted: Mon May 19, 2014 1:54 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Tue Oct 19, 2004 6:44 pm
Posts: 8011
Location: Fernie British Columbia, Canada
Most hosts have a control panel that allows uploading files, and an option to unzip files. Even the most crappy control panel I've used had that option somewhere.

And if your host doesn't have a web control panel that allows uploading and unzipping files, then it's probably time to consider moving to a host that doesn't suck.

_________________
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Installation won't start > white screen
PostPosted: Mon May 19, 2014 2:10 pm 
Offline
Forum Members
Forum Members

Joined: Tue Apr 02, 2013 1:15 pm
Posts: 23
Location: 's-Hertogenbosch
  1. Uploaded the file with the filemanager DirectAdmin.
  2. Found the extract function in the filemanager.
  3. Ran the file and the same error pops up.

???

I appreciate all the effort and time for helping me. Thanks in advance @calguy.

@cb2004, @candra and @hgpdesign did you manage to install CMS MS 2.0 by changing the FTP transfermode to binair ?


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Installation won't start > white screen
PostPosted: Mon May 19, 2014 2:53 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Wed Jul 09, 2008 7:06 am
Posts: 47
We uploaded (with Fetch) the zip file and 'unzipped' it on the server with PHP UnZIP (unzip.zip-> unzip.php) and now we have our 'welcome screen'!


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 29 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
A2 Hosting