Upgrade from 1.11.1 to 1.11.4 can't edit pages

Help with getting the CMS CORE package up and running. This does not include 3rd party modules, PHP scripts, anything downloaded via module manager or from any external source.
User avatar
Jo Morg
Dev Team Member
Dev Team Member
Posts: 1812
Joined: Mon Jan 29, 2007 4:47 pm

Re: Upgrade from 1.11.1 to 1.11.4 can't edit pages

Post by Jo Morg »

Did you actually try this: http://forum.cmsmadesimple.org/viewtopi ... =3&t=64546 ?
In long threads like this one I never know if people actually read it all an try all suggestions... :P Maybe people could state all steps they already took before... (duh, this is just me daydreaming...)

PS: and, btw, I don't think guestbook is up to date with recent cmsms versions...
"There are 10 types of people in this world, those who understand binary... and those who don't."
* by the way: English is NOT my native language (sorry for any mistakes...).
Code of Conduit | CMSMS Docs | Help Support CMSMS
My developer Page on the Forge | Yet another blog about CMSMS
GeekMoot 2015 in Ghent, Belgium: I was there!
GeekMoot 2016 in Leicester, UK: I was there!
User avatar
Rolf
Dev Team Member
Dev Team Member
Posts: 7772
Joined: Wed Apr 23, 2008 7:53 am
Location: The Netherlands
Contact:

Re: Upgrade from 1.11.1 to 1.11.4 can't edit pages

Post by Rolf »

Jo Morg wrote:PS: and, btw, I don't think guestbook is up to date with recent cmsms versions...
Yeah, it does work in latest cmsms release!
Image
- + - + - + - + - + -
Latest CMSMS tutorial: FormBuilder WatchGuard
- + - + - + - + - + -
Did my post help you solving a problem at your (customers) website and it saved you many hours of work?
Great!! Buy me a cup of coffee in return as a small token of appreciation!
User avatar
Jo Morg
Dev Team Member
Dev Team Member
Posts: 1812
Joined: Mon Jan 29, 2007 4:47 pm

Re: Upgrade from 1.11.1 to 1.11.4 can't edit pages

Post by Jo Morg »

Rolf wrote:
Jo Morg wrote:PS: and, btw, I don't think guestbook is up to date with recent cmsms versions...
Yeah, it does work in latest cmsms release!
Sorry! I stand corrected. 8)
"There are 10 types of people in this world, those who understand binary... and those who don't."
* by the way: English is NOT my native language (sorry for any mistakes...).
Code of Conduit | CMSMS Docs | Help Support CMSMS
My developer Page on the Forge | Yet another blog about CMSMS
GeekMoot 2015 in Ghent, Belgium: I was there!
GeekMoot 2016 in Leicester, UK: I was there!
Mats Helge

Re: Upgrade from 1.11.1 to 1.11.4 can't edit pages

Post by Mats Helge »

Jo Morg wrote:Did you actually try this: http://forum.cmsmadesimple.org/viewtopi ... =3&t=64546 ?
I did try this, got as far as deleting the files and changing the first template, after which I could edit pages associated with that specific template. When I tried to edit other templates it wouldnt save the modifications, just printed a mixed up page with some nes articles.

I then tried to manually empty cache during edit mode on, but this didnt help.

I also checked that my menu manager is not cacheable.

After this I uploaded the deleted stylesheet-files back to the server.

So I think I've tried most of the workarounds now. Gladly I have a working webpage, just hope some cure will appear before I have to update my pages.

Thanks for all help this far and I'm sure you specialist can figure this one out soon!
dlen
Forum Members
Forum Members
Posts: 67
Joined: Fri Apr 09, 2010 11:32 pm

Re: Upgrade from 1.11.1 to 1.11.4 can't edit pages

Post by dlen »

Jo Morg wrote:Did you actually try this: http://forum.cmsmadesimple.org/viewtopi ... =3&t=64546 ?
Yes I did. This caused the error message displayed, because cmsms did not find the "stylesheet"-object.

But IMHO no template whatsoever should crash the backend, as it shouldn't be interpreted there in the first place.

A tip: I edited templates - having no other way left - via phpmyAdmin directly in the database.
User avatar
Dr.CSS
Moderator
Moderator
Posts: 12678
Joined: Thu Mar 09, 2006 5:32 am
Location: Arizona

Re: Upgrade from 1.11.1 to 1.11.4 can't edit pages

Post by Dr.CSS »

@Mats Helge

Both TreeManager and Forum have most likely NOT been upgraded to work with the latest versions of CMSMS...
Check ver. CMSMS, PHP, server OS, in System Information page.
Default content http://multiintech.com/defaultcontent/
People are Wonderful
Business is Great
Life is Terrific
Ever wonder what happened to the Album module? Well it is alive and well.
http://album.multiintech.com/
Image
janvl
Power Poster
Power Poster
Posts: 865
Joined: Wed Aug 13, 2008 10:57 am

Re: Upgrade from 1.11.1 to 1.11.4 can't edit pages

Post by janvl »

There is a clear stability-issue here.

I have just the same problem, now the cause is in a UDT that is functioning normal but blocks the ability to edit the template, or add a page.

This phenomena is only there since 1.11.4.
Just mentioning "I cannot produce the error so it does not exist" is not a way of solving problems.

I hope someone will start seaching in the code, what has changed since 1.11.3 to 1.11.4, how come that some smarty-code blocks the edit functionality. I am very willing to assist in finding the cause.

Kind regards,
Jan
calguy1000
Support Guru
Support Guru
Posts: 8169
Joined: Tue Oct 19, 2004 6:44 pm
Location: Fernie British Columbia, Canada

Re: Upgrade from 1.11.1 to 1.11.4 can't edit pages

Post by calguy1000 »

Other than the (long deprecated) {stylesheet} tag (Deprecated around the 1.8 series, we stopped shipping it a long time ago, and now it no longer works). This is probably caused by badly written UDT's executed from a page template or the page content itself.

1.11.x uses the smarty parser to parse page templates to find content blocks. This gives us the advantage of using template inheritance, or simply defining content blocks inside of GCB's.

In 1.11.1 UDT's were not loaded in the admin interface. They were replaced with dummy plugins. However, this caused problems with stylesheets that used UDT's and the wysiwyg editors, along with other problems. So we had to enable this in 1.11.4. Unfortunately, that means that your UDT's must be clean, and smarter than they were before.

However, there is always an error message somewhere. And has has been said before, you need to find it. Once you find the error messages you will have a much better idea as to how to solve your problem.
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.
janvl
Power Poster
Power Poster
Posts: 865
Joined: Wed Aug 13, 2008 10:57 am

Re: Upgrade from 1.11.1 to 1.11.4 can't edit pages

Post by janvl »

Hi,

I will put debug mode on and see what comes out, This will be done in about 4 hours when it is night here.
In the meantime I will use a testinstallation on the same kind of host with debug on. There I found the cause of the problem.

What i have is a UDT called {mobildetect} without "e" to prevent mixup with terms that I should not use.
The code in the UDT is

Code: Select all

@include("Mobile_Detect.php");
$detect = new Mobile_Detect();
if ($detect->isMobile() && isset($_COOKIE['mobile']))
{
$detect = "false";
}
elseif ($detect->isMobile())
{
header("Location:http://www.taxigerhard.at/index.php?page=mobil");
}
which incorporates a PHP Script from google
http://code.google.com/p/php-mobile-detect/
so I trust it to be of enough quality.

Still this blocks the normal functionality of CMSMS.
Now as you can hardly call this "coding" done by me I would say there is a problem within CMSMS 1.11.4.
Just for the record, I used to be a systemmanager for VaxVMS so I have had a lot to do with software that broke systems.

I appreciate the achievements made by the devteam and CMSMS is the best CMS I know for small to mediumsize websites. Since about half a year however, I am getting very carefull making updates for customers because of problems like this. Sometimes choosing for a slower pace in updates is good for stability.

Kind regards,
Jan
janvl
Power Poster
Power Poster
Posts: 865
Joined: Wed Aug 13, 2008 10:57 am

Re: Upgrade from 1.11.1 to 1.11.4 can't edit pages

Post by janvl »

Hi,

with
$config['debug'] = true ;
in config.php

I had hope to see some information but I still get a beautifully white page when trying to save the template.
Now somewhere there must be a way to get some error that tells me what is wrong here. I am open for every experiment.

Kind regards,
Jan
dlen
Forum Members
Forum Members
Posts: 67
Joined: Fri Apr 09, 2010 11:32 pm

Re: Upgrade from 1.11.1 to 1.11.4 can't edit pages

Post by dlen »

I looked at the server error log and did find no useful information.

Without the backend showing anything, it is very hard to get the error messages - may be there is a trick, which the wiser-than-me know (no irony, this is really necessary to solve somehow).

Also it would be useful to define, what exactly separates a "clean" UDT from a "not so clean" one.

Or build in some UDT-test that throws an error message before the backend output is killed??? (I'm of very basic proficiency.)
calguy1000
Support Guru
Support Guru
Posts: 8169
Joined: Tue Oct 19, 2004 6:44 pm
Location: Fernie British Columbia, Canada

Re: Upgrade from 1.11.1 to 1.11.4 can't edit pages

Post by calguy1000 »

Did you try to 'run' the UDT from the admin interface?
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.
dlen
Forum Members
Forum Members
Posts: 67
Joined: Fri Apr 09, 2010 11:32 pm

Re: Upgrade from 1.11.1 to 1.11.4 can't edit pages

Post by dlen »

Maybe that can help carry investigations a bit forward:

The 1st file is the template that seems to cause the backend to go on strike:

http://dominik-lenne.de/cmsmsfiles/my_template.txt

The 2nd file is what cmsms 1.11.4 delivers when be clicked on "edit page"

http://dominik-lenne.de/cmsmsfiles/home ... ssible.txt

Remark: The frontend is working flawlessly! Only the backend, which actually doesn't use the template (only loads it as said above for some reason) is puzzled.
User avatar
Jo Morg
Dev Team Member
Dev Team Member
Posts: 1812
Joined: Mon Jan 29, 2007 4:47 pm

Re: Upgrade from 1.11.1 to 1.11.4 can't edit pages

Post by Jo Morg »

Replace {stylesheet} with {cms_stylesheet} on your template.
dlen wrote:* I replaced every existing {stylesheets} with {cms_stylesheets}
Well it is still on the template. ???
"There are 10 types of people in this world, those who understand binary... and those who don't."
* by the way: English is NOT my native language (sorry for any mistakes...).
Code of Conduit | CMSMS Docs | Help Support CMSMS
My developer Page on the Forge | Yet another blog about CMSMS
GeekMoot 2015 in Ghent, Belgium: I was there!
GeekMoot 2016 in Leicester, UK: I was there!
dlen
Forum Members
Forum Members
Posts: 67
Joined: Fri Apr 09, 2010 11:32 pm

Re: Upgrade from 1.11.1 to 1.11.4 can't edit pages

Post by dlen »

I am very sorry for that - I somehow loaded the wrong file up. I corrected it. But it makes no difference concerning editing pages.

Another information which might be of importance: i updated from 1.10.3 directly to 1.11.4 by copying the full-install-file and running upgrade.php.

I checked, that there is no use of {stylesheet} in the whole site by searching for the string and looking how it is used - only in commenting texts referring to it being deprecated.

I uninstalled the Guestbook and AVPlayer - modules to no avail.

Also, as additional info, I installed multilanguage capability according to
http://www.i-do-this.com/blog/25/Anothe ... CMSMS-Page. Don't know whether this affects the problem.
Locked

Return to “[locked] Installation, Setup and Upgrade”