error on assign in a smarty template

A place to discuss issues related to CMSMS 1.11 beta versions. This forum will be heavily moderated.
Locked
leolivier

error on assign in a smarty template

Post by leolivier »

In a template (which works fine in 1.10.3) I get the following error:

Code: Select all

OMG! You broke this page.
Error: at line 656 in file D:\wamp\www\ph1.11\lib\smarty\sysplugins\smarty_internal_templatecompilerbase.php:

Message:

Syntax Error in template "96fe65b6569c1054e0dcbb74aa499c624f486433"  on line 90 "{assign var="movie"  value="http://www.youtube.com/v/`$item->videoid`&hl=`$item->lang`&fs=`$item->fullscreen_int`&rel=0&color1=`$item->color1`&color2=`$item->color2`&border=1&autoplay=`$item->autoplay`"}" missing "value" attribute
I am on svn 8201
User avatar
Dr.CSS
Moderator
Moderator
Posts: 12675
Joined: Thu Mar 09, 2006 5:32 am
Location: Arizona

Re: error on assign in a smarty template

Post by Dr.CSS »

You need to show the 'before' code...
Check ver. CMSMS, PHP, server OS, in System Information page.
Default content http://multiintech.com/defaultcontent/
People are Wonderful
Business is Great
Life is Terrific
Ever wonder what happened to the Album module? Well it is alive and well.
http://album.multiintech.com/
Image
leolivier

Re: error on assign in a smarty template

Post by leolivier »

I finally understood what's happening!
Apparently, smarty (or at least the smarty parser in cmsms 1.11) does not manage tabs (not screen parts but \t) correctly any more...
In the line above there is a tab between var="movie" and value="...
I just removed the \t and the error moved to the next one 5 lines further...

Should be corrected I think...
Locked

Return to “[locked] CMSMS 1.11 Beta”