0.13 Beta4 Released!

Project Announcements. This is read-only, as in... not for problems/bugs/feature request.
User avatar
Dr.CSS
Moderator
Moderator
Posts: 12675
Joined: Thu Mar 09, 2006 5:32 am
Location: Arizona

Re: 0.13 Beta4 Released!

Post by Dr.CSS »

here you go 2 flavors the whole anchilada or just the update files all zipped up and ready to go out and play...;)...

http://www.multiintech.com/index.php

  mark
Check ver. CMSMS, PHP, server OS, in System Information page.
Default content http://multiintech.com/defaultcontent/
People are Wonderful
Business is Great
Life is Terrific
Ever wonder what happened to the Album module? Well it is alive and well.
http://album.multiintech.com/
Image
Russ
Power Poster
Power Poster
Posts: 813
Joined: Fri Nov 25, 2005 5:02 pm
Location: North West England

Re: 0.13 Beta4 Released!

Post by Russ »

Many thanks Mark, when I can shake of that 'Sunday Feeling' I'll get testing :)

Seeing what you've been playing with, maybe it would be good to create a proper blog module based on news. With perhaps 'captacha' for blog entry to stop spam etc. That way we can tailor a new set of fields for a blog and a more blog like data entry form. What do you think? I can have a look and put together something. It could then have nice url's like the news module:

http://www.domain/news/2005-05-30/newsstory ...

http://www.domain/blog/2005-06-31/blogentry ...

We could also add a calendar type display for retrieving older news items and also a mini side bar display of the top five or so items like you have already done.

Russ
User avatar
Dr.CSS
Moderator
Moderator
Posts: 12675
Joined: Thu Mar 09, 2006 5:32 am
Location: Arizona

Re: 0.13 Beta4 Released!

Post by Dr.CSS »

actually i've rewriten a news module to include the word blog to make it diff. than the news that's where the 'Comments' link comes from it used to be the [More] link for news and thru in a comments counter tag that Elijah(?sp) worked up. i needed Blog for client.
you did look around and found this  http://www.multiintech.com/index.php?page=blogger  she likes purple....

  mark
Check ver. CMSMS, PHP, server OS, in System Information page.
Default content http://multiintech.com/defaultcontent/
People are Wonderful
Business is Great
Life is Terrific
Ever wonder what happened to the Album module? Well it is alive and well.
http://album.multiintech.com/
Image
Redguy
Forum Members
Forum Members
Posts: 44
Joined: Wed May 18, 2005 12:59 pm

Re: 0.13 Beta4 Released!

Post by Redguy »

how can I get rid of index.php in http://localhost/cmsms/index.php/submenu/something/ ?? and why isn't that the default?

and by the way, good stuff ;)
Ron@Spikecity

Re: 0.13 Beta4 Released!

Post by Ron@Spikecity »

I have one possible problem with the clean urls in 0.13b4.

All works OK (even without mod_rewrite and Apache but using a similar mechanism built into Sambar 6.4 all-in-one server, until you enter the admin center and try to edit a page.
Everything looks if it is loading OK, but instead of the content in the editor window I get a Page Not Found.

I've tried about every possible combination, with or without extention, with mod rewrite assumed true and false but the only option where it works both on the frontdoor and in the admin center is without the clean url option.
User avatar
Dr.CSS
Moderator
Moderator
Posts: 12675
Joined: Thu Mar 09, 2006 5:32 am
Location: Arizona

Re: 0.13 Beta4 Released!

Post by Dr.CSS »

redguy
i'm not sure how to do that...
i can't figure out why i get this.. http://www.multiintech.com/index.php?page=Round
instead of this... http://mit-computers.com/index.php/home  or this... http://mit-computers.com/index.php/navi ... us/navleft

both running... CMS Made Simple 0.13-beta4 "Canary"

mit-computers  fresh install other one is upgrade... would like to at least get rid of index.php?page=

    mark
Check ver. CMSMS, PHP, server OS, in System Information page.
Default content http://multiintech.com/defaultcontent/
People are Wonderful
Business is Great
Life is Terrific
Ever wonder what happened to the Album module? Well it is alive and well.
http://album.multiintech.com/
Image
User avatar
Elijah Lofgren
Power Poster
Power Poster
Posts: 811
Joined: Mon Apr 24, 2006 1:01 am
Location: Deatsville, AL

Re: 0.13 Beta4 Released!

Post by Elijah Lofgren »

Redguy wrote:how can I get rid of index.php in http://localhost/cmsms/index.php/submenu/something/ ?? and why isn't that the default?

See: http://wiki.cmsmadesimple.org/index.php ... And_Tricks for how to do it. It's not default because not every server has mod_rewrite installed or enabled.


You need to change this option in config.php to use index.php/Round instead of  index.php?page=Round.

Code: Select all

#If you don't use mod_rewrite, then would you like to use the built-in
#pretty url mechanism?  This will not work with IIS and the {metadata} tag
#should be in all of your templates before enabling.
$config['internal_pretty_urls'] = true;


And if you want to not have index.php in the URL at all see: http://wiki.cmsmadesimple.org/index.php ... And_Tricks
Note: I don't have time to take on any more projects. I'm quite busy. I may be too busy to reply to emails or messages. Thanks for your understanding. :)
Redguy
Forum Members
Forum Members
Posts: 44
Joined: Wed May 18, 2005 12:59 pm

Re: 0.13 Beta4 Released!

Post by Redguy »

Elijah Lofgren wrote:
Redguy wrote:how can I get rid of index.php in http://localhost/cmsms/index.php/submenu/something/ ?? and why isn't that the default?

See: http://wiki.cmsmadesimple.org/index.php ... And_Tricks for how to do it. It's not default because not every server has mod_rewrite installed or enabled.


Ok, thanks man :)
User avatar
Dr.CSS
Moderator
Moderator
Posts: 12675
Joined: Thu Mar 09, 2006 5:32 am
Location: Arizona

Re: 0.13 Beta4 Released!

Post by Dr.CSS »

Russ
i'm using the 'Comments' Module which has captcha already, i just haven't called it,and it has 'emailfield' and 'websitefield' if you leave an email add. when you leave a comment it makes your name the email link that is encrypt. so it can't be harvested for spam. a very nice module i must say.

    mark
Check ver. CMSMS, PHP, server OS, in System Information page.
Default content http://multiintech.com/defaultcontent/
People are Wonderful
Business is Great
Life is Terrific
Ever wonder what happened to the Album module? Well it is alive and well.
http://album.multiintech.com/
Image
Russ
Power Poster
Power Poster
Posts: 813
Joined: Fri Nov 25, 2005 5:02 pm
Location: North West England

Re: 0.13 Beta4 Released!

Post by Russ »

Thanks for the info Mark, I still havn't had chance to play with this (and I want to!) but I'm stuck with a steep learning curve for Qcodo (PHP MVC,) because a client wants some stuff yesterday - me - I can just about get the examples working - sigh... and all I want to do is play with this...

Russ
gogou

Re: 0.13 Beta4 Released!

Post by gogou »

Don't know why but using default css menu horiz 1c I got this error:

Not Found

The requested URL /cmsms/index.php/home was not found on this server.
Apache/2.0.46 (Red Hat) Server at www.ltas.ulg.ac.be Port 80

assuming home is my first page, this is working when making a simple link http://www.ltas.ulg.ac.be/cmsms/index.php?page=home
Why using the menu it is not working? Didn't have that problem on 0.12.2 (ps I cannot modify the config file of the server, it is a school server)

Except that, it is a fine release.
Ted
Power Poster
Power Poster
Posts: 3329
Joined: Fri Jun 11, 2004 6:58 pm
Location: Fairless Hills, Pa USA

Re: 0.13 Beta4 Released!

Post by Ted »

If you set the internal_pretty_urls option in config.php (in the CMSMS document root) to false, it should fix the url problem for you.
gogou

Re: 0.13 Beta4 Released!

Post by gogou »

Perfect, thanks a lot :)
User avatar
petert
Power Poster
Power Poster
Posts: 282
Joined: Wed Feb 09, 2005 9:30 pm
Location: behind my desk

Re: 0.13 Beta4 Released!

Post by petert »

news doesn't seem to work with 'use_hierarchy' turned on?
Mambo sucks, that's why I am here.
Now they call it Joomla, but it still sucks!

CMSMS rules!
Post Reply

Return to “Announcements”