[Solved]Nyhetsvisaren och å ä ö... problem i den nya versionen 1.5.4

Support och diskussion på svenska för CMS Made Simple.

Moderator: Coldman

Post Reply
Eva 33c
Forum Members
Forum Members
Posts: 18
Joined: Mon Dec 01, 2008 10:55 pm

[Solved]Nyhetsvisaren och å ä ö... problem i den nya versionen 1.5.4

Post by Eva 33c »

Idag började jag sätta upp en ny sida med CMSMS och då valde jag att använda den senaste versionen. Tidigare har jag använt 1.5.1 utan att följande problem uppstått.

Jag skrev en test artikel i Nyhetsvisaren, rubriken innehöll å och ä. Det ser helt OK ut tills jag klickar på "läs mer" taggen. När artikeln öppnas i helformat så ändras å och ä till "Ã¥" och "ä" men resten av texterna, både sammandraget och brödtexten är helt rätt.

Konstigt va? Är det nån som har en smart förklaring och en enkel lösning så vore jag tacksam. Det känns märkligt om jag inte ska kunna använda den senaste versionen pga detta.
Last edited by Eva 33c on Fri May 08, 2009 10:20 am, edited 1 time in total.
Coldman
Power Poster
Power Poster
Posts: 318
Joined: Sun Jun 22, 2008 5:33 am
Location: Sweden

Re: Nyhetsvisaren och å ä ö... problem i den nya versionen 1.5.4

Post by Coldman »

Hej Eva 33c!

Problemet kan vara inställningarna på din server.
Är det samma server som den förra sidan du gjorde med 1.5.1?

Det du kan prova är att ändra lite i config.php

Code: Select all

$config['locale'] = ''; 

till

Code: Select all

$config['locale'] = 'utf-8';


Samt hur ser dessa ut för dig?

Code: Select all

$config['default_encoding'] = '';
$config['admin_encoding'] = '';


Tillägg:
Såg i annan tråd från dig att du hade problem med CMSmailer och å,ä,ö
Löste du det? 


/Coldman
Last edited by Coldman on Thu May 07, 2009 9:18 pm, edited 1 time in total.
Important Code of Conduct
Why don't use CMSMS Docs or search?
Do you read Help?
Admin for Swedish Translations Team
Moderator Swedish Forum
After your problem is solved, push the green button
Eva 33c
Forum Members
Forum Members
Posts: 18
Joined: Mon Dec 01, 2008 10:55 pm

Re: Nyhetsvisaren och å ä ö... problem i den nya versionen 1.5.4

Post by Eva 33c »

Det är inte samma server som förut. Men detta problem hade jag inte där, fast då var det som sagt en äldre version av CMSMS och även Newsmodulen var en något tidigare version. Problemet med mailen löste jag aldrig, det var som sagt enbart texten i ämnesraden som blev fel. Inte innehållet.

Den server jag använder nu ska använda utf-8, och även databasen. det står utf-8 i min config-fil på de ställen du frågade efter. Utom efter

Code: Select all

$config['locale'] = ''; 
som är tomt och då ska ju serverns kodning väljas.

Det mystiska är ju att felet med å ä ö endast uppträder när jag väljer att följa länken i Nyhetsvisaren och då enbart i rubriken.
Kolla här http://www.s1072904.crystone.net/
I den gamla installationen funkar det dock:
http://cmsms.popcom.nu/
Coldman
Power Poster
Power Poster
Posts: 318
Joined: Sun Jun 22, 2008 5:33 am
Location: Sweden

Re: Nyhetsvisaren och å ä ö... problem i den nya versionen 1.5.4

Post by Coldman »

Hej igen..

Har ett förslag. Ändra denna del i DetailTemplate

Code: Select all

<h3 id="NewsPostDetailTitle">{$entry->title|escape:htmlall}</h3>

till

Code: Select all

<h3 id="NewsPostDetailTitle">{$entry->title|escape:html}</h3>


Skulle det inte fungera testa då denna.

Code: Select all

<h3 id="NewsPostDetailTitle">{$entry->title}</h3>



/Coldman
Important Code of Conduct
Why don't use CMSMS Docs or search?
Do you read Help?
Admin for Swedish Translations Team
Moderator Swedish Forum
After your problem is solved, push the green button
Eva 33c
Forum Members
Forum Members
Posts: 18
Joined: Mon Dec 01, 2008 10:55 pm

Re: Nyhetsvisaren och å ä ö... problem i den nya versionen 1.5.4

Post by Eva 33c »

Det ska jag testa!
Jag var och kikade på just den där raden förut  och såg att det stod olika i de olika versionerna av Newsmodulen jag har.
Återkommer om hur det gick...
Eva 33c
Forum Members
Forum Members
Posts: 18
Joined: Mon Dec 01, 2008 10:55 pm

Re: Nyhetsvisaren och å ä ö... problem i den nya versionen 1.5.4

Post by Eva 33c »

Hurra!
Det funkade, jag använde det sista alternativet, så såg det ut i den äldre versionen av Newsmodulen.
Tack för hjälpen  :D
Post Reply

Return to “Swedish - Svenska”