• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Bug in Newsletter Made Simple?
PostPosted: Sat Nov 09, 2019 6:29 am 
Offline
Forum Members
Forum Members

Joined: Sun Oct 28, 2007 4:14 am
Posts: 216
Location: Australia
I cannot see address lists in NMS, or users, despite their being present in the database tables. It's a pest. I have tried uninstalling and removing the module and then reinstalling and importing the users etc.

I have also gone back a couple of versions of NMS. Same problem.

Today I used softaculous to set up a dummy installation of CMS Made Simple, upgraded the only module needing it (News) and then installed NMS. I entered a list. The admin page showed no lists.

I added a user to the list. I could see the list in the drop down box you use to add a user to a list. But the user is not visible.

I can see the user and the list using phpMyadmin.

I'm calling this a bug. It suggests to me that something in the Core Install is preventing NMS from displaying its admin pages correctly.

Andrew

----------------------------------------------

Cms Version: 2.2.12

Installed Modules:

AdminSearch: 1.0.4
CGExtensions: 1.64.10
CGSimpleSmarty: 2.2.1
CMSContentManager: 1.1.8
CmsJobManager: 0.1.3
DesignManager: 1.1.6
FileManager: 1.6.9.1
FilePicker: 1.0.4.1
MenuManager: 1.50.3
MicroTiny: 2.2.4
ModuleManager: 2.1.7
NMS: 2.13.3
Navigator: 1.0.9
News: 2.51.7
Search: 1.51.7

Config Information:

php_memory_limit:
max_upload_size: 2000000
url_rewriting: none
page_extension:
query_var: page
auto_alias_content: true
locale:
set_names: true
timezone: America/New_York
permissive_smarty: false

Php Information:

phpversion: 7.3.11
md5_function: On (True)
json_function: On (True)
gd_version: 2
tempnam_function: On (True)
magic_quotes_runtime: Off (False)
E_ALL: 32767
E_STRICT: 2048
E_DEPRECATED: 8192
test_file_timedifference: No time difference found
test_db_timedifference: No time difference found
create_dir_and_file: 1
memory_limit: 128M
max_execution_time: 30
register_globals: Off (False)
output_buffering: 4096
disable_functions: show_source, system, shell_exec, passthru, exec, popen, proc_open
open_basedir:
test_remote_url: Success
file_uploads: On (True)
post_max_size: 8M
upload_max_filesize: 2M
session_save_path: /opt/alt/php73/var/lib/php/session (0700)
session_use_cookies: On (True)
xml_function: On (True)
xmlreader_class: On (True)
check_ini_set: On (True)
curl: On

Performance Information:

allow_browser_cache: On (True)
browser_cache_expiry: 60
php_opcache: Off (False)
smarty_cache: Off (False)
smarty_compilecheck: Off (False)
auto_clear_cache_age: On (True)
Server Information:

Server Software: Apache
Server Api: cgi-fcgi
Server Os: Linux 3.10.0-962.3.2.lve1.5.26.5.el7.x86_64 On x86_64
Server Db Type: MySQL (mysqli)
Server Db Version: 5.7.28
Server Db Grants: Found a "GRANT ALL" statement that appears to be suitable

Permission Information:

tmp: /home/mansweb/public_html/crazy/tmp (0755)
tmp_cache: /home/mansweb/public_html/crazy/tmp/cache (0755)
templates_c: /home/mansweb/public_html/crazy/tmp/templates_c (0755)
modules: /home/mansweb/public_html/crazy/modules (0755)
uploads: /home/mansweb/public_html/crazy/uploads (0755)
File Creation Mask (umask): /home/mansweb/public_html/crazy/tmp/cache (0755)
config_file: 0644
----------------------------------------------


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Bug [NOT A BUG] in Newsletter Made Simple?
PostPosted: Tue Nov 12, 2019 10:28 pm 
Offline
Forum Members
Forum Members

Joined: Sun Oct 28, 2007 4:14 am
Posts: 216
Location: Australia
So I installed NMS in another site on another server-- same company, exactly the same server config. It works fine.

So a clean softaculous install, and my years old website are both killing the viewing of address lists and users. It sounds like something on my server... :(


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Bug in Newsletter Made Simple?
PostPosted: Wed Nov 13, 2019 12:51 am 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 845
Location: Victoria, BC
If there's nothing in the error log, I would suggest finding out if mod_security is on your server. It doesn't seem typical of the issues caused by mod_security, but it's something to rule out anyway.

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Hosting Nation - Managed CMSMS Hosting