• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 6 posts ] 
Author Message
 Post subject: Error message when submitting content page
PostPosted: Fri Nov 01, 2019 7:53 pm 
Offline
Forum Members
Forum Members

Joined: Tue Sep 08, 2015 10:41 am
Posts: 122
I am getting this error message when submitting a content page with unicode characters.

\$1:
ERROR: Incorrect string value: '\xE2\x86\x90' for column `m_main`.`cms_module_search_index`.`word` at row 1

This "incorrect" string value is a unicode left arrow. Uninstalling the core Search module makes the error go away, but I wish to use search.

CMSMS is latest version. Any ideas?


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Error message when submitting content page
PostPosted: Fri Nov 01, 2019 8:29 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 847
Location: Victoria, BC
I wasn't able to recreate this, so I'm going to guess it's unique to your configuration rather than a bug. Is everything in your setup set to be utf-8, or anything unusual in your config?

Does it make a difference if you're using a wysiwyg to add the content? Do all symbols do it or just this one?

If you can make it happen on a clean install, perhaps provide the exact steps for other people to recreate it.

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Error message when submitting content page
PostPosted: Fri Nov 01, 2019 8:36 pm 
Offline
Forum Members
Forum Members

Joined: Tue Sep 08, 2015 10:41 am
Posts: 122
The server is setting utf-8 in the content header. Nothing unusual in my setup that I'm aware of.

I disabled WYSIWYG on the page and it still occurs.

It appears to be all unicode characters generating it. If I delete ← from the content, some Japanese symbols later in the page trigger the error. After I delete the last Unicode character, the error disappears.

Interestingly, despite the error, the changed content does submit ok, even though the user sees just a white page with the error message.

I'll try pasting the content into a fresh install.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Error message when submitting content page
PostPosted: Fri Nov 01, 2019 8:52 pm 
Offline
Forum Members
Forum Members

Joined: Tue Sep 08, 2015 10:41 am
Posts: 122
Pasting identical content into a clean install does not produce the error.

Any ideas on how I can fix my existing installation?


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Error message when submitting content page  Topic is solved
PostPosted: Fri Nov 01, 2019 9:10 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 847
Location: Victoria, BC
Probably need to start checking the database encoding and other things, see if you can find any difference between the site and the clean install.

Also perhaps check the config file to see if a default encoding is set (or try setting one): https://docs.cmsmadesimple.org/configur ... t_encoding

Other than that I'm not sure, but it's not anything I've had to deal with before. Someone else might have more insight.

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Error message when submitting content page
PostPosted: Fri Nov 01, 2019 9:34 pm 
Offline
Forum Members
Forum Members

Joined: Tue Sep 08, 2015 10:41 am
Posts: 122
Some of the structure on my database (which was initialised many versions ago) was different to the fresh install.

I changed the table from InnoDB to MyISAM and created a new index, but I think what fixed it is switching the collation from latin1_swedish_ci to utf8_general_ci. Curious as to why I only saw an error now and not before.

Many thanks for setting me on the right path!


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Hosting Nation - Managed CMSMS Hosting