• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 6 posts ] 
Author Message
 Post subject: Module installable that is only supported up to 1.9.9
PostPosted: Fri Sep 30, 2011 1:57 pm 
Offline
Power Poster
Power Poster
User avatar

Joined: Fri Jun 08, 2007 7:29 pm
Posts: 889
Location: 's-Hertogenbosch, Netherlands
Hi,

I've tried to install one of my modules (DTInventory) using Module Manager.
I know that the version available from the forge is not updated to the latest CMSMS vs 1.10...
Installing is done without a problem and in the modules overview, it is clearly stated that the module is only supported up until 1.9.9.
The module is available via eCommerce menu option.
I thought that once the maximum supported version is set to something installation is not possible.
Does this have to do that 1.9.9 is greater than 1.10-beta3 (at least for the server)?
If so, doesn't this give a problem with all modules that have a maximum support set to at lease 1.1...?

Duketown

PS. MinimumCMSVersion() returns 1.8 for this module.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Module installable that is only supported up to 1.9.9
PostPosted: Fri Sep 30, 2011 2:11 pm 
Offline
Support Guru
Support Guru
User avatar

Joined: Wed Sep 05, 2007 8:03 pm
Posts: 4000
Location: The Netherlands
In the updated Module API Docs I read:

Quote:
MaximumCMSVersion (line 417)
Returns the maximum version necessary to run this version of the module.

deprecated:
abstract:
string MaximumCMSVersion ()


http://www.cmsmadesimple.org/apidoc_1.10/

Maybe that has something to do with your "issue"

I never use MaximumCMSVersion in modules. Raises more questions is the forum then it prevents?

_________________


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Module installable that is only supported up to 1.9.9
PostPosted: Fri Sep 30, 2011 2:28 pm 
Offline
Power Poster
Power Poster
User avatar

Joined: Fri Jun 08, 2007 7:29 pm
Posts: 889
Location: 's-Hertogenbosch, Netherlands
Jos,

Thanks for the reply.
Since retrieval of data and checking if module has been installed is handled differently, I need to check which version is running. In other words on purpose I'm using both MinimumCMSVersion() as well as MaximumCMSVersion() to return 1.8 resp. 1.9.9
At this moment the module has been installed, but is not performing as it should (due to the checking of another module installation which is in my case if ShopMadeSimple is installed).

So there must be something else.

Duketown


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Module installable that is only supported up to 1.9.9
PostPosted: Fri Sep 30, 2011 3:07 pm 
Offline
Power Poster
Power Poster
User avatar

Joined: Fri Jun 08, 2007 7:29 pm
Posts: 889
Location: 's-Hertogenbosch, Netherlands
Continuing on this minimum and maximum version setting I can even imagine that a version of a module prepared by me with 1.10-beta2 as minimum could be installed using module manager in a CMSMS version 1.9.4.3 environment. This could cause problems as well I think.

Were do I make a thinking mistake?

Duketown


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Module installable that is only supported up to 1.9.9
PostPosted: Tue Oct 04, 2011 4:34 am 
Offline
Power Poster
Power Poster
User avatar

Joined: Fri Jun 08, 2007 7:29 pm
Posts: 889
Location: 's-Hertogenbosch, Netherlands
Really like to know if I'm mistaken here.
When is it best to release 1.10 based modules?

Duketown


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Module installable that is only supported up to 1.9.9
PostPosted: Thu Oct 06, 2011 2:55 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Tue Oct 19, 2004 6:44 pm
Posts: 7955
Location: Fernie British Columbia, Canada
something with a Minumum version number of 1.10-beta2 should not be allowed to be installed from ModuleManager from CMSMS 1.9.x ... but I am also aware that the ModuleManager does not check MaximumCMSVersion (that data isn't even in the xml file).

So there isn't much you can do.

However, there is no reason you can't set a minimum version of 1.9.x for your module and have the same code work with 1.9.x and 1.10.x ... at least for a while, till most people are on 1.10.x

_________________
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
A2 Hosting