in Formbuilder funktionieert een berekend veld niet meer

Nederlandse ondersteuning voor CMS Made Simple

Moderator: velden

Post Reply
janvl
Power Poster
Power Poster
Posts: 953
Joined: Wed Aug 13, 2008 10:57 am

in Formbuilder funktionieert een berekend veld niet meer

Post by janvl »

Hallo,

is had een kontrole voor het bestaan van MX-records in een formulier eingebouwd.

Nu heb ik een Site gekopieerd en een update op 2.2.20 gegeven.

In een berekend veld heb ik als PHP-Kode:
checkdnsrr("$fld_73.'.'.$fld_74","MX")

de velden 73 en 74 vormen samen de domain waarbei 74 de tld is.

Na enig zoekwerk heb ik een simpel php-scriptje geschreven en dat werkt wel.

De PHP foutmelding is:
[Sun May 19 16:30:53.516066 2024] [proxy_fcgi:error] [pid 989647:tid 139769389495872] [remote 213.162.68.235:36702] AH01071: Got error 'PHP message: PHP Fatal error: Uncaught Error: Undefined constant "opopopop" in /var/www/clients/client3/web82/web/modules/FormBuilder/classes/ComputedField.class.php(113) : eval()'d code:1\nStack trace:\n#0 /var/www/clients/client3/web82/web/modules/FormBuilder/classes/ComputedField.class.php(113): eval()\n#1 /var/www/clients/client3/web82/web/modules/FormBuilder/classes/Form.class.php(738): fbComputedField->Compute()\n#2 /var/www/clients/client3/web82/web/modules/FormBuilder/action.default.php(150): fbForm->Dispose()\n#3 /var/www/clients/client3/web82/web/lib/classes/class.CMSModule.php(1407): include('...')\n#4 /var/www/clients/client3/web82/web/modules/FormBuilder/FormBuilder.module.php(194): CMSModule->DoAction()\n#5 /var/www/clients/client3/web82/web/lib/classes/class.CMSModule.php(1483): FormBuilder->DoAction()\n#6 /var/www/clients/client3/web82/web/lib/functions/page.functions.php(551): CMSModule->DoActionBase()\n#7 /var/www/clients/client3/web82/web/index.php(156): preprocess_mact()\n#8 {main}\n th...', referer: https://******.top/index.php?page=test

Ik krijg steeds een wit scherm (php-fout).
Wat kan de oorzaak zijn en is er een workaround om in de formbuilder te krijgen of er MX-records zijn?

Mvg
Jan
janvl
Power Poster
Power Poster
Posts: 953
Joined: Wed Aug 13, 2008 10:57 am

Re: in Formbuilder funktionieert een berekend veld niet meer [opgelost]

Post by janvl »

Was een probleem met de quotes

eerst domain als berekend veld (fld_92):
'$fld_90'.".".'$fld_91'
dan zo kontroleren of de domain bestaat
checkdnsrr('$fld_92',"MX")

Nu werkt het.

Mvg
Jan
Post Reply

Return to “Dutch - Nederlands”