• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 
Author Message
 Post subject: [fixed] Some external modules do not work after the update
PostPosted: Sun Apr 02, 2017 5:43 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Sun Apr 02, 2017 10:00 am
Posts: 24
After the update of CMS 2.1.6 to 2.2 beta2 not work some installed modules:
MultiDomain module:
Fatal error: Call to undefined method CMSMS\Database\mysqli\Connection::GetAssoc() in /var/www/ksb/modules/MultiDomains/MultiDomains.module.php on line 688

CGActionBar module:
Notice: Undefined index: cms_admin_username in /var/www/ksb/modules/CGActionBar/CGActionBar.module.php on line 160

FAQ module:
Fatal error: Call to undefined method CMSMS\Database\mysqli\Connection::Qmagic() in /var/www/ksb/modules/FAQ/lib/class.FAQ_utils.php on line 138


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Some external modules do not work after the update
PostPosted: Sun Apr 02, 2017 7:20 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Tue Oct 19, 2004 6:44 pm
Posts: 7795
Location: Fernie British Columbia, Canada
I've fixed the issue in the database abstraction library with the obscure missing methods.

And fixed the issue in CGActionBar where I was using a session property that I should not have been. There is an API function to handle that.

Thanks

_________________
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: [fixed] Some external modules do not work after the upda
PostPosted: Mon Apr 03, 2017 7:05 am 
Offline
Forum Members
Forum Members
User avatar

Joined: Sun Apr 02, 2017 10:00 am
Posts: 24
Well done. Where I can download the corrected code?
Thank you very much.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: [fixed] Some external modules do not work after the upda
PostPosted: Mon Apr 03, 2017 9:11 am 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7223
Location: The Netherlands
esmiran wrote:
Well done. Where I can download the corrected code?
Thank you very much.
Will be available in the next beta release to test.

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return! [ Click here ]



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
A2 Hosting