Page 1 of 1

Simplex Graphics Corrupt Under https

Posted: Sun Sep 12, 2021 10:08 pm
by NorfolkGreg

Newbie here! I've just reinstalled CMSMS. via Softaculous. I am not a "professional coder" but a long term hobbyist. My only qualification being a "Data Processing" module taken as part of a day release Business Studies course in 1978-80 when in my early thirties. However, I am competent with HTML and CSS, but not PHP, JavaScript, or any other modern stuff, but I did used to be a competent Z80 assembly coder, and once produced an almost compete disassembly of an integer-only BASIC compiler the UK Sharp User Club had obtained from Japan.

The reason for investigation CMSMS is because I'm resigning as "technical support" guy for the professional association of my wife, as she retires from the group and they need something to replace my hand coded web site, so that can one of their very non-technical members can use a WYSIWYG interface for editing pages and and news one to a revised version of their site I want to leave them with.

With that bvackground, on to the problem...

Initially I thought I had some problems with Windows after suffering a power cut that caused it to choke, and produce weird error screens that I have never encountered before. However, it did eventually sorted it self out and appeared to be running OK until I installed CMSMS.

The symptoms were that the default Simplex home screen showed most of the graphics (search box magnifying glass, go to top arrowhead and spinning social media icons) as boxes with, in some browsers, hex numbers within.

Checking on Android devices, and a Windows laptop, using different browsers, things seemed to be OK. So assuming it was my desktop Windows installation that had become corrupted I even tried using a Windows restore point (for the first time in about 20 years) to see if that would fix it. It didn't!

Then I tried the reinstall of CMSMS, again on my desktop via Softaculous, as my host offers it as a way for providing a "one-click install" for many applications. It then seemed that the desktop was OK but the other devices showed the problem. At least that's what I thought initially. Now I realise that it depends how I entered the address of the site in my browsers. I can reproduce the error repeatedly on all my devices.

It seems that the graphics display properly if I use allow the browser to add the http and just type the domain and path to CMSMS. They graphics fail fail to display if I use add the https:// as I type it in the address bar. (In setting the options in Softaculous for the installation I requested the installation be with https.)

I couldn't find any reference to this issue on the forum. Can anyone else reproduce it? Could it be that the Softaculous installer is set up incorrectly for CMSMS. Any thoughts/ideas welcome! (I haven't yet tried a manual install of CMSMS.)

Re: Simplex Graphics Corrupt Under https

Posted: Mon Sep 13, 2021 1:49 pm
by DIGI3
What you're describing is called mixed content, it means some things on your page are served with http: urls which is not allowed when viewing a secure page (https).

Start with the config.php file and make sure everything is set correctly. Then check your .htaccess. Finally, check the page templates to make sure nothing is hard-coded with http. Clear the cmsms cache after any fixes and check again. Your browser console (F12) will give you more clues into any issues.

This isn't technically a cmsms issue, it's standard webdev stuff but became a lot more important in the past few years as browsers started blocking mixed-content.

Re: Simplex Graphics Corrupt Under https

Posted: Mon Sep 13, 2021 5:35 pm
by NorfolkGreg
Thanks DIGI3,

That makes it sound as if Softaculous is not taking account of all that it should in the case of CMSMS. I'll follow it up with them. They've proved very responsive and sorted out problems that I encountered with other installations in the past. Their service is meant to provide a one-click install. It defeats the service's objective if it doesn't handle a CMSMS default install.

In the mean time I'll take a look at the config.php and .htaccess files and see if I can sort the issue myself.

Re: Simplex Graphics Corrupt Under https

Posted: Tue Sep 14, 2021 9:30 am
by NorfolkGreg
It would seem that installing via Softaculous may cause a number of issues, this one included.

For example, I see my config.php file includes:

Code: Select all

$config['timezone'] = 'America/New_York';
Having just downloaded the official CMSMS install file and read the README I was surprised by that line. I had understood that my host's servers were UK based. I have raised a ticket with them to get confirmation that I have the correct setting.

I recognise that the supplied templates are not supposed to be production ready, but I remain surprised that a fresh install of CMSMS with the default theme does not run without issues under both http and https.

Obviously, it could be that installation via Softaculous fails to offer some of the necessary options that I see from the README I should be offered to get things to run correctly (such as timezone setting). In that case I do need to take up the issue with them.

But before I do that I need confirmation that:
1. Simplex does contain "mixed content", which you suggest is the reason for the issue
2. If I enter appropriate options when using using "cmsms-2.2.15-install.php" the Simplex theme will run without the problem I encounter.

In other words, if I remove my current installation and start again using the official install process and entering optimal settings would I still need either to remove the mixed content or need to make further edits to the CMSMS configuration or the theme for it to run without issues under both http and https?

Re: Simplex Graphics Corrupt Under https

Posted: Tue Sep 14, 2021 3:10 pm
by DIGI3
The Simplex theme doesn't contain any mixed content, and it shouldn't matter whether it's installed via the installer or softalicous. I wasn't able to test the softalicious install though as it's currently not working on my host.

You don't need to contact support to find your server's timezone, just create a phpinfo file, view it, and ctrl-f to find the timezone (this isn't necessarily where your server is physically located). You can Google how to easily create a phpinfo file.

Are you able to share the url of the install with the mixed content issue? My instinct says it's not softalicious or the theme, but a simple configuration issue. It's hard to tell working blind though. At the very least, share the console content - copy and paste or screenshot.

Re: Simplex Graphics Corrupt Under https

Posted: Tue Sep 14, 2021 4:11 pm
by NorfolkGreg

Thanks for the response! My installation is at

It's as installed via Softaculous at my host plus I've entered and successfully tested the EMail settings on the Admin Global Settings page and edited the config.php to:
$config['timezone'] = 'Europe/London';
rather than
$config['timezone'] = 'America/New_York';
that my host says is wrong.

The System Info screen shows green ticks everywhere except:
Enable Smarty Caching
Is E_STRICT disabled in error_reporting (E_STRICT)
Is E_DEPRECATED disabled in error_reporting (E_DEPRECATED)
disable_functions in PHP (disable_functions)

Re: Simplex Graphics Corrupt Under https

Posted: Tue Sep 14, 2021 5:23 pm
by DIGI3
It turns out my original thought about the fonts was correct, you have a security policy blocking it. This is likely in an .htaccess file, possibly in a higher level directory (they cascade). It's super-important to check the console when troubleshooting:

Code: Select all

Access to font at '' from origin '' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.
simplex.woff:1 Failed to load resource: net::ERR_FAILED Access to font at '' from origin '' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.
simplex.ttf:1 Failed to load resource: net::ERR_FAILED
There's no mixed content, the install is fine and there's no issue with softalicous. This is specifically a security policy you have.

Re: Simplex Graphics Corrupt Under https

Posted: Thu Sep 16, 2021 9:55 am
by NorfolkGreg
My Host suggested this as a solution and it seems to have done the job.
Can you try the .htaccess code as mentioned here: ... cess-cont/

The code is:

<IfModule mod_headers.c>
<FilesMatch "\.(ttf|ttc|otf|eot|woff|woff2|font.css|css|js)$">
Header set Access-Control-Allow-Origin "*"

Although in that case it is WordPress the issue looks very similar.