Filemanager: No uploads and no thumbs

For questions and problems with the CMS core. This board is NOT for any 3rd party modules, addons, PHP scripts or anything NOT distributed with the CMS made simple package itself.
Post Reply
antibart
Power Poster
Power Poster
Posts: 1128
Joined: Sun Aug 17, 2008 9:29 am

Filemanager: No uploads and no thumbs

Post by antibart »

Hi,

I notice some strange behavior in the file manager on cmsms 2.2.14.

1. It IS possible to upload images via TinyMCE.
2. It is NOT possible to upload images with the file manager directly. I can see the status bar processing. But finally there is no image.
3. No thumbs created at all. Even when I try to create a thumb manually I get an error report as "Problem by creating a thumbnail".

What I tried:
1. Changing unmask from 022 to 002
2. Refreshing the cmsms installationen
3. Different versions of of PHP 7.x.
4. Confirmed "create thumbnails" in the file manager settings

Hoster: all-inkl.com
Modules: All core modules, no third party modules.
User avatar
velden
Dev Team Member
Dev Team Member
Posts: 3305
Joined: Mon Nov 28, 2011 9:29 am
Location: The Netherlands

Re: Filemanager: No uploads and no thumbs

Post by velden »

I would check the browser's DevTools for errors (both Console and Network tab)

If you have access to the web server (error) logs that could give hints too.

Further, sometimes if you set debug mode on in config.php additional error messages are displayed. This also depends on server configuration.
https://docs.cmsmadesimple.org/configur ... nfig_debug

I checked my test-install and file upload and thumbnail creation works for me.
antibart
Power Poster
Power Poster
Posts: 1128
Joined: Sun Aug 17, 2008 9:29 am

Re: Filemanager: No uploads and no thumbs

Post by antibart »

Thank you, velden...

I have a trace.

I think it's struggling with the correct image type.

All images are downloaded from a wordpress blog - hosted on wordpress. And they appear as jpgs when downloading like image1.jpg. But WP does any webp-converting with the images - but you do not see it.

When I look on the MIME-Type-column in the file manager I read "image/webp" but it should be image/jpeg.

When I now use the debug mode I get a notice: Undefined offset: 18 in /www/.../modules/FileManager/fileinfo.php on line 96

Line 96 is:

Code: Select all

// Make 'type' usefull.
       $data['type'] = $types[$data['type']];
So: All image have a wrong file extension. They appear to be jpegs but they are webp. So have to convert these tons of images I donwloaded.
User avatar
velden
Dev Team Member
Dev Team Member
Posts: 3305
Joined: Mon Nov 28, 2011 9:29 am
Location: The Netherlands

Re: Filemanager: No uploads and no thumbs

Post by velden »

It appears CMSMS does not support WebP yet for thumbnails.
It seems possible though to upload .webp files (even if they have a .jpeg file extension).
antibart
Power Poster
Power Poster
Posts: 1128
Joined: Sun Aug 17, 2008 9:29 am

Re: Filemanager: No uploads and no thumbs

Post by antibart »

velden wrote: It seems possible though to upload .webp files (even if they have a .jpeg file extension).
Not in the filmanager itself. Only via tinyMCE.
User avatar
velden
Dev Team Member
Dev Team Member
Posts: 3305
Joined: Mon Nov 28, 2011 9:29 am
Location: The Netherlands

Re: Filemanager: No uploads and no thumbs

Post by velden »

I tried in File Manager, upload button as well as dropzone.
Both work.

Downloaded sample image from https://developers.google.com/speed/webp/gallery1
antibart
Power Poster
Power Poster
Posts: 1128
Joined: Sun Aug 17, 2008 9:29 am

Re: Filemanager: No uploads and no thumbs

Post by antibart »

I think it's because my images are saved as jpg without being jpg - because firefox does not support webp. That is why I did not noticed it.
User avatar
Dr.CSS
Moderator
Moderator
Posts: 12678
Joined: Thu Mar 09, 2006 5:32 am
Location: Arizona

Re: Filemanager: No uploads and no thumbs

Post by Dr.CSS »

I've had the same problem with a WP site, I just load them in paint.NET and convert to jpeg, no problem...
Check ver. CMSMS, PHP, server OS, in System Information page.
Default content http://multiintech.com/defaultcontent/
People are Wonderful
Business is Great
Life is Terrific
Ever wonder what happened to the Album module? Well it is alive and well.
http://album.multiintech.com/
Image
antibart
Power Poster
Power Poster
Posts: 1128
Joined: Sun Aug 17, 2008 9:29 am

Re: Filemanager: No uploads and no thumbs

Post by antibart »

Dr.CSS wrote:I've had the same problem with a WP site, I just load them in paint.NET and convert to jpeg, no problem...
I have hundreds of pics, converted them with the batch mode in irfan view. Which works good and fast - but a lot of pics look destroyed after uploading on the server.

But this is at least not a problem of cmsms. I have to check the converting configuration.
Post Reply

Return to “CMSMS Core”