metadata tag showbase parameter not working

For questions and problems with the CMS core. This board is NOT for any 3rd party modules, addons, PHP scripts or anything NOT distributed with the CMS made simple package itself.
Post Reply
cjcollen
Forum Members
Forum Members
Posts: 36
Joined: Sat Aug 04, 2018 4:20 pm
Location: Shropshire, UK

metadata tag showbase parameter not working

Post by cjcollen »

I am trying to work out how to suppress the <base> tag.

I found the showbase parameter for the metadata tag but it does not work.

If I put in {metadata showbase=false} then the base tag shows as well as the other meta tags.

If I put in {metadata showbase=true} then the base tag disappears but so do all the other meta tags.

My other meta tags are in Core::Generic templates and so I have the {global_content} tags in the meta data field on each of the pages as well as the Global Settings meta field.
So, when I use {metadata showbase=true}, the global content tags are displayed instead.

I also tried to suppress the base tag by using the $config setting but that did not suppress the base tag even though I cleared CMSMS cache and browser cache.

Very strange indeed. Any ideas?
User avatar
velden
Dev Team Member
Dev Team Member
Posts: 3321
Joined: Mon Nov 28, 2011 9:29 am
Location: The Netherlands

Re: metadata tag showbase parameter not working

Post by velden »

Yeah, it seems it's implemented in a bad way.
You have to give the STRING value 'false'.

Code: Select all

{metadata showbase='false'}
BR: http://dev.cmsmadesimple.org/bug/view/12292
cjcollen
Forum Members
Forum Members
Posts: 36
Joined: Sat Aug 04, 2018 4:20 pm
Location: Shropshire, UK

Re: metadata tag showbase parameter not working

Post by cjcollen »

OK Velden. Thanks for response. But it does not solve my problem about not showing my meta tags that are stored in a generic template.

So, in my master page layout template I have put
{metadata showbase='false'}

In my content page, the page specific metadata field on Logic tab has this Core::Generic template

{global_content name='generic-meta-page'}

This contains my meta tags.

So with the showbase='false', CMSMS does not evaluate the global_content tag but just puts that tag out at top of page. But at least the base tag is not shown

I cannot really see in the metadata plugin code how it is bypassing evaluation.

So, still no further forward on this.
Post Reply

Return to “CMSMS Core”