CMS Made Simple Forums
https://forum.cmsmadesimple.org/

Validating new site reports missing files
https://forum.cmsmadesimple.org/viewtopic.php?f=8&t=81771
Page 1 of 1

Author:  markS [ Wed Nov 20, 2019 11:06 am ]
Post subject:  Validating new site reports missing files

Hello,

I have been updating a few sites to the latest version 2.2.12 and I have an issue with one that has errors when updated.

In order to debug the issue I installed an entirely clean version of 2.2.12 and then ran the validation against the checksum file. It reported 486 missing files from the clean install, mostly language files by the looks of it, but this can't be right, can it?

Report of missing files is attached.

BTW: tried this with the PHAR and expanded installers with same results.

Thanks for any info you can provide.

Mark.

Attachments:
File comment: Missing files cmsms 2.2.12
cmsms2.2.12-missing-files.txt [17.03 KiB]
Downloaded 53 times

Author:  DIGI3 [ Wed Nov 20, 2019 3:56 pm ]
Post subject:  Re: Validating new site reports missing files

I can verify that there's an issue with the checksum file - if you look more closely, only the language files are reported as missing (this is normal), the rest are checksum fails.

I've brought it up with the team. For the meantime, it's always a good idea to generate your own checksum after install/upgrade and after each major change anyway.

Author:  DIGI3 [ Fri Nov 22, 2019 4:46 pm ]
Post subject:  Re: Validating new site reports missing files

It turns out the problem was on my end in this case. The checksum uses /index.php and /lib/version.php to create the salt, and I had an older version.php file due to some previous testing. On a clean install everything works fine for me.

That said, 486 missing language files is exactly correct if you only installed English. If you scroll down and see that there's also some failed checksums then that could indicate a different issue.

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/