CMS Made Simple Forums
https://forum.cmsmadesimple.org/

cmsms core install ok but website result not expected
https://forum.cmsmadesimple.org/viewtopic.php?f=8&t=80815
Page 1 of 1

Author:  dahlgrjp [ Wed May 08, 2019 7:40 pm ]
Post subject:  cmsms core install ok but website result not expected

I have installed cmsms 2.2.10 twice with same result.
Install Assistant appears to have completed normally without error,

but when I select the link "visit your website" I get an unexpected result. see attached website.png.
Attachment:
website.png
website.png [ 66.31 KiB | Viewed 279 times ]


Similar results when I visit the link "login to the CMSMS admin panel."
Attachment:
cmsms_admin.png
cmsms_admin.png [ 62 KiB | Viewed 279 times ]


Where has my install gone wrong?

I installed cmsms in localhost
/home/dahlgrjp/lampstack-7.1.29-0/apache2/htdocs/CMSMS2

Install details:
OS: Linux mint 18.2
Bitnami Lampstack 7.1.29-0
Apache 2.4.39
MySQL 5.7.26
PHP 7.1.29

Author:  DIGI3 [ Wed May 08, 2019 8:12 pm ]
Post subject:  Re: cmsms core install ok but website result not expected

Check the javascript console, see why it can't load the css. Perhaps a certificate/mixed content issue?

Author:  dahlgrjp [ Sat May 11, 2019 8:47 pm ]
Post subject:  Re: cmsms core install ok but website result not expected

I checked the javascript browser and found no error that appear to be related to loading a .cwebss. In fact, when I look at the index.php and the admin/login.php files, there are no references to a .css. Also, after the install, the /assests/css directory is empty, along with all other /asset subdirectories.

Another issue I do see after the install to my localhost website is that all urls do not include the 8080 port (localhost:8080). As a result, there are many javascript loading failed errors. the 8080 port must be manually entered for these scripts to be found.

By the way, I deleted and installed cmsms from scratch a fourth time with these same results.

Pete

Author:  DIGI3 [ Sun May 12, 2019 2:57 am ]
Post subject:  Re: cmsms core install ok but website result not expected

There won't be css files there, they are dynamically generated and loaded from the tmp/cache directory.

I'm guessing the issue is using port 8080, you may want to search the forum for similar concerns.

Author:  MantaPro [ Mon May 13, 2019 11:40 pm ]
Post subject:  Re: cmsms core install ok but website result not expected

Check your config.php file - I suggest you try adding a line like this if there is not one already
Code:
$config['root_url'] = 'http://localhost:8080';

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/