• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 14 posts ] 
Author Message
 Post subject: Problems using module manager after core upgrade
PostPosted: Thu Jan 31, 2019 2:52 pm 
Offline
Forum Members
Forum Members

Joined: Thu Oct 15, 2009 11:11 am
Posts: 169
Hi :-

I just upgraded the core from 2.2.5 > 2.2.9

I went to upgrade the individual modules and I get "The CMSMS core must be upgraded before this operation can succeed"

I cleared the cache

Same thing happened

I rolled back the core upgrade and did an incremental upgrade

Upgraded from 2.2.5 > 2.2.6

Same problem with the module manager

I have run out of ideas

Has anyone experienced this ?


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Problems using module manager after core upgrade
PostPosted: Thu Jan 31, 2019 3:09 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 810
Location: Victoria, BC
Was this originally a 1.x site? I've had something similar happen in the past and it turned out to be an old version.php file lingering around.

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Problems using module manager after core upgrade
PostPosted: Thu Jan 31, 2019 3:52 pm 
Offline
Forum Members
Forum Members

Joined: Thu Oct 15, 2009 11:11 am
Posts: 169
I can't see one.
Would it be in the top level directory ?


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Problems using module manager after core upgrade
PostPosted: Thu Jan 31, 2019 3:55 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 810
Location: Victoria, BC
I think so, but you may want to scan for it.

Are all modules, including core, saying they need to be upgraded? Or just some third-party ones? If it's the former, it means the upgrade didn't complete properly for some reason - possibly a bad third party module. If it's the latter, try deleting the moduleinfo.ini file in each module's folder.

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Problems using module manager after core upgrade
PostPosted: Thu Jan 31, 2019 4:06 pm 
Offline
Forum Members
Forum Members

Joined: Thu Oct 15, 2009 11:11 am
Posts: 169
Hi :-
Thanks for getting back to me.

No, it is ALL modules.

I tried upgrading stuff like CGExtensions first, stuff that everything else depends upon, but it didn't work.

FYI, They are ALL CG Modules apart from Gallery, but they all give the same error message when I try and upgrade

I think the Core upgrade was OK. I used the checksum and the only things missing was language files.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Problems using module manager after core upgrade
PostPosted: Thu Jan 31, 2019 4:08 pm 
Offline
Forum Members
Forum Members

Joined: Thu Oct 15, 2009 11:11 am
Posts: 169
In ref to previous point.
I think I first installed at the end of 2015.
Would this make it a v.1 site ? Not sure


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Problems using module manager after core upgrade
PostPosted: Thu Jan 31, 2019 4:12 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 810
Location: Victoria, BC
I do remember this happening around the time of 2.2.5, and I don't think there was a way to fix it post-upgrade. Reinstalling the modules won't help.

You might have to do some forum searching unless someone with a better memory than me can remember the fix. I seem to recall it was doing an incremental upgrade but from before 2.2.5, which may not be much help to you. There may be other options but not that I'm remembering.

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Problems using module manager after core upgrade
PostPosted: Thu Jan 31, 2019 4:53 pm 
Offline
Forum Members
Forum Members

Joined: Thu Oct 15, 2009 11:11 am
Posts: 169
oh no ! That sounds pretty serious / drastic

Really disheartening.

What I thought was a 10 minute job to update some modules looks like a major issue.

Not really sure where to go from here


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Problems using module manager after core upgrade
PostPosted: Fri Feb 01, 2019 1:59 am 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 810
Location: Victoria, BC
Wait, you said it's all CG modules, but originally said it was all modules. Are the CORE modules showing this symptom too? (Like AdminSearch, DesignManager, etc?)

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Problems using module manager after core upgrade
PostPosted: Fri Feb 01, 2019 9:05 am 
Offline
Forum Members
Forum Members

Joined: Thu Oct 15, 2009 11:11 am
Posts: 169
$1:
Screen Shot 2019-02-01 at 09.00.32.png
Screen Shot 2019-02-01 at 09.00.32.png [ 148.86 KiB | Viewed 901 times ]
Yes, It is ALL modules.
What I was trying to say, is that I have only additionally installed CG Modules.

Screen attached


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Problems using module manager after core upgrade
PostPosted: Fri Feb 01, 2019 11:53 am 
Offline
Forum Members
Forum Members

Joined: Thu Oct 15, 2009 11:11 am
Posts: 169
UPDATE :-

I HAVE been able to update the modules now, but the module manager still shows INCORRECT information.

I was only able to update modules by going into the A-Z list of available modules and clicking 'Upgrade' from there.

The module manager info didn't change, although it now clearly states "0 Upgrades available"

If I click 'About' next to each module, it displays the correct version number ( see pic )

If I now click "upgrade' I get a "Nothing to do" message ( see pic )


Attachments:
Screen Shot 2019-02-01 at 11.47.04.png
Screen Shot 2019-02-01 at 11.47.04.png [ 65.05 KiB | Viewed 897 times ]
Screen Shot 2019-02-01 at 11.31.20.png
Screen Shot 2019-02-01 at 11.31.20.png [ 140.64 KiB | Viewed 897 times ]
Screen Shot 2019-02-01 at 11.43.55.png
Screen Shot 2019-02-01 at 11.43.55.png [ 187.36 KiB | Viewed 897 times ]
Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Problems using module manager after core upgrade
PostPosted: Fri Feb 01, 2019 2:46 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 810
Location: Victoria, BC
You can try deleting the moduleinfo.ini file within each module's folder, and perhaps doing a freshen install. I'm pretty sure this isn't solvable without going back to a known-good version then finding what's causing it during the upgrade though.

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Problems using module manager after core upgrade
PostPosted: Fri Feb 01, 2019 8:19 pm 
Offline
Power Poster
Power Poster
User avatar

Joined: Fri Apr 18, 2008 9:34 pm
Posts: 355
Location: Nimbin, Australia
if you have direct access to database, maybe check the [prefix]_version table. the one and only field reads: 202 for my 2.2.9 installation. Should you be game enough to change this number in database, you also must clear cache. (sort your tmp/cache files by size, and one of the smallest files will be the same version number - me thinks).
Also, the file lib/version.php should show the same number for CMS_SCHEMA_VERSION.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Problems using module manager after core upgrade
PostPosted: Sun Feb 03, 2019 4:06 am 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 810
Location: Victoria, BC
I was upgrading a bunch of old sites over the past few days and ran into the same symptoms on some of them. There were a few different reasons, but ultimately it was the upgrade database step encountering an error, even though it allowed me to continue and seemed to finish fine.

I think you're going to need to go to your backup from before the upgrade and see if you can find out if something is not going right during the upgrade. Watch all of the messages, use debug mode, check logs, etc.

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Hosting Nation - Managed CMSMS Hosting