1and1 install php memory problem

For questions and problems with the CMS core. This board is NOT for any 3rd party modules, addons, PHP scripts or anything NOT distributed with the CMS made simple package itself.
Post Reply
bentonbee
New Member
New Member
Posts: 1
Joined: Mon Nov 05, 2018 5:31 pm

1and1 install php memory problem

Post by bentonbee »

I am no expert at these things. I have installed CMS made simple on 1and1 linux webserver before and not had problems.
I have tried installing the lastest cms made simple 2.2.8 expanded install and 2.2.6 and 2.2.1 and keep getting the same error.
I upload the zip file. unpack it in file cmsmsinstall that I created on the server. Then when I go to install it cmsms does a ck of the webserver and I get this error:

Checking for a sufficient PHP memory limit
Your memory limit value is too low. You had -1, however a minimum of 16M is required, and 32M is recommended

I have called 1and1 help and they can't seem to fix it. Say it is a cmsmade simple problem.
Can you help me
Thanks
Pastor Mike
User avatar
DIGI3
Dev Team Member
Dev Team Member
Posts: 1035
Joined: Wed Feb 25, 2009 4:25 am
Location: Victoria, BC

Re: 1and1 install php memory problem

Post by DIGI3 »

Depending upon the hosting setup, you may be able to define a memory limit in php.ini, .user.ini or .htaccess.

If 1and1 has a php.ini editor in cPanel that might be the best place to start, enter a value there. If it doesn't, you'll need to experiment with the above files or ask 1and1 where to set it.

in php.ini or user.ini it will be something like:
memory_limit = 32M

in .htaccess it would be:
php_value memory_limit 32M

If none of those work, you may need to escalate a bit with 1and1 - ask for second level support or whatever their equivalent is. It's possible it's something we need to tweak in the installer, but as this is the first report I've seen with this issue it sounds pretty unique to this host.
Not getting the answer you need? CMSMS support options
johnflan
Forum Members
Forum Members
Posts: 26
Joined: Thu Aug 23, 2007 5:20 pm

Re: 1and1 install php memory problem

Post by johnflan »

Got the same problem - never had this issue before so perhaps something has changed at 1and1 IONOS.

At 1and1 IONOS, support for php5.6 is due to cease so had to add "ini_set("memory_limit", "256M");" to config.php files to get my cmsms sites to work with php7.2.

Upgrading - I haven't found a way to get around the "Your memory limit value is too low" problem even though I'm sure it's set to 256M. Tried .htaccess etc.

1and1 believe it's not them. Has anyone found a solution?
Hupi
Forum Members
Forum Members
Posts: 15
Joined: Fri Dec 25, 2015 4:03 pm

Re: 1and1 install php memory problem

Post by Hupi »

I have the exact same issue too.

No way to get the upgrade running ( from 2.2.7 to 2.2.8 ).

The installer tells me "Checking for a sufficient PHP memory limit
Your memory limit value is too low. You had -1, however a minimum of 16M is required, and 32M is recommended
".

Changing the memory limit is not required really: If I check with phpInfo, the memory limit is set to 256M already (running php 7.1.25).

I have no clue why the installer say's "-1". The only settings I can find with phpInfo that have a value of "-1" are "max_input_time" and "serialize_precision"...

Since I have this issue the first time now, I would guess it is not a 1and1 issue but caused by the CMSMS installer.
I was always able to upgrade until now and never had an issue to install CMSMS on the 1and1 hosts either.

BR Hupi

BTW: I also tried to change the memory_limit within the php.ini and also .htaccess --> both methods failed for me on the 1and1 hosts. php.ini is not looked up I guess and the .htaccess method gives error 500 immediately.
MantaPro
Forum Members
Forum Members
Posts: 78
Joined: Sun Feb 03, 2008 8:14 pm

Re: 1and1 install php memory problem

Post by MantaPro »

I have done several installs of CMSMS v2.2.8 on 1&1 Ionos recently and my fix of the memory limit =-1 seems to have worked OK

After creating the root directory and the root/cms_install directories; and after unzipping CMSMS v2.2.8; but before running the install; I created the following php.ini file

Code: Select all

memory_limit = 32M
output_buffering = on
Can sometimes achieve the same thing via .htaccess but .htaccess commands on 1&1 seem a mysterious dark art often causing Server 500 errors and no error log messages (or more accurately 1&1 do not allow customers to access the server error log messages which makes diagnostics tough); and 1&1 are no help with .htaccess, so often it is just easier and less fragile to use php.ini

Unlike .htaccess, php.ini settings are NOT inherited by subdirectories so this php.ini file is needed in every directory were you may initiate a php program which is only 3 directories, so upload it to:
root/php.ini for your front end
root/cms_install/php.ini for the installation process
root/admin/php.ini for the admin back end

Hope this helps some fellow 1&1 users
calguy1000
Support Guru
Support Guru
Posts: 8169
Joined: Tue Oct 19, 2004 6:44 pm
Location: Fernie British Columbia, Canada

Re: 1and1 install php memory problem

Post by calguy1000 »

Just a tip... you can probably override the error_log and other error settings in the php.ini too.

Code: Select all

error_log = php_errors.log
log_errors = On
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.
Hupi
Forum Members
Forum Members
Posts: 15
Joined: Fri Dec 25, 2015 4:03 pm

Re: 1and1 install php memory problem

Post by Hupi »

MantaPro wrote:I have done several installs of CMSMS v2.2.8 on 1&1 Ionos recently and my fix of the memory limit =-1 seems to have worked OK

After creating the root directory and the root/cms_install directories; and after unzipping CMSMS v2.2.8; but before running the install; I created the following php.ini file

Code: Select all

memory_limit = 32M
output_buffering = on
Unlike .htaccess, php.ini settings are NOT inherited by subdirectories so this php.ini file is needed in every directory were you may initiate a php program which is only 3 directories, so upload it to:
root/php.ini for your front end
root/cms_install/php.ini for the installation process
root/admin/php.ini for the admin back end
Thanks Manta,

I have spent some more time on it again. Your described way works for the upgrade now. I guess this php.ini is propably only required in the install folder during the upgrade. It did not work because I had it in the root only but not in the installer directory when I tried first.

After the update, I deleted that and returned to my default php.ini which enables gzip and other things. The memory entry is not needed anymore after completing the installation it seams.

BR Hupi
Post Reply

Return to “CMSMS Core”