• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 3 posts ] 
Author Message
 Post subject: [SOLVED] HTTPS on pages required?
PostPosted: Fri May 11, 2018 2:13 pm 
Offline
Forum Members
Forum Members

Joined: Mon Dec 05, 2011 4:40 pm
Posts: 67
Location: Voorburg, Nederland
On a website I use:
- CMSMS 2.2.3.1
- CGExtensions
- CMSMailer
- FormBuilder
- News
- Search

In .htaccess I have:
Code:
RewriteEngine on
RewriteCond %{HTTPS} !=on
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]


I did not check the checkbox "Use HTTPS" on any page and there is no mixed content. It seems that everything works fine.

Q: is it required to check the "Use HTTPS"?


Last edited by rooon on Fri May 11, 2018 2:32 pm, edited 1 time in total.

Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: HTTPS on pages required?  Topic is solved
PostPosted: Fri May 11, 2018 2:19 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 405
Location: Victoria, BC
No, and in fact it's best not to. I think it's going to be deprecated/removed in a future release.

It was leftover from when it was normal to have an http site, but perhaps one or two pages with forms on to be https. Because certificates are easy and free/cheap now, there's no reason to not have your entire site https, so this setting is no longer relevant.

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: [SOLVED] HTTPS on pages required?
PostPosted: Fri May 11, 2018 2:32 pm 
Offline
Forum Members
Forum Members

Joined: Mon Dec 05, 2011 4:40 pm
Posts: 67
Location: Voorburg, Nederland
Thanks for your reply. I leave all https checkboxes unchecked as you explained. Question solved.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
A2 Hosting