• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 13 posts ] 
Author Message
 Post subject: How Do I Designate the Default Page?
PostPosted: Sat Apr 14, 2018 4:52 am 
Offline
Forum Members
Forum Members
User avatar

Joined: Sun Mar 01, 2009 5:40 am
Posts: 75
In CMSMS 1.x, the page list in Content > Pages included a check mark to indicate which page was to be treated as the default page. That seems to be gone in CMSMS 2.x. (Perhaps) as a result:

My working homepage is here:
http://villageofbergen.com/home
...and my new site is completely navigable from there.

But navigating to the domain name alone:
http://villageofbergen.com
...yields a 404 error.

I can't figure out how to configure CMSMS so that it knows what to do when a visitor requests the site by the domain name alone. Do I need to add a line to my .htaccess file to make this explicit?

Thanks in advance for your help,
Jim


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: How Do I Designate the Default Page?
PostPosted: Sat Apr 14, 2018 2:54 pm 
Offline
Dev Team Member
Dev Team Member

Joined: Mon Nov 28, 2011 9:29 am
Posts: 2995
Location: The Netherlands
Screenshot from a CMSMS 2.2.7 site:
Attachment:
cmsms_default_page.png
cmsms_default_page.png [ 9.57 KiB | Viewed 452 times ]


As far as I know it's not possible to not have a default page.

Did you migrate the website or upgrade or ...?


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: How Do I Designate the Default Page?
PostPosted: Sat Apr 14, 2018 3:48 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Sun Mar 01, 2009 5:40 am
Posts: 75
Thanks for the quick reply. That's *exactly* the column and control I was expecting to see, but exactly what my site is missing, as you'll see in the attached screenshot!

Your thoughts?

And to answer your question:
I built this site from scratch on 2.2.6. It's not an upgrade.


Attachments:
screenshot.jpg
screenshot.jpg [ 25.76 KiB | Viewed 451 times ]
Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: How Do I Designate the Default Page?
PostPosted: Sat Apr 14, 2018 5:10 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Sun Mar 01, 2009 5:40 am
Posts: 75
As a temporary fix for those pesky 404 errors that were greeting folks attempting to visit the site via just the domain name, I put an index.htm file in place at the site's root that redirects the browser to http://villageofbergen.com/home.

I know this only addresses the symptoms of our problem, not the root cause, but as we're just cutting over to the new site on a new web host, I needed to smooth out this bump in the road. Any help in solving the underlying problem would still be appreciated!


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: How Do I Designate the Default Page?
PostPosted: Sat Apr 14, 2018 6:54 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 367
Location: Victoria, BC
Try clearing your browser cache, using incognito mode, or a different browser.
You can also check your javascript console, and inspect the code to see if the column is there but just hidden for some reason.

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: How Do I Designate the Default Page?
PostPosted: Sat Apr 14, 2018 7:09 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Sun Mar 01, 2009 5:40 am
Posts: 75
DIGI3 wrote:
Try clearing your browser cache, using incognito mode, or a different browser.
You can also check your javascript console, and inspect the code to see if the column is there but just hidden for some reason.

Good suggestions, but...
    - I've tried clearing my browser's cache, without improvement.
    - I've tried another browser, without improvement.
    - I've used the inspector to look at the source for the Content Manager page, and I don't see a column hidden between "Active" and "Move".

Your thoughts?


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: How Do I Designate the Default Page?
PostPosted: Sat Apr 14, 2018 7:30 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 367
Location: Victoria, BC
Sounds like perhaps something got corrupted on upgrade or content reordering.

In the database, after making a backup, look at the 'content' table (usually cms_content), there should be a column called 'default_content'. Check that there's a 1 in the cell for the home page, and a 0 in everything else.

If the column isn't there, you may need to recreate it - but I'd take that as a clue that there could be more damage, so it might be better to go back to a known-good backup and seeing if you can find where things went wrong.

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: How Do I Designate the Default Page?
PostPosted: Sat Apr 14, 2018 8:00 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Sun Mar 01, 2009 5:40 am
Posts: 75
DIGI3 wrote:
In the database, after making a backup, look at the 'content' table (usually cms_content), there should be a column called 'default_content'. Check that there's a 1 in the cell for the home page, and a 0 in everything else.

With great care, I navigated the database. I was happy to see the "default_content" column in its expected place, but the only line marked with a "1" was the last object I created -- a separator. So I made that line a 0 and marked the home page with a 1.

With high hopes, I tested that solution by removing the (kludgy) index.htm file at the root level that I had put in place to redirect the visitor's browser. Sadly, my request to browse to http://villageofbergen.com was greeted with a 404 error.

So I put the index.htm file back in place and I await your further thoughts.

With gratitude,
Jim


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: How Do I Designate the Default Page?
PostPosted: Sat Apr 14, 2018 8:08 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 367
Location: Victoria, BC
Did you clear the cache after doing this?

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: How Do I Designate the Default Page?
PostPosted: Sat Apr 14, 2018 8:19 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Tue Oct 19, 2004 6:44 pm
Posts: 7952
Location: Fernie British Columbia, Canada
Quote:
Thanks for the quick reply. That's *exactly* the column and control I was expecting to see, but exactly what my site is missing, as you'll see in the attached screenshot!


I bet that that column has been turned off in the Content manager settings.

Under "Site Admin >> Settings - Content Manager | Content List Settings" there is a multiselect field entitled "Visible Columns" that controls what columns are displayed. By default everything should be selected. but I bet the "Default" column is not selected on your site.

_________________
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: How Do I Designate the Default Page?
PostPosted: Sat Apr 14, 2018 8:24 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Sun Mar 01, 2009 5:40 am
Posts: 75
DIGI3 wrote:
Did you clear the cache after doing this?

Oh, jeepers -- what a dope I can be!

So I set that index.html aside once again, cleared the CMSMS db cache, then cleared the cache on a couple of browsers and retested. NOW I think we can declare at least a temporary victory! I still don't see the "default" column on the Content Manager page, of course, but at least my site's visitors are taken to the homepage without error or delay.

Thank you SO much for your capable help!

Sincerely,
Jim


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: How Do I Designate the Default Page?
PostPosted: Sat Apr 14, 2018 8:25 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 367
Location: Victoria, BC
Cool. See Calguy's note above about the column settings.

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: How Do I Designate the Default Page?
PostPosted: Sat Apr 14, 2018 8:27 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Sun Mar 01, 2009 5:40 am
Posts: 75
calguy1000 wrote:
Quote:
I bet that that column has been turned off in the Content manager settings.

And OF COURSE you're right, calguy! That was the missing magic, and now we can declare a real and lasting victory!

Much obliged,
Jim


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
A2 Hosting