CMS Made Simple Forums
https://forum.cmsmadesimple.org/

Background Job Manager apparently not working
https://forum.cmsmadesimple.org/viewtopic.php?f=8&t=77693
Page 1 of 1

Author:  kmesd62 [ Wed Dec 06, 2017 1:39 pm ]
Post subject:  Background Job Manager apparently not working

Hi

I have jobs from NMS, News and no module in the Background Job Manager.

All jobs are listed as started, but there is no indication that any has completed; (viz no emails from NMS). The NMS entries all begin "Initialize sending of job..." [Edit].

The admin log has a steady stream of entries from CmsJobManager, all saying "Received 0 response when trying to trigger async processing"

I can't see anything that needs setting up, either in CMSMS or on the host - is this correct?

How can I check this module is working?

SysInfo follows

[code]----------------------------------------------
Cms Version: 2.2.3.1
Installed Modules:
AdminSearch: 1.0.4
AdvancedContent: 0.9.4.3
CGCalendar: 2.5
CGContentUtils: 2.2.2
CGExtensions: 1.57.1
CGGoogleMaps2: 1.1.1
CGSimpleSmarty: 2.1.7
CGTiny: 1.2.8
CMSContentManager: 1.1.6
CMSMailer: 6.2.14
Captcha: 0.5.5
CmsJobManager: 0.1.1
CustomContent: 1.9
DesignManager: 1.1.3
DownloadManager: 1.5.3
FileManager: 1.6.4
FilePicker: 1.0.1
FormBrowser: 0.5
FormBuilder: 0.8.1.6
Forum: 0.9.4
FrontEndUsers: 2.7.1
Gallery: 2.3.2
JQueryTools: 1.4.0.3
MenuManager: 1.50.3
MicroTiny: 2.2.1
ModuleManager: 2.1.2
NMS: 2.13.1
Navigator: 1.0.8
News: 2.51.3
Notifications: 1.1
Printing: 1.1.2
Search: 1.51.2
SelfRegistration: 1.12
ThemeManager: 1.1.8
TinyMCE: 2.9.12
TreeManager: 0.6.0
XMLMadeSimple: 0.0.6

Config Information:
php_memory_limit:
max_upload_size: 64000000
url_rewriting: mod_rewrite
page_extension:
query_var: page
auto_alias_content: true
locale:
set_names: true
timezone: Europe/London
permissive_smarty: false

Php Information:
phpversion: 5.5.38
md5_function: On (True)
json_function: On (True)
gd_version: 2
tempnam_function: On (True)
magic_quotes_runtime: Off (False)
E_ALL: 22519
E_STRICT: 0
E_DEPRECATED: 0
test_file_timedifference: No time difference found
test_db_timedifference: No time difference found
create_dir_and_file: 1
memory_limit: 128M
max_execution_time: 30
register_globals: Off (False)
output_buffering: 4096
disable_functions:
open_basedir:
test_remote_url: Success
file_uploads: On (True)
post_max_size: 64M
upload_max_filesize: 64M
session_save_path: /tmp (1777)
session_use_cookies: On (True)
xml_function: On (True)
xmlreader_class: On (True)
check_ini_set: On (True)
curl: On

Performance Information:
allow_browser_cache: Off (False)
browser_cache_expiry: 60
php_opcache: Off (False)
smarty_cache: Off (False)
smarty_compilecheck: Off (False)
auto_clear_cache_age: On (True)
Server Information:
Server Software: Apache/2.4.29 (Unix)
Server Api: cgi-fcgi
Server Os: Linux 2.6.32-696.3.2.el6.x86_64 On x86_64
Server Db Type: MySQL (mysqli)
Server Db Version: 10.1.24
Server Db Grants: Could not find a suitable "GRANT ALL" permission, this does not necessarily lead to problems... But if you have problems installing/removing modules or adding and deleting items/pages this could be the cause!
----------------------------------------------[/code]

Author:  master3395 [ Sun Dec 31, 2017 9:11 pm ]
Post subject:  Re: Background Job Manager apparently not working

You aren't the only one that has this problem.

Image dimension is too big for the forum apparently...

https://newstargeted.com/uploads/images/bugs-features/cmsms/Modules/Core/Background-Job-Manager/59970576c4739c36a4b580a3363f7953.png

I run mine on a shared hosting.
Never had any issues before i upgraded from 2.1.6
and before i started using cloudflare.

Code:
----------------------------------------------

Cms Version: 2.2.5

Installed Modules:

AdminSearch: 1.0.4
BoxPacker: 1.2.6
CGBetterForms: 1.3
CGBlog: 1.15.6
CGCalendar: 2.5
CGClientTickets: 1.1.4.1
CGContentUtils: 2.2.2
CGEcommerceBase: 1.8.6
CGExtensions: 1.57.1
CGFBPost: 1.1.3
CGJobMgr: 1.3.6
CGMessageQueue: 1.0.1
CGMyOrders: 1.2.4
CGNotifier: 1.1
CGPaymentGatewayBase: 1.6.2
CGSimpleSmarty: 2.1.7
CGSmartImage: 1.22.1
CGSnapshot: 1.3
CGSocialBlaster: 1.1
CGTiny: 1.2.8
CGTweet: 1.3.1
CGUserDirectory: 1.5.1
CGWebPush: 1.1.1
CGml: 1.1
CMSContentManager: 1.1.6
CMSMailer: 6.2.14
Captcha: 0.5.5
CmsJobManager: 0.1.2
CustomGS: 3.2
DesignManager: 1.1.4
Disqus: 2.1.0
ErrorLogger: 1.5.1
FAQ: 2.0.3
FRTaxes: 1.3
FileManager: 1.6.5
FilePicker: 1.0.2
FormBuilder: 0.8.1.6
FrontEndUsers: 2.7.1
Harden: 0.0.1
JM_Forum: 1.1.rc.1
JQueryTools: 1.4.0.3
MenuManager: 1.50.3
MetaMax: 2.1.7
MicroTiny: 2.2.2
ModuleManager: 2.1.3
NMS: 2.13.2
Navigator: 1.0.8
News: 2.51.3
Orders: 1.23.2
PaypalGateway: 2.6
Piwik: 1.0.1
Products: 2.28.3
ProductsByVendor: 1.2.6
Promotions: 1.3.1.1
Search: 1.51.2
SelfRegistration: 1.12
Showtime2: 3.5.4
SimpleSiteInfo: 3.3
SimpleSiteMgr: 3.3.1
SitemapMgr: 1.5.3
Statistics: 1.2.1.2
TinyMCE: 3.2-beta3
TweetMgr: 1.0
Uploads: 1.25.8
Widgets: 1.1

Config Information:

php_memory_limit:
max_upload_size: 256000000
url_rewriting: mod_rewrite
page_extension:
query_var: page
auto_alias_content: true
locale:
set_names: true
timezone: Europe/Oslo
permissive_smarty: true

Php Information:

phpversion: 7.1.11
md5_function: On (True)
json_function: On (True)
gd_version: 2
tempnam_function: On (True)
magic_quotes_runtime: Off (False)
E_ALL: 32767
E_STRICT: 2048
E_DEPRECATED: 8192
test_file_timedifference: No time difference found
test_db_timedifference: No time difference found
create_dir_and_file: 1
memory_limit: 512M
max_execution_time: 240
register_globals: Off (False)
output_buffering: 4096
disable_functions: system, exec, shell_exec, passthru, ini_restore, mysql_list_dbs, ini_alter, dl, openlog, syslog, symlink, link, chgrp, leak, popen, escapeshellcmd, apache_child_terminate, virtual, mb_send_mail
open_basedir:
test_remote_url: Success
file_uploads: On (True)
post_max_size: 256M
upload_max_filesize: 256M
session_save_path: /tmp (0700)
session_use_cookies: On (True)
xml_function: On (True)
xmlreader_class: On (True)
check_ini_set: On (True)
curl: On

Performance Information:

allow_browser_cache: On (True)
browser_cache_expiry: 60
php_opcache: Off (False)
smarty_cache: Off (False)
smarty_compilecheck: Off (False)
auto_clear_cache_age: On (True)
Server Information:

Server Software: Apache
Server Api: litespeed
Server Os: Linux 3.10.0-714.10.2.lve1.4.75.el7.x86_64 On x86_64
Server Db Type: MySQL (mysqli)
Server Db Version: 10.1.29
Server Db Grants: Found a "GRANT ALL" statement that appears to be suitable

Permission Information:

tmp: /home/user/public_html/tmp (0755)
tmp_cache: /home/user/public_html/tmp/cache (0755)
templates_c: /home/user/public_html/tmp/templates_c (0755)
modules: /home/user/public_html/modules (0755)
uploads: /home/user/public_html/uploads (0755)
File Creation Mask (umask): /home/user/public_html/tmp/cache (0755)
config_file: 0444
----------------------------------------------

Author:  kmesd62 [ Tue Mar 20, 2018 9:31 pm ]
Post subject:  Re: Background Job Manager apparently not working

An update iro the 'received 0 response' audit log entries:

I pinpointed the module code with the tests that generated the log entries to my hosting provider, who considered the null response "could be connected to the fact that we do not allow loopback connections which is effectively what this would do."

Is this correct / is there another server setting that could be responsible?

If I picked another host at random, what is the chance they would have the same view of loopback connections?

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/