Hyphenation Topic is solved

For questions and problems with the CMS core. This board is NOT for any 3rd party modules, addons, PHP scripts or anything NOT distributed with the CMS made simple package itself.
Post Reply
User avatar
caigner
Forum Members
Forum Members
Posts: 28
Joined: Sun Aug 16, 2020 5:29 am

Hyphenation

Post by caigner »

Hello!

With

Code: Select all

<__html lang="de">
in the HTML header and

Code: Select all

hypens: auto;
in the CSS code hyphenation works like a charm.

Now, I have the problem that CMSms sets the language like so:

Code: Select all

<__html lang="de_DE">
And with that hyphenation doesn't work anymore.

Any solutions to this problem?

Regards,
Christian
I am using CMSms 2.2.15
User avatar
DIGI3
Dev Team Member
Dev Team Member
Posts: 1187
Joined: Wed Feb 25, 2009 4:25 am
Location: Victoria, BC

Re: Hyphenation

Post by DIGI3 »

CMSMS doesn't set the lang like that, but your template might. Just change the template so it doesn't.
I've seen some templates come with

Code: Select all

<__html lang="{cms_get_language}">
which will result in the problem you're having, so you could change that to:

Code: Select all

<__html lang="{cms_get_language|truncate:2:"":true}">
or simply

Code: Select all

<__html lang="de">
Not getting the answer you need? CMSMS support options
User avatar
caigner
Forum Members
Forum Members
Posts: 28
Joined: Sun Aug 16, 2020 5:29 am

[SOLVED] Re: Hyphenation

Post by caigner »

Brilliant! So simply and elegant!

Thank you so much!
I am using CMSms 2.2.15
Post Reply

Return to “CMSMS Core”