• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 
Author Message
 Post subject: [fixed?] Admin section headers not appearing
PostPosted: Tue Jul 24, 2012 8:51 am 
Offline
New Member
New Member

Joined: Mon Jul 25, 2011 9:57 am
Posts: 9
I'm not really sure if this is the right forum for this, but it seems to be something that has changed in 1.11. I couldn't find this documented in the change log or discussed in any of the other topics.

With the new default theme it seems the different admin section headers (content, extensions) are not appearing even if the user, for example, has access to the News module.

If I create a new user group which has access to only the News module (Approve News For Frontend Display, Modify News) then clear cache and log in as that user the "Content" section which contains the link to the News module does not appear. (See attached screencap #1)

However, as soon as I add the "Modify Any Page" permission to the user the section header appears (See screencap #2).

The same happens for other modules and the "extensions" section header for example, it does not appear until the user is given the "Modify modules" permission.

Mayby this an intended change? I just tested this on a 1.10 install where a user with only the News module permissions could still see the content section header.


Attachments:
theme_2.jpg
theme_2.jpg [ 71.6 KiB | Viewed 3098 times ]
theme_1.jpg
theme_1.jpg [ 64.75 KiB | Viewed 3098 times ]
Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Admin section headers not appearing
PostPosted: Tue Jul 24, 2012 10:38 am 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7500
Location: The Netherlands
SanderDuif wrote:
If I create a new user group which has access to only the News module (Approve News For Frontend Display, Modify News) then clear cache and log in as that user the "Content" section which contains the link to the News module does not appear. (See attached screencap #1)
Confirmed in SVN rev. 8196
SanderDuif wrote:
However, as soon as I add the "Modify Any Page" permission to the user the section header appears (See screencap #2).
Confirmed in SVN rev. 8196

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return! [ Click here ]



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: [confirmed] Admin section headers not appearing
PostPosted: Tue Jul 24, 2012 4:46 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Tue Oct 19, 2004 6:44 pm
Posts: 7936
Location: Fernie British Columbia, Canada
Fixed in svn.

_________________
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: [confirmed] Admin section headers not appearing
PostPosted: Tue Jul 24, 2012 7:15 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7500
Location: The Netherlands
confirmed fixed in SVN rev. 8198

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return! [ Click here ]



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
HostPapa CMS Made Simple hosting