• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 7 posts ] 
Author Message
 Post subject: [fixed?] cms1.11 beta won't find the {search} tag
PostPosted: Fri Jul 20, 2012 2:57 pm 
Offline
New Member
New Member

Joined: Sat Mar 20, 2010 12:10 pm
Posts: 8
I installed cmsms 1.11b4 from scratch on my filesystem but on a database which already contained an old version (1.10.3) of my cmsms site. When I try to open the site's main page, I get:


Quote:
OMG! You broke this page.
Error: at line 656 in file D:\wamp\www\cmsms1.11b4\lib\smarty\sysplugins\smarty_internal_templatecompilerbase.php:

Message:

Syntax Error in template "tpl_body:23" on line 22 "{search search_method="post"}" unknown tag "search"


And when I look at the tags list, I can't find the {search} tag although I have the search module installed:

Code:
MicroTiny      1.2.3   Installé   Vrai   Désinstaller   Non   Aide   À propos   XML
ModuleManager   1.5.4      Installé   Vrai   Désinstaller   Non   Aide   À propos   XML
News            2.12.7   Installé   Vrai   Désinstaller   Oui   Aide   À propos   XML
Search         1.7.6      Installé   Vrai   Désinstaller   Non   Aide   À propos   XML
ThemeManager   1.1.6      Installé   Vrai   Désinstaller   Non   Aide   À propos   XML


Also, I realized something's weird: the module version for search for my installation is 1.7.6 whereas it is 1.5.4 on the forge... I checked my 1.10.3 install where the search version number is 1.7... Which one is the right one???

Any idea?


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: cms1.11 beta won't find the {search} tag
PostPosted: Fri Jul 20, 2012 3:32 pm 
Offline
Support Guru
Support Guru
User avatar

Joined: Wed Sep 05, 2007 8:03 pm
Posts: 3999
Location: The Netherlands
leolivier wrote:
whereas it is 1.5.4 on the forge...

Because Search is a core module and is released in the core package, it doesn't need to have actual releases in the Forge.

_________________


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: cms1.11 beta won't find the {search} tag
PostPosted: Fri Jul 20, 2012 3:42 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Tue Oct 19, 2004 6:44 pm
Posts: 7936
Location: Fernie British Columbia, Canada
Quote:
I installed cmsms 1.11b4 from scratch on my filesystem but on a database which already contained an old version (1.10.3) of my cmsms site. When I try to open the site's main page, I get:


If you downloaded and installed a fresh install of CMSMS over top of an existing 1.10.x install without going through the upgrade routine. then you will have problems... all kinds of them... unless by chance you used a different database prefix, in which case two installs should co-exist nicely in the same database.

You can do a fresh install, or an upgrade... but you cannot just install overtop of an existing database and expect things to work.

_________________
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: cms1.11 beta won't find the {search} tag
PostPosted: Fri Jul 20, 2012 4:05 pm 
Offline
New Member
New Member

Joined: Sat Mar 20, 2010 12:10 pm
Posts: 8
Well I followed the upgrade routine...
What I did exactly is:
1.Extract the 1.11 code in a new site directory
2.Make a copy of the old database
3.Copy the old config.php file and the module I wanted to test
4.I changed the database name, the root directory and the root url related stuff in config.php
5.Then I ran the upgrade routine (which explains why my search module is in 1.7.6 version)

And now, it can't find the search tag


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: cms1.11 beta won't find the {search} tag
PostPosted: Fri Jul 20, 2012 5:02 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7498
Location: The Netherlands
This should be fixed in SVN rev.200 - Minor fix to upgrade routine.

ps. This was after beta-4 was cut!!

_________________
Image
Latest CMSMS article: Search Form Autocomplete

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return! [ Click here ]



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: [fixed?] cms1.11 beta won't find the {search} tag
PostPosted: Fri Jul 27, 2012 5:23 pm 
Offline
New Member
New Member

Joined: Sat Mar 20, 2010 12:10 pm
Posts: 8
Seems ok with svn 8201


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: [fixed?] cms1.11 beta won't find the {search} tag
PostPosted: Sat Jul 28, 2012 3:29 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Tue Oct 19, 2004 6:44 pm
Posts: 7936
Location: Fernie British Columbia, Canada
Just did an upgrade from 1.10.3 with a completely different site, specifically to test this problem. it worked great for me (as usual).

_________________
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
A2 Hosting