[fixed?] Assigning template missing the {content} tag

A place to discuss issues related to CMSMS 1.11 beta versions. This forum will be heavily moderated.
Locked
brunettdan
New Member
New Member
Posts: 9
Joined: Fri Jun 01, 2012 2:54 pm

[fixed?] Assigning template missing the {content} tag

Post by brunettdan »

When trying to assign a template which is missing the {content} tag to a page, the server thorws the following error:

Code: Select all

[Tue Jun 26 22:49:24 2012] [error] [client xxx] PHP Fatal error:  Uncaught exception 'SmartyException' with message 'Call of unknown method '_compile_source'.' in /xx/xx/public_html/lib/smarty/sysplugins/smarty_internal_templatebase.php:806
[Tue Jun 26 22:49:24 2012] [error] [client xxx] Stack trace:
[Tue Jun 26 22:49:24 2012] [error] [client xxx] #0 /xx/xx/public_html/modules/TinyMCE/stylesheet.php(141): Smarty_Internal_TemplateBase->__call('_compile_source', Array)
[Tue Jun 26 22:49:24 2012] [error] [client xxx] #1 /xx/xx/public_html/modules/TinyMCE/stylesheet.php(141): Smarty_CMS->_compile_source('temporary style...', '/* Start of CMS...', '/* Start of CMS...')
[Tue Jun 26 22:49:24 2012] [error] [client xxx] #2 {main}
[Tue Jun 26 22:49:24 2012] [error] [client xxx]   thrown in /xx/xx/public_html/lib/smarty/sysplugins/smarty_internal_templatebase.php on line 806
Although, it is possible to assign the template by choosing 'Set All Pages' in the Templates list.

Running beta2
calguy1000
Support Guru
Support Guru
Posts: 8169
Joined: Tue Oct 19, 2004 6:44 pm
Location: Fernie British Columbia, Canada

Re: Assigning template missing the {content} tag

Post by calguy1000 »

Edit template in 1.11 should not allow you to commit if there is no {content} tag available.

That's where the bug lies.
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.
User avatar
Rolf
Dev Team Member
Dev Team Member
Posts: 7759
Joined: Wed Apr 23, 2008 7:53 am
Location: The Netherlands
Contact:

Re: Assigning template missing the {content} tag

Post by Rolf »

calguy1000 wrote:Edit template in 1.11 should not allow you to commit if there is no {content} tag available.

That's where the bug lies.
Confirmed new template without {content} can be saved (rev. 8121)
Image
- + - + - + - + - + -
Latest CMSMS tutorial: FormBuilder WatchGuard
- + - + - + - + - + -
Did my post help you solving a problem at your (customers) website and it saved you many hours of work?
Great!! Buy me a cup of coffee in return as a small token of appreciation!
calguy1000
Support Guru
Support Guru
Posts: 8169
Joined: Tue Oct 19, 2004 6:44 pm
Location: Fernie British Columbia, Canada

Re: [confirmed] Assigning template missing the {content} tag

Post by calguy1000 »

should be fixed in svn.
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.
User avatar
Rolf
Dev Team Member
Dev Team Member
Posts: 7759
Joined: Wed Apr 23, 2008 7:53 am
Location: The Netherlands
Contact:

Re: [confirmed] Assigning template missing the {content} tag

Post by Rolf »

Confirmed fixed in rev. 8126
Image
- + - + - + - + - + -
Latest CMSMS tutorial: FormBuilder WatchGuard
- + - + - + - + - + -
Did my post help you solving a problem at your (customers) website and it saved you many hours of work?
Great!! Buy me a cup of coffee in return as a small token of appreciation!
Locked

Return to “[locked] CMSMS 1.11 Beta”