• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 5 posts ] 
Author Message
 Post subject: [invalid] "Not allowed by security setting" Smarty Error
PostPosted: Sun Jun 24, 2012 6:01 am 
Offline
Forum Members
Forum Members
User avatar

Joined: Sun Apr 24, 2011 8:14 pm
Posts: 81
Location: Montenegro
Hi all,

Server: Apache 2.2 (local, on Win XP)
PHP Version 5.2.5

After a clean installation I've got this error while trying to see Admin area:
\$1:
Fatal error: Uncaught exception 'SmartyException' with message 'directory 'G:\www\vhosts\localhost\cmsms111\admin\themes\OneEleven\templates\topcontent.tpl' not allowed by security setting' in G:\www\vhosts\localhost\cmsms111\lib\smarty\sysplugins\smarty_security.php:381 Stack trace: #0 G:\www\vhosts\localhost\cmsms111\lib\smarty\sysplugins\smarty_internal_resource_file.php(33): Smarty_Security->isTrustedResourceDir('G:\www\vhosts\l...') #1 G:\www\vhosts\localhost\cmsms111\lib\smarty\sysplugins\smarty_resource.php(532): Smarty_Internal_Resource_File->populate(Object(Smarty_Template_Source), Object(Smarty_Internal_Template)) #2 G:\www\vhosts\localhost\cmsms111\lib\smarty\sysplugins\smarty_internal_template.php(628): Smarty_Resource::source(Object(Smarty_Internal_Template)) #3 G:\www\vhosts\localhost\cmsms111\lib\smarty\sysplugins\smarty_internal_templatebase.php(117): Smarty_Internal_Template->__get('source') #4 G:\www\vhosts\localhost\cmsms111\lib\classes\class.Smarty_CMS.php(298): Smarty_Internal_TemplateBase->fetch('top in G:\www\vhosts\localhost\cmsms111\lib\smarty\sysplugins\smarty_security.php on line 381


Frontend seems OK.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: "Not allowed by security setting" Smarty Error
PostPosted: Sun Jun 24, 2012 4:21 pm 
Offline
Power Poster
Power Poster
User avatar

Joined: Tue Oct 19, 2004 6:44 pm
Posts: 8172
Location: Fernie British Columbia, Canada
Works fine here... just did a complete new installation.

_________________
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: "Not allowed by security setting" Smarty Error
PostPosted: Sun Jun 24, 2012 4:35 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7713
Location: The Netherlands
I can't confirm this too, works fine here.
At the moment I will mark this one "invalid"

Could you provide more info to reproduce this one?

_________________
$1

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return!



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: [invalid] "Not allowed by security setting" Smarty Error
PostPosted: Sun Jun 24, 2012 6:34 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Sun Apr 24, 2011 8:14 pm
Posts: 81
Location: Montenegro
No, I'm afraid I can't. I'm using a standard Web-developer Server Suite v2.00. First time I've seen this error was when I installed an early 1.11 Alpha release, months ago. But I thought it's something Alpha - related. What's strange, when I first installed it, I was able to use the system normally - I was admiring the new admin theme, peeking on some new (then not yet implemented) features, understanding the context of some new translation strings... And then suddenly - this error. I don't remember doing anything that could cause this behavior. I've tried changing the file/folder permissions etc, but it was a futile effort.

Just now I've tried with a yet another new installation - same thing happens. But, when I change my admin theme (via database) to NCleanGrey, I can access admin area, except Site admin area (subitems) and My Account. Everything else behaves as expected. It's madness! Madness, I tell you! :)

Well, if no one else has this problem, then it's not really a CMS MS problem.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: [invalid] "Not allowed by security setting" Smarty Error
PostPosted: Tue Jun 26, 2012 1:06 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Sun Apr 24, 2011 8:14 pm
Posts: 81
Location: Montenegro
Hi, sorry for bumping this up, but I've commented out a certain line of code (I know, I shouldn't talk about it, but...) and here's some system info that you might find useful:

----------------------------------------------

Cms Version: 1.11-beta2

Installed Modules:

CMSMailer: 5.2.1
CMSPrinting: 1.0.2
FileManager: 1.4.0
MenuManager: 1.8.2
MicroTiny: 1.2.2
ModuleManager: 1.5.4
News: 2.12.7
Search: 1.7.6
ThemeManager: 1.1.6


Config Information:

php_memory_limit:
process_whole_template:
output_compression:
max_upload_size: 10000000
url_rewriting: none
page_extension:
query_var: page
image_manipulation_prog: GD
auto_alias_content: true
locale:
default_encoding: utf-8
admin_encoding: utf-8
set_names: true


Php Information:

phpversion: 5.2.5
md5_function: On (True)
gd_version: 2
tempnam_function: On (True)
magic_quotes_runtime: Off (False)
E_STRICT: 0
memory_limit: 128M
max_execution_time: 60
output_buffering: 1
safe_mode: Off (False)
file_uploads: On (True)
post_max_size: 10M
upload_max_filesize: 10M
session_save_path: G:/www/tmp/ (0777)
session_use_cookies: On (True)
xml_function: On (True)
xmlreader_class: On (True)


Server Information:

Server Api: apache2handler
Server Db Type: MySQL (mysqli)
Server Db Version: 5.0.45
Server Db Grants: Found a "GRANT ALL" statement that appears to be suitable
----------------------------------------------

FYI, without this particular line throwing the exception (\lib\smarty\sysplugins\smarty_security.php on line 381) everything seems to work OK.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Hosting Nation - Managed CMSMS Hosting