• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 5 posts ] 
Author Message
 Post subject: [fixed?] root_url adding trailing slashes
PostPosted: Thu Jun 21, 2012 11:40 am 
Offline
Forum Members
Forum Members

Joined: Thu Aug 21, 2008 11:47 am
Posts: 89
After installing the 1.11 Beta1 I noticed no root_url had been added to my config.php file as a default. This then caused my site's base URL to have a trailing / meaning all URL references were wrong causing issues with links and CSS references etc.

Adding the root_url to my config fixed the issue, should this not be added to the config.php as a default? And if not why does my default root_url automatically get appended with / ?

Image attached with system PHP info.


Attachments:
Screen Shot 2012-06-21 at 12.34.34.png
Screen Shot 2012-06-21 at 12.34.34.png [ 97.69 KiB | Viewed 5064 times ]
Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: root_url adding trailing slashes
PostPosted: Thu Jun 21, 2012 1:32 pm 
Offline
Power Poster
Power Poster

Joined: Mon Sep 08, 2008 9:43 am
Posts: 306
I installed Beta-1 on Win-7, Apache2, PHP 5.3.5, and got a backslash(\) trailing the root_url. In all CMSMS generated links a slash was added after the backslash (\/) and no links worked.

Like oliverseddon I added root_url to the config.php to fix it.

_________________
My little CTLMM help site


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: root_url adding trailing slashes
PostPosted: Thu Jun 21, 2012 1:53 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7591
Location: The Netherlands
problem confirmed

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return! [ Click here ]



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: [reproduced] root_url adding trailing slashes
PostPosted: Thu Jun 21, 2012 2:06 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Tue Oct 19, 2004 6:44 pm
Posts: 7965
Location: Fernie British Columbia, Canada
Fixed in svn.

_________________
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: [fixed?] root_url adding trailing slashes
PostPosted: Sun Jul 22, 2012 7:39 am 
Offline
Forum Members
Forum Members

Joined: Fri Dec 30, 2005 10:08 am
Posts: 58
Location: London
Not fixed in beta 4


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
A2 Hosting