[fixed] CMSMS 1.10 Beta3: $entry->title missing on detail

The members of the Dev team will place issues here that they consider to be solved.
Post Reply
fredp
Forum Members
Forum Members
Posts: 218
Joined: Sun Jul 27, 2008 1:36 am
Location: USA

[fixed] CMSMS 1.10 Beta3: $entry->title missing on detail

Post by fredp »

Hi,

There is another issue with News articles displayed on a detail page: $entry->title is always unset.

I tracked the problem down to a modules/News/lib/class.news_ops.php method:

Code: Select all

  static private function &get_article_from_row($row,$get_fields = 'PUBLIC')
  {...
It seems that the 'news_title' case is missing from the switch statement; so, the title value is never stored in the new news_article object.

I didn't check if there were any other $row keys missing from the switch statement. You might want to check that while you're "in" the function. ;)

Cheers!
Nearly all men can stand adversity, but if you want to test a man's character, give him power.
- Abraham Lincoln
Jos
Support Guru
Support Guru
Posts: 4016
Joined: Wed Sep 05, 2007 8:03 pm
Location: The Netherlands

Re: CMSMS 1.10 Beta3: $entry->title missing on detail

Post by Jos »

Confirmed. I just encountered this issue too.

I checked on rev 7451.
Still no $entry->title available in the detailtemplate of News
User avatar
Rolf
Dev Team Member
Dev Team Member
Posts: 7770
Joined: Wed Apr 23, 2008 7:53 am
Location: The Netherlands
Contact:

Re: CMSMS 1.10 Beta3: $entry->title missing on detail

Post by Rolf »

Calguy fixed this yesterday
I tried it just now in rev. 7451 and it works for me...

@Jos, could you double check this?

grtz. Rolf
Image
- + - + - + - + - + -
Latest CMSMS tutorial: FormBuilder WatchGuard
- + - + - + - + - + -
Did my post help you solving a problem at your (customers) website and it saved you many hours of work?
Great!! Buy me a cup of coffee in return as a small token of appreciation!
Jos
Support Guru
Support Guru
Posts: 4016
Joined: Wed Sep 05, 2007 8:03 pm
Location: The Netherlands

Re: [fixed???] CMSMS 1.10 Beta3: $entry->title missing on de

Post by Jos »

I'm sorry, it works now.

I must have done something wrong updating the files. :-[

Fixed!
User avatar
Rolf
Dev Team Member
Dev Team Member
Posts: 7770
Joined: Wed Apr 23, 2008 7:53 am
Location: The Netherlands
Contact:

Re: [fixed???] CMSMS 1.10 Beta3: $entry->title missing on de

Post by Rolf »

pfeww, thanks Jos ;)
Image
- + - + - + - + - + -
Latest CMSMS tutorial: FormBuilder WatchGuard
- + - + - + - + - + -
Did my post help you solving a problem at your (customers) website and it saved you many hours of work?
Great!! Buy me a cup of coffee in return as a small token of appreciation!
Post Reply

Return to “Closed Issues”