• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: [Solved] Fatal error after upgrading test site...
PostPosted: Sat Aug 20, 2011 7:06 pm 
Offline
Forum Members
Forum Members

Joined: Sun Jan 10, 2010 7:02 pm
Posts: 183
After upgrading from the latest 1.9.x to 1.10 (without problems) I could log on to the admin page once, see the front end once, with a number of smarty errors from invalidated module tags.

First time I click on a an admin pages menue, now I get, both on admin and front end:
\$1:
Fatal error: Call to a member function get_tasks() on a non-object in /var/www/testsite/lib/classes/class.CmsRegularTaskHandler.php on line 87


I have a clean 1.10 install working fine on the same system.

So I suppose its a core error but caused by some module.. ???


Last edited by janaf on Sat Aug 20, 2011 8:34 pm, edited 1 time in total.

Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Fatal error after upgrading test site...
PostPosted: Sat Aug 20, 2011 7:12 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Tue Oct 19, 2004 6:44 pm
Posts: 8167
Location: Fernie British Columbia, Canada
Nope, that one appears to be a genuine bug. in the modules_with_capability cache stuff.

I've commited a fix to it to svn, and here's the diff:

Index: class.CmsRegularTaskHandler.php
===================================================================
--- class.CmsRegularTaskHandler.php (revision 7338)
+++ class.CmsRegularTaskHandler.php (revision 7340)
@@ -82,6 +82,7 @@
if (!$modules) return;
foreach( $modules as $one )
{
+ if( !is_object($one) ) $one = cms_utils::get_module($one);
if( !method_exists($one,'get_tasks') ) continue;

$tasks = $one->get_tasks()

_________________
Follow me on twitter
Please post system information from "Extensions >> System Information" (there is a bbcode option) on all posts asking for assistance.
--------------------
If you can't bother explaining your problem well, you shouldn't expect much in the way of assistance.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Fatal error after upgrading test site...
PostPosted: Sat Aug 20, 2011 8:33 pm 
Offline
Forum Members
Forum Members

Joined: Sun Jan 10, 2010 7:02 pm
Posts: 183
The fix is confirmed OK on my install...


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
A2 Hosting