CMS Made Simple Forums
https://forum.cmsmadesimple.org/

Module installable that is only supported up to 1.9.9
https://forum.cmsmadesimple.org/viewtopic.php?f=74&t=57034
Page 1 of 1

Author:  Duketown [ Fri Sep 30, 2011 1:57 pm ]
Post subject:  Module installable that is only supported up to 1.9.9

Hi,

I've tried to install one of my modules (DTInventory) using Module Manager.
I know that the version available from the forge is not updated to the latest CMSMS vs 1.10...
Installing is done without a problem and in the modules overview, it is clearly stated that the module is only supported up until 1.9.9.
The module is available via eCommerce menu option.
I thought that once the maximum supported version is set to something installation is not possible.
Does this have to do that 1.9.9 is greater than 1.10-beta3 (at least for the server)?
If so, doesn't this give a problem with all modules that have a maximum support set to at lease 1.1...?

Duketown

PS. MinimumCMSVersion() returns 1.8 for this module.

Author:  Jos [ Fri Sep 30, 2011 2:11 pm ]
Post subject:  Re: Module installable that is only supported up to 1.9.9

In the updated Module API Docs I read:

Quote:
MaximumCMSVersion (line 417)
Returns the maximum version necessary to run this version of the module.

deprecated:
abstract:
string MaximumCMSVersion ()


http://www.cmsmadesimple.org/apidoc_1.10/

Maybe that has something to do with your "issue"

I never use MaximumCMSVersion in modules. Raises more questions is the forum then it prevents?

Author:  Duketown [ Fri Sep 30, 2011 2:28 pm ]
Post subject:  Re: Module installable that is only supported up to 1.9.9

Jos,

Thanks for the reply.
Since retrieval of data and checking if module has been installed is handled differently, I need to check which version is running. In other words on purpose I'm using both MinimumCMSVersion() as well as MaximumCMSVersion() to return 1.8 resp. 1.9.9
At this moment the module has been installed, but is not performing as it should (due to the checking of another module installation which is in my case if ShopMadeSimple is installed).

So there must be something else.

Duketown

Author:  Duketown [ Fri Sep 30, 2011 3:07 pm ]
Post subject:  Re: Module installable that is only supported up to 1.9.9

Continuing on this minimum and maximum version setting I can even imagine that a version of a module prepared by me with 1.10-beta2 as minimum could be installed using module manager in a CMSMS version 1.9.4.3 environment. This could cause problems as well I think.

Were do I make a thinking mistake?

Duketown

Author:  Duketown [ Tue Oct 04, 2011 4:34 am ]
Post subject:  Re: Module installable that is only supported up to 1.9.9

Really like to know if I'm mistaken here.
When is it best to release 1.10 based modules?

Duketown

Author:  calguy1000 [ Thu Oct 06, 2011 2:55 pm ]
Post subject:  Re: Module installable that is only supported up to 1.9.9

something with a Minumum version number of 1.10-beta2 should not be allowed to be installed from ModuleManager from CMSMS 1.9.x ... but I am also aware that the ModuleManager does not check MaximumCMSVersion (that data isn't even in the xml file).

So there isn't much you can do.

However, there is no reason you can't set a minimum version of 1.9.x for your module and have the same code work with 1.9.x and 1.10.x ... at least for a while, till most people are on 1.10.x

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/