LISE + custom URL

Have a question or a suggestion about a 3rd party addon module or plugin?
Let us know here.
Post Reply
User avatar
Cyc
Forum Members
Forum Members
Posts: 64
Joined: Wed Nov 18, 2015 11:54 pm
Location: Poland

LISE + custom URL

Post by Cyc »

Hi, when I set field: "Choose a custom URL for this item or accept the generated one:" on custom URL LISE still generated ugly URL. How to use this feature?
User avatar
DIGI3
Dev Team Member
Dev Team Member
Posts: 1037
Joined: Wed Feb 25, 2009 4:25 am
Location: Victoria, BC

Re: LISE + custom URL

Post by DIGI3 »

You need to have pretty urls set up for your site. Once you do then it should just work. If you're still having problems you're going to need to provide more information and be specific about where the problem is.
Not getting the answer you need? CMSMS support options
User avatar
Cyc
Forum Members
Forum Members
Posts: 64
Joined: Wed Nov 18, 2015 11:54 pm
Location: Poland

Re: LISE + custom URL

Post by Cyc »

Thx for reply. My config.php looks like:

Code: Select all

$config['timezone'] = 'Europe/Warsaw';
$config['url_rewriting'] = 'mod_rewrite';
$config['page_extension'] = '.html';
Pretty URLs is enabled, but links generated by LISE are still ugly. What more informations do you need?
User avatar
DIGI3
Dev Team Member
Dev Team Member
Posts: 1037
Joined: Wed Feb 25, 2009 4:25 am
Location: Victoria, BC

Re: LISE + custom URL

Post by DIGI3 »

Pretty urls are tested and working in other areas of your site? (htaccess is set up correctly?)

What versions of cmsms and lise?
Where are the urls not pretty - just the generated link to the detail template from your summary template?
What happens if you hit the url manually?
Not getting the answer you need? CMSMS support options
User avatar
Cyc
Forum Members
Forum Members
Posts: 64
Joined: Wed Nov 18, 2015 11:54 pm
Location: Poland

Re: LISE + custom URL

Post by Cyc »

https://www.cbmn.pl/ - link to the website.
What versions of cmsms and lise?
CMS: 2.2.10
LISE: 1.3.1
Where are the urls not pretty - just the generated link to the detail template from your summary template?
No, in LISE is field "Choose a custom URL for this item or accept the generated one:" when I set here URL nothing is happen.
What happens if you hit the url manually?
Nothing...
User avatar
DIGI3
Dev Team Member
Dev Team Member
Posts: 1037
Joined: Wed Feb 25, 2009 4:25 am
Location: Victoria, BC

Re: LISE + custom URL

Post by DIGI3 »

Sorry, I'm still not really understanding the problem. I just did some tests and I can enter a custom url into any lise item, then access it with mysite.com/my-custom-lise-url.

The default summary template generates the pretty urls properly and uses the custom url.

When you say nothing happens when you visit the url manually, do you mean 404? Blank page? Another error?

What is generated by {$item->url} in the default summary template for your item with a custom url?
Not getting the answer you need? CMSMS support options
Post Reply

Return to “Modules/Add-Ons”