• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Bug in Newsletter Made Simple?
PostPosted: Sat Nov 09, 2019 6:29 am 
Offline
Forum Members
Forum Members

Joined: Sun Oct 28, 2007 4:14 am
Posts: 222
Location: Australia
I cannot see address lists in NMS, or users, despite their being present in the database tables. It's a pest. I have tried uninstalling and removing the module and then reinstalling and importing the users etc.

I have also gone back a couple of versions of NMS. Same problem.

Today I used softaculous to set up a dummy installation of CMS Made Simple, upgraded the only module needing it (News) and then installed NMS. I entered a list. The admin page showed no lists.

I added a user to the list. I could see the list in the drop down box you use to add a user to a list. But the user is not visible.

I can see the user and the list using phpMyadmin.

I'm calling this a bug. It suggests to me that something in the Core Install is preventing NMS from displaying its admin pages correctly.

Andrew

----------------------------------------------

Cms Version: 2.2.12

Installed Modules:

AdminSearch: 1.0.4
CGExtensions: 1.64.10
CGSimpleSmarty: 2.2.1
CMSContentManager: 1.1.8
CmsJobManager: 0.1.3
DesignManager: 1.1.6
FileManager: 1.6.9.1
FilePicker: 1.0.4.1
MenuManager: 1.50.3
MicroTiny: 2.2.4
ModuleManager: 2.1.7
NMS: 2.13.3
Navigator: 1.0.9
News: 2.51.7
Search: 1.51.7

Config Information:

php_memory_limit:
max_upload_size: 2000000
url_rewriting: none
page_extension:
query_var: page
auto_alias_content: true
locale:
set_names: true
timezone: America/New_York
permissive_smarty: false

Php Information:

phpversion: 7.3.11
md5_function: On (True)
json_function: On (True)
gd_version: 2
tempnam_function: On (True)
magic_quotes_runtime: Off (False)
E_ALL: 32767
E_STRICT: 2048
E_DEPRECATED: 8192
test_file_timedifference: No time difference found
test_db_timedifference: No time difference found
create_dir_and_file: 1
memory_limit: 128M
max_execution_time: 30
register_globals: Off (False)
output_buffering: 4096
disable_functions: show_source, system, shell_exec, passthru, exec, popen, proc_open
open_basedir:
test_remote_url: Success
file_uploads: On (True)
post_max_size: 8M
upload_max_filesize: 2M
session_save_path: /opt/alt/php73/var/lib/php/session (0700)
session_use_cookies: On (True)
xml_function: On (True)
xmlreader_class: On (True)
check_ini_set: On (True)
curl: On

Performance Information:

allow_browser_cache: On (True)
browser_cache_expiry: 60
php_opcache: Off (False)
smarty_cache: Off (False)
smarty_compilecheck: Off (False)
auto_clear_cache_age: On (True)
Server Information:

Server Software: Apache
Server Api: cgi-fcgi
Server Os: Linux 3.10.0-962.3.2.lve1.5.26.5.el7.x86_64 On x86_64
Server Db Type: MySQL (mysqli)
Server Db Version: 5.7.28
Server Db Grants: Found a "GRANT ALL" statement that appears to be suitable

Permission Information:

tmp: /home/mansweb/public_html/crazy/tmp (0755)
tmp_cache: /home/mansweb/public_html/crazy/tmp/cache (0755)
templates_c: /home/mansweb/public_html/crazy/tmp/templates_c (0755)
modules: /home/mansweb/public_html/crazy/modules (0755)
uploads: /home/mansweb/public_html/crazy/uploads (0755)
File Creation Mask (umask): /home/mansweb/public_html/crazy/tmp/cache (0755)
config_file: 0644
----------------------------------------------


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Bug [NOT A BUG] in Newsletter Made Simple?
PostPosted: Tue Nov 12, 2019 10:28 pm 
Offline
Forum Members
Forum Members

Joined: Sun Oct 28, 2007 4:14 am
Posts: 222
Location: Australia
So I installed NMS in another site on another server-- same company, exactly the same server config. It works fine.

So a clean softaculous install, and my years old website are both killing the viewing of address lists and users. It sounds like something on my server... :(


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Bug in Newsletter Made Simple?
PostPosted: Wed Nov 13, 2019 12:51 am 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 868
Location: Victoria, BC
If there's nothing in the error log, I would suggest finding out if mod_security is on your server. It doesn't seem typical of the issues caused by mod_security, but it's something to rule out anyway.

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Bug in Newsletter Made Simple?
PostPosted: Wed Nov 13, 2019 3:51 am 
Offline
Forum Members
Forum Members

Joined: Sun Oct 28, 2007 4:14 am
Posts: 222
Location: Australia
Thanks Digi3. ModSecurity is on the serve, but I can turn it off for the domain... This makes no difference. It is also on the server where NMS works just fine...

I have found an error log in the admin folder. That has the following errors which arrived after I removed modules I can exist without to see if there were any clashes they were causing. No difference in the result, but these are the errors:

\$1:
[13-Nov-2019 06:11:49 Australia/Brisbane] PHP Warning: Invalid argument supplied for foreach() in /home/adminfolder/public_html/modules/NMS/function.admin_lists_tab.php on line 53
[13-Nov-2019 06:16:02 Australia/Brisbane] PHP Warning: Invalid argument supplied for foreach() in /home/adminfolder/public_html/modules/NMS/function.admin_lists_tab.php on line 53
[13-Nov-2019 13:15:20 Australia/Brisbane] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /home/adminfolder/public_html/lib/classes/class.moduleoperations.inc.php on line 933
[13-Nov-2019 13:19:55 Australia/Brisbane] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /home/adminfolder/public_html/lib/classes/class.moduleoperations.inc.php on line 933
[13-Nov-2019 13:20:34 Australia/Brisbane] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /home/adminfolder/public_html/lib/classes/class.moduleoperations.inc.php on line 933
[13-Nov-2019 13:23:45 Australia/Brisbane] PHP Warning: Invalid argument supplied for foreach() in /home/adminfolder/public_html/modules/NMS/function.admin_lists_tab.php on line 53


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Bug in Newsletter Made Simple?
PostPosted: Wed Nov 13, 2019 4:46 am 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 868
Location: Victoria, BC
Those look like PHP 7.3 warnings, does switching to 7.2 help?

Remember to clear the CMSMS cache after any change, including after disabling modsec or switching php versions.

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Bug in Newsletter Made Simple?
PostPosted: Wed Nov 13, 2019 10:11 am 
Offline
Forum Members
Forum Members

Joined: Sun Oct 28, 2007 4:14 am
Posts: 222
Location: Australia
Both servers are 7.3; ie the one that works and the one that doesn't work with NMS. I dialed them both back to 7.2 and get nothing but a blank website front page and blank website login page on both. :(


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Bug in Newsletter Made Simple?
PostPosted: Thu Nov 14, 2019 7:42 am 
Offline
Forum Members
Forum Members

Joined: Sun Oct 28, 2007 4:14 am
Posts: 222
Location: Australia
So I tried php 7.1 on both servers instead of just going back from 7.3 to 7.2.. The sites and the backends both work at 7.1-- no more white page like 7.3. But it makes no difference to NMS. Lists and users are invisible.

I tried a test install in a subdir on my site, in case the softaculous install did something odd. Still no lists and users visible.

I went into php and checked what functions were loaded. The server where everything works had a couple less. I loaded them. No difference. Still works there.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Bug in Newsletter Made Simple?
PostPosted: Thu Nov 14, 2019 3:35 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 868
Location: Victoria, BC
Anything in the console? (F12)

Can you make an exact copy of the "bad" site to the "good" server, so you can determine whether it's the server or the site?

_________________
Not getting the answer you need? CMSMS support options


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Bug in Newsletter Made Simple?
PostPosted: Fri Nov 15, 2019 12:19 am 
Offline
Forum Members
Forum Members

Joined: Sun Oct 28, 2007 4:14 am
Posts: 222
Location: Australia
Thanks mate.

There are no errors listed in the console, or in the warnings tab. I'm not competent to get much past there.

However, like you, I've suspected the server setup. I was planning to go to the hosting support, but took your advice and created the identical site on the other server by zipping up the folders (minus the uploads) and exporting and restoring the database. Voila: NMS works in all it's glory.

So it's something on my server, it would seem.

I'll talk to them next.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Hosting Nation - Managed CMSMS Hosting