• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: CGBetterForm inside Widget not working properly
PostPosted: Mon May 13, 2019 11:32 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Wed Aug 29, 2007 4:36 am
Posts: 246
Location: Sydney Australia
I have a very simple contact form in CGBetterForms that works perfectly when placed in page content.
I have 'inline' set to no and the form output displays a message after submit.

If I set 'inline' to yes I get an error alert, on submit, saying "Please specify a form name when calling CGBetterForms".

I have also put the same contact form in a widget (Widgets module) with 'inline' set to yes or no.
With inline=yes, the form should be replaced with the form output message.
With inline=no, the page content should be replaced with the form output message.
The form sends correctly, on submit, but there is no output display message, the form remains with fields still filled in.

Latest Core and Modules as of 14may19.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Hosting Nation - Managed CMSMS Hosting