CMS Made Simple Forums
https://forum.cmsmadesimple.org/

Problems with cataloger after Upgrade 1.12.2 auf 2.2.8
https://forum.cmsmadesimple.org/viewtopic.php?f=7&t=79338
Page 1 of 1

Author:  rx9 [ Fri Nov 02, 2018 3:37 pm ]
Post subject:  Problems with cataloger after Upgrade 1.12.2 auf 2.2.8  Topic is solved

Hey guys,

they say never change a running system but for security reasons I tried to upgrade 1.12.2 to 2.2.8. After solving Error 500 and other problems with some modules, i handled to login to the backend.
But there is an error with the Cataloger module, I couldn't resolve.
In the frontend I get the message:
Code:
[== ERROR ==]
Warning: Declaration of CatalogCategory::AddProperty($name, $priority, $tab = self::TAB_MAIN, $required = false) should be compatible with ContentBase::AddProperty($name, $priority, $tab = self::TAB_MAIN, $required = false, $basic = false) in /cmsms/modules/Cataloger/lib/class.CatalogCategory.php on line 711 Warning: Declaration of CatalogItem::AddProperty($name, $priority, $tab = self::TAB_MAIN, $required = false) should be compatible with ContentBase::AddProperty($name, $priority, $tab = self::TAB_MAIN, $required = false, $basic = false) in /cmsms/modules/Cataloger/lib/class.CatalogItem.php on line 659

I tried to upgrade to the newest version and updated the templates scopes. But now, I have no idea how to keep going.

Does someone have an idea?

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/