CMS Made Simple Forums
https://forum.cmsmadesimple.org/

Sitemap file has not yet been created.
https://forum.cmsmadesimple.org/viewtopic.php?f=7&t=79021
Page 1 of 1

Author:  gianpiero [ Thu Sep 06, 2018 3:15 pm ]
Post subject:  Sitemap file has not yet been created.

Sorry for this I've seen previous topics about this but I'm not able to solve.

ex
viewtopic.php?f=7&t=77925

I've the same problem

Sitemap file has not yet been created.
First create a new module template as described in the documentation.
Update the Name and Module Tag as you need it!
A new sitemap(-index) file will be created after submit.


I'm coming from 1.9.9.2 upgraded to 2.2.8, system info and config is:

https://pastebin.com/gMwxYZ2m

The template Sitemap News exist :

Code:
<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">
{foreach from=$items item=entry}
<url>
  <loc>{$entry->moreurl}</loc>
  <lastmod>{$entry->modified_date|date_format:'%Y-%m-%d'}</lastmod>
  <changefreq>{math now=$smarty.now modified=strtotime($entry->modified_date) equation='(now-modified)/86400' assign='days'}{if $days < 2}hourly{elseif $days < 14}daily{elseif $days < 61}weekly{elseif $days < 365}monthly{else}yearly{/if}</changefreq>
  <priority>0.6</priority>
</url>
{/foreach}
</urlset>


NOTE:

- Sitemap Pages works on the same site from the beginning of the installation

- I've installed on a clean 2.2.8 site and is working normally

- Sitemap version is 1.5.3

Thanks in advance for any suggestion

Gianpiero

Author:  Rolf [ Thu Sep 06, 2018 3:56 pm ]
Post subject:  Re: Sitemap file has not yet been created.

When you enable debug in config.php what happens than?
Anything in server Error Log?

Author:  gianpiero [ Thu Sep 06, 2018 5:02 pm ]
Post subject:  Re: Sitemap file has not yet been created.

Thanks for your quick reply

Into the ADMIN PAGE when i create the news sitemap appear:

Code:
Debug: (0.236532) - (net usage: 2206408) - (peak: 2520800)

SELECT sitemap_id FROM cms_module_sitemapmgr WHERE sitemap_name='News'

Debug: (0.236914) - (net usage: 2207440) - (peak: 2521136)

Sitemap ID: 5

Debug is on. Redirecting disabled... Please click this link to continue.
http://mysite/admin/moduleinterface.php?mact=SitemapMgr,m1_,defaultadmin,0&__c=96b1f866fa40bfe4484&m1_active_tab=sitemaps&m1_message=sitemap_created
Debug: (0.003767) - (net usage: 264176) - (peak: 512920)

Initialize Database

Debug: (0.007022) - (net usage: 359416) - (peak: 610744)

Done Initializing Database

Debug: (0.007061) - (net usage: 360160) - (peak: 611360)

initialize internal global cache

Debug: (0.008355) - (net usage: 477008) - (peak: 789520)

done initializing global cache

Debug: (0.008411) - (net usage: 475008) - (peak: 789520)

Loading Modules

Debug: (0.015454) - (net usage: 1154728) - (peak: 1411976)

SET @CG_ZEROTIME = NOW() - INTERVAL 150 YEAR,@CG_FUTURETIME = NOW() + INTERVAL 5 YEAR

Debug: (0.020283) - (net usage: 1619792) - (peak: 1883840)

SELECT username, password, active, first_name, last_name, admin_access, email FROM cms_users WHERE user_id = 1

Debug: (0.086992) - (net usage: 1627240) - (peak: 1891568)

SELECT preference,value FROM cms_userprefs WHERE user_id = 1

Debug: (0.08793) - (net usage: 1725512) - (peak: 1994864)

End of Loading Modules

Debug: (0.089932) - (net usage: 1741248) - (peak: 2035240)

SELECT * FROM cms_mod_cmsjobmgr WHERE start < UNIX_TIMESTAMP() AND created < UNIX_TIMESTAMP() ORDER BY errors ASC,created ASC LIMIT 1

Debug: (0.09094) - (net usage: 1751512) - (peak: 2035240)

SELECT * FROM cms_content WHERE content_id = 1 LIMIT  1

Debug: (0.092905) - (net usage: 1927680) - (peak: 2209896)

UPDATE cms_siteprefs SET sitepref_value = 1536252359 WHERE sitepref_name = 'CmsJobManager_mapi_pref_last_async_trigger'

Debug: (0.228902) - (net usage: 1867640) - (peak: 2210032)

Initialize Smarty

Debug: (0.228952) - (net usage: 1868040) - (peak: 2210032)

Done Initialing Smarty

Debug: (0.22916) - (net usage: 1869424) - (peak: 2210032)

SELECT sitepref_name,sitepref_value FROM cms_siteprefs

Debug: (0.232317) - (net usage: 2010040) - (peak: 2364136)

SELECT group_id FROM cms_user_groups WHERE user_id = 1

Debug: (0.23336) - (net usage: 2203072) - (peak: 2518104)

Nothing is known about CGBlog... cant load it

Debug: (0.23339) - (net usage: 2203496) - (peak: 2518424)

Nothing is known about CGCalendar... cant load it

Debug: (0.233411) - (net usage: 2203792) - (peak: 2518472)

Nothing is known about CompanyDirectory... cant load it

Debug: (0.233429) - (net usage: 2204088) - (peak: 2518520)

Nothing is known about LISE... cant load it

Debug: (0.233447) - (net usage: 2204376) - (peak: 2518568)

Nothing is known about Products... cant load it

Debug: (0.233786) - (net usage: 2205144) - (peak: 2519008)

SELECT count(*) FROM `cms_module_sitemapmgr` WHERE sitemap_name = 'News' LIMIT  1

Debug: (0.234142) - (net usage: 2205640) - (peak: 2519480)

SELECT count(*) FROM `cms_module_sitemapmgr` WHERE sitemap_name = 'News' LIMIT  1

Debug: (0.236498) - (net usage: 2208472) - (peak: 2520152)

INSERT INTO cms_module_sitemapmgr (`sitemap_name`, `sitemap_type`, `sitemap_tag`) VALUES ('News','sitemap_news','{News summarytemplate=\'cms_template:Sitemap News\'}')

Debug: (0.236873) - (net usage: 2207312) - (peak: 2521136)

SELECT sitemap_id FROM cms_module_sitemapmgr WHERE sitemap_name='News'

Debug: (0.268432) - (net usage: 2237288) - (peak: 2757216)

SELECT * FROM cms_module_sitemapmgr ORDER BY sitemap_name

Debug display of 'Fetch /home/mysite/public_html/modules/SitemapMgr/templates/default_sitemap_index.tpl start':(0.268523) - (net usage: 2241152) - (peak: 2757216)
Debug display of 'Fetch /home/mysite/public_html/modules/SitemapMgr/templates/default_sitemap_index.tpl end':(0.281304) - (net usage: 3932624) - (peak: 4264840)
Debug: (0.282144) - (net usage: 3936248) - (peak: 4265448)

INSERT INTO cms_adminlog (timestamp, user_id, username, item_id, item_name, action, ip_addr) VALUES (1536252358,1,'adminloginuser',-1,'SitemapMgr','A new sitemap tab is created, check the settings there!','95.237.232.203')



Sorry but error log on server I can't find at this moment, I'll return tomorrow whan the ticket service of my provider is "active not over time"

Anyway there is no error_log in the root, I can't find other logs related to this our and event

Author:  gianpiero [ Fri Sep 07, 2018 12:08 pm ]
Post subject:  Re: Sitemap file has not yet been created.

Ok

I've seen the error log of yesterday, no error related to SitemapMgr yesterday

A few minute ago I created a new sitemap for news, to reproduce the error, result is: IT WORKS an the Sitemap News is on line ;D

Is this a mystery ? ??? ??? ???

Author:  Rolf [ Fri Sep 07, 2018 12:46 pm ]
Post subject:  Re: Sitemap file has not yet been created.  Topic is solved

Glad it works now. Have fun with SitemapMgr!

Author:  gianpiero [ Fri Sep 07, 2018 4:10 pm ]
Post subject:  Re: Sitemap file has not yet been created.

I have two sites with the modules runnning, thanks ;D

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/