CMS Made Simple Forums
https://forum.cmsmadesimple.org/

Newsletter Made Simple (NMS) - Jobs starting but not sending
https://forum.cmsmadesimple.org/viewtopic.php?f=7&t=77556
Page 1 of 1

Author:  webform [ Thu Nov 02, 2017 2:15 pm ]
Post subject:  Newsletter Made Simple (NMS) - Jobs starting but not sending

I've updated an old installation running NMS and now i can't get it to process and send jobs/newsletters. Jobs always have the status "Starting" but is not sending anything.

I can send and receive test Email within NMS.
I can send and receive test Email from Mail Settings in Global Configuration (Mailer => Mail).
I've setup "Bounce Processing" in NMS with an active email account.
I've created a Cronjob handling the Job Processing URL in CGJobMgr.
"There are no jobs in the database" message is displayed in CGJobMgr.

Maybe i'm missing some setting or an action to do in either NMS or CGJobMgr?

Code:
----------------------------------------------
Cms Version: 2.2.3.1
Installed Modules:
AdminSearch: 1.0.4
CGCalendar: 2.5
CGExtensions: 1.57.1
CGFeedMaker: 1.0.11
CGFeedback: 2.1
CGHeadMaster: 1.0.13
CGJobMgr: 1.3.6
CGSimpleSmarty: 2.1.7
CGSmartImage: 1.22.1
CGUserDirectory: 1.5.1
CMSContentManager: 1.1.6
CMSMailer: 6.2.14
CmsJobManager: 0.1.1
CompanyDirectory: 1.23.5
CustomContent: 1.8.2
CustomGS: 3.2
DesignManager: 1.1.3
ECB2: 1.3.1
FAQ: 2.0.3
FileManager: 1.6.4
FilePicker: 1.0.1
FormBrowser: 0.5
FormBuilder: 0.8.1.6
Forum: 0.9.4
FrontEndUsers: 2.7.1
Gallery: 2.3.2
JMFilePicker: 1.0.1
JQueryTools: 1.4.0.3
LISE: 1.3.1
LISESlideshow: 1.3.1
MenuManager: 1.50.3
MicroTiny: 2.2.1
ModuleManager: 2.1.2
NMS: 2.13
Navigator: 1.0.8
News: 2.51.3
Printing: 1.1.2
Search: 1.51.2
SelfRegistration: 1.12
Smileys: 0.2.0
ThemeManager: 1.1.8
TreeManager: 0.6.0
Uploads: 1.25.8

Config Information:
php_memory_limit:
max_upload_size: 100000000
url_rewriting: mod_rewrite
page_extension: .html
query_var: page
auto_alias_content: true
locale: da_DK.utf8
set_names: true
timezone: Europe/Copenhagen
permissive_smarty: true

Php Information:
phpversion: 7.0.25
md5_function: Fra (Sand)
json_function: Fra (Sand)
gd_version: 2
tempnam_function: Fra (Sand)
magic_quotes_runtime: Til (Falsk)
E_ALL: 32757
E_STRICT: 2048
E_DEPRECATED: 8192
test_file_timedifference: No time difference found
test_db_timedifference: No time difference found
create_dir_and_file: 1
memory_limit: 512M
max_execution_time: 3000
register_globals: Til (Falsk)
output_buffering: 4096
disable_functions: link, symlink, exec, passthru, shell_exec, system, proc_open, proc_nice, popen, dl, show_source
open_basedir: /tmp:/hsphere/local/home:/hsphere/shared/apache/htdocs:/usr/local/lsws/share/autoindex:/usr/local/lsws/lsphp7/share/pear/:/dev/urandom
test_remote_url: Succes
file_uploads: Fra (Sand)
post_max_size: 100M
upload_max_filesize: 100M
session_save_path: Kan ikke kontrolleres pga af at open_basedir er aktiv
session_use_cookies: Fra (Sand)
xml_function: Fra (Sand)
xmlreader_class: Fra (Sand)
check_ini_set: Fra (Sand)
curl: Fra

Performance Information:
allow_browser_cache: Til (Falsk)
browser_cache_expiry: 60
php_opcache: Fra (Sand)
smarty_cache: Til (Falsk)
smarty_compilecheck: Til (Falsk)
auto_clear_cache_age: Til (Falsk)
Server Information:
Server Software: LiteSpeed
Server Api: litespeed
Server Os: Linux 2.6.32-696.13.2.el6.x86_64 Fra x86_64
Server Db Type: MySQL (mysqli)
Server Db Version: 5.6.38
Server Db Grants: Et "GRANT ALL" statement, som ser ud til at kunne bruges, fundet

Permission Information:
tmp: /hsphere/local/home/webform2/macbruger.dk/tmp (0777)
tmp_cache: /hsphere/local/home/webform2/macbruger.dk/tmp/cache (0777)
templates_c: /hsphere/local/home/webform2/macbruger.dk/tmp/templates_c (0777)
modules: /hsphere/local/home/webform2/macbruger.dk/modules (0777)
uploads: /hsphere/local/home/webform2/macbruger.dk/uploads (0777)
Filoprettelsesmaske (umask): /hsphere/local/home/webform2/macbruger.dk/tmp/cache (0777)
config_file: 0444
----------------------------------------------

Author:  webform [ Wed Nov 08, 2017 4:47 pm ]
Post subject:  Re: Newsletter Made Simple (NMS) - Jobs starting but not sen

Still no luck to get NMS to send newsletters.

I've tried to change mail setting from "mail" to "smtp". Test mails send just fine and i receive them.

I've tried to reupload NMS.

Background Job Manager message is "Initialize Sending of job 266" but admin log is "CmsJobManager An error occurred while processing: Initialize Sending of job 266".

Calguys Job Processing Manager message is "There are no jobs in the database".

The Cron Job i've set up run on schedule without error message.

Anyone has any suggestions where the problem could be?

Maybe someone with a working NMS installation can share their setting?

Author:  Solutic [ Fri Nov 17, 2017 3:39 pm ]
Post subject:  Re: Newsletter Made Simple (NMS) - Jobs starting but not sen

Hello,

I have the exact same problem after update to latest version. I totally removed and re-installed NMS module with no luck at all, tried with default newsletter template.
Sending test email works well, but job stay on Background Job Manager
Code:
Initialize Sending of job 1    NMS    55 minutes ago    55 minutes ago


I also have this error on admin log:
Code:
CmsJobManager    An error occurred while processing: Initialize Sending of job 1


CMS information:

Code:
----------------------------------------------

Cms Version: 2.2.3.1

Installed Modules:

    AdminSearch: 1.0.4
    CGExtensions: 1.57.1
    CGFeedMaker: 1.0.20
    CGGoogleMaps2: 1.1.1
    CGSimpleSmarty: 2.1.7
    CGSmartImage: 1.22.1
    CMSContentManager: 1.1.6
    CMSMailer: 6.2.14
    CmsJobManager: 0.1.1
    DesignManager: 1.1.3
    ExaExternalizer: 0.6
    FileManager: 1.6.4
    FilePicker: 1.0.1
    FormBuilder: 0.8.1.6
    Gallery: 2.3.2
    JMFilePicker: 1.0.1
    JQueryTools: 1.4.0.3
    LISE: 1.3.1
    LISEOffresSpeciales: 1.3.1
    LISEhebergement: 1.3.1
    LISEpays: 1.3.1
    LISEregion: 1.3.1
    LISEtypeProduit: 1.3.1
    MenuManager: 1.50.3
    MicroTiny: 2.2.1
    ModuleManager: 2.1.2
    NMS: 2.13
    Navigator: 1.0.8
    News: 2.51.3
    Search: 1.51.2
    ThemeManager: 1.1.8
    TinyMCE: 3.2-beta3


Config Information:

    php_memory_limit: 768M
    max_upload_size: 20000000
    url_rewriting: mod_rewrite
    page_extension: .html
    query_var: page
    auto_alias_content: true
    locale:
    set_names: true
    timezone: Europe/Zurich
    permissive_smarty: false


Php Information:

    phpversion: 5.6.27-1+deb.sury.org~xenial+1
    md5_function: On (True)
    json_function: On (True)
    gd_version: 2
    tempnam_function: On (True)
    magic_quotes_runtime: Off (False)
    E_ALL: 22527
    E_STRICT: 0
    E_DEPRECATED: 0
    test_file_timedifference: No time difference found
    test_db_timedifference: No time difference found
    create_dir_and_file: 1
    memory_limit: 768M
    max_execution_time: 60
    register_globals: Off (False)
    output_buffering: 4096
    disable_functions: pcntl_alarm, pcntl_fork, pcntl_waitpid, pcntl_wait, pcntl_wifexited, pcntl_wifstopped, pcntl_wifsignaled, pcntl_wexitstatus, pcntl_wtermsig, pcntl_wstopsig, pcntl_signal, pcntl_signal_dispatch, pcntl_get_last_error, pcntl_strerror, pcntl_sigprocmask, pcntl_sigwaitinfo, pcntl_sigtimedwait, pcntl_exec, pcntl_getpriority, pcntl_setpriority,
    open_basedir:
    test_remote_url: Success
    file_uploads: On (True)
    post_max_size: 20M
    upload_max_filesize: 20M
    session_save_path: /var/lib/php/sessions (1733)
    session_use_cookies: On (True)
    xml_function: On (True)
    xmlreader_class: On (True)
    check_ini_set: On (True)
    curl: On


Performance Information:

    allow_browser_cache: On (True)
    browser_cache_expiry: 10
    php_opcache: On (True)
    smarty_cache: Off (False)
    smarty_compilecheck: Off (False)
    auto_clear_cache_age: On (True)

Server Information:

    Server Software: Apache/2.4.18 (Ubuntu)
    Server Api: apache2handler
    Server Os: Linux 4.4.0-47-generic On x86_64
    Server Db Type: MySQL (mysqli)
    Server Db Version: 5.7.16
----------------------------------------------


Does anyone have any idea ?

Author:  JamesT [ Fri Nov 17, 2017 10:43 pm ]
Post subject:  Re: Newsletter Made Simple (NMS) - Jobs starting but not sen

I'm having the same issue. NMS jobs sit permanently in Background Job Manager with the message "Initialize Sending of job".

The latest version of NMS was rewritten to use CmsJobManager instead of CGJobMgr to process the NMS jobs. it seems there may be a bug in the new implementation, so I've raised a bug report.

Author:  steven_germany [ Mon Nov 20, 2017 1:18 pm ]
Post subject:  Re: Newsletter Made Simple (NMS) - Jobs starting but not sen

Same problem here ...

any solutions?

Author:  JamesT [ Mon Nov 20, 2017 1:51 pm ]
Post subject:  Re: Newsletter Made Simple (NMS) - Jobs starting but not sen

It has been fixed for the next release.

Author:  steven_germany [ Mon Nov 20, 2017 2:02 pm ]
Post subject:  Re: Newsletter Made Simple (NMS) - Jobs starting but not sen

yes ... but unfortunatelly i need it very soon :-)

Author:  JamesT [ Mon Nov 27, 2017 5:59 pm ]
Post subject:  Re: Newsletter Made Simple (NMS) - Jobs starting but not sen

The latest version of NMS is working fine.

Author:  JamesT [ Mon Nov 27, 2017 6:07 pm ]
Post subject:  Re: Newsletter Made Simple (NMS) - Jobs starting but not sen

Actually there is one minor issue in that "Finish job" is not clearing from Background Job Manager, resulting in Admin Log entries of:

Quote:
"An error occurred while processing: Finish job", "Removing an expired lock. An error probably occurred with a previous job", and "nms job has invalid status".

But these errors all occurred after the emails had successfully been sent out.

Author:  kmesd62 [ Tue Dec 05, 2017 9:49 pm ]
Post subject:  Re: Newsletter Made Simple (NMS) - Jobs starting but not sen

[quote="JamesT"]The latest version of NMS is working fine.[/quote]

Unfortunately not for me (yet) - still have starting but not sending error after updating to NMS 2.13.1

* Cleared cache,
* NMS Job listing lists the job status "Starting..."
* Waited for cron to trigger in admin log, still says "Received 0 response when trying to trigger async processing"
* Bkgnd Job Mgr says "Initialize sending of job nnn nn minutes ago"

Repeated with a completely new NMS job, same results

I still have Calguys job processing manager still installed - can i remove if Bkgnd Job Mgr doing the same thing (kind of)?

Any ideas?

System info follows
----------------------------------------------
Cms Version: 2.2.3.1
Installed Modules:
AdminSearch: 1.0.4
AdvancedContent: 0.9.4.3
CGCalendar: 2.5
CGContentUtils: 2.2.2
CGExtensions: 1.57.1
CGGoogleMaps2: 1.1.1
CGJobMgr: 1.3.6
CGSimpleSmarty: 2.1.7
CGTiny: 1.2.8
CMSContentManager: 1.1.6
CMSMailer: 6.2.14
Captcha: 0.5.5
CmsJobManager: 0.1.1
CustomContent: 1.9
DesignManager: 1.1.3
DownloadManager: 1.5.3
FileManager: 1.6.4
FilePicker: 1.0.1
FormBrowser: 0.5
FormBuilder: 0.8.1.6
Forum: 0.9.4
FrontEndUsers: 2.7.1
Gallery: 2.3.2
JQueryTools: 1.4.0.3
MenuManager: 1.50.3
MicroTiny: 2.2.1
ModuleManager: 2.1.2
NMS: 2.13.1
Navigator: 1.0.8
News: 2.51.3
Notifications: 1.1
Printing: 1.1.2
Search: 1.51.2
SelfRegistration: 1.12
ThemeManager: 1.1.8
TinyMCE: 2.9.12
TreeManager: 0.6.0
XMLMadeSimple: 0.0.6

Author:  JamesT [ Tue Dec 05, 2017 10:36 pm ]
Post subject:  Re: Newsletter Made Simple (NMS) - Jobs starting but not sen

kmesd62 wrote:
I still have Calguys job processing manager still installed - can i remove if Bkgnd Job Mgr doing the same thing (kind of)?

Yes you can, if no other module depends on it. I didn't need to remove CGJobMgr to get NMS working, although I have removed it now you mentioned it. I also allows me to cancel the cron job it requires.

Author:  kmesd62 [ Wed Dec 06, 2017 12:03 am ]
Post subject:  Re: Newsletter Made Simple (NMS) - Jobs starting but not sen

[quote="JamesT"][quote="kmesd62"]I still have Calguys job processing manager still installed - can i remove if Bkgnd Job Mgr doing the same thing (kind of)?[/quote]
Yes you can, if no other module depends on it. I didn't need to remove CGJobMgr to get NMS working, although I have removed it now you mentioned it. I also allows me to cancel the cron job it requires.[/quote]

Ah... prior to CMSMS 2 upgrade I never had a cron job set up, I just used to navigate to CGJobMgr/Settings and open the URL that's there to initiate sending a newsletter manually - could this be a factor/is there something else I need to set up?

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/