SOLVED: spontaneous "smarty error, unknown tag gallery"

Have a question or a suggestion about a 3rd party addon module or plugin?
Let us know here.
Post Reply
dlen
Forum Members
Forum Members
Posts: 67
Joined: Fri Apr 09, 2010 11:32 pm

SOLVED: spontaneous "smarty error, unknown tag gallery"

Post by dlen »

Hi,

on the website the modules gallery and formbuilder don't work anymore. Instead the following messages appear:

Code: Select all

string(112) "Smarty error: [in content:content_en line 1]: [plugin] unknown tag - 'Gallery' (core.load_plugins.php, line 124)" Fatal error: Call to a member function function_plugin() on a non-object in /srv/www/vhosts/roswitha-sameen-jacobi.de/httpdocs/tmp/templates_c/56^%%70^707^707A8977%%content%3Acontent_en.php on line 5

Code: Select all

string(116) "Smarty error: [in content:content_en line 2]: [plugin] unknown tag - 'FormBuilder' (core.load_plugins.php, line 124)"
Fatal error: Call to a member function function_plugin() on a non-object in /srv/www/vhosts/roswitha-sameen-jacobi.de/httpdocs/tmp/templates_c/58^%%70^707^707A8977%%content%3Acontent_en.php on line 6
Interestingly, both modules have disappeared from the -->extensions -->modules list. In -->administration -->system protocol no uninstallation is registered, which is to be expected, because of course I didn't uninstall the modules. The module directories and files are still existing on the webspace.

Another interesting observation, which may or may not be of importance is, that in the -->extensions -->module manager list, both modules have in the column "status/action" the remark "could not download anything" (retranslated form german "Konnte nichts herunterladen").

This has all happened "spontaneously", i.e. without any action from my side. Three weeks ago all was well.

Could someone give me a hint where to look?
Last edited by dlen on Sat Feb 05, 2011 10:31 pm, edited 1 time in total.
User avatar
Dr.CSS
Moderator
Moderator
Posts: 12678
Joined: Thu Mar 09, 2006 5:32 am
Location: Arizona

Re: spontaneous "smarty error, unknown tag gallery"

Post by Dr.CSS »

As always, what version of CMSMS, have you cleared your admin/system cache?...
Check ver. CMSMS, PHP, server OS, in System Information page.
Default content http://multiintech.com/defaultcontent/
People are Wonderful
Business is Great
Life is Terrific
Ever wonder what happened to the Album module? Well it is alive and well.
http://album.multiintech.com/
Image
dlen
Forum Members
Forum Members
Posts: 67
Joined: Fri Apr 09, 2010 11:32 pm

Re: spontaneous "smarty error, unknown tag gallery"

Post by dlen »

Ah, yes, thanks: cms ve 1.9.2

Clearing the system cache changed the behaviour in such a way, that now the pages in question are displayed at all (which they weren't before), though without the module output. The first page access after clearing the cache yields the error message "string(128) "Smarty error: [in content:content_en line 2]: syntax error: unrecognized tag 'FormBuilder' (Smarty_Compiler.class.php, line 590)" " (analogous for the other module), at the following accesses nothing is produced by the modules.

Interestingly, in -->site admin -->system information the modules in question are listed properly.


----------------------------------------------

Cms Version: 1.9.2

Installed Modules:

CMSMailer: 2.0
FileManager: 1.0.3
MenuManager: 1.7.4
ModuleManager: 1.4
News: 2.11
nuSOAP: 1.0.2
Printing: 1.1.1
Search: 1.6.8
ThemeManager: 1.1.3
TinyMCE: 2.8.2
Gallery: 1.4.3
FormBuilder: 0.6.4

Config Information:

php_memory_limit:
process_whole_template: false
output_compression: false
max_upload_size: 250000000
default_upload_permission: 664
url_rewriting: internal
page_extension: .html
query_var: page
image_manipulation_prog: GD
auto_alias_content: true
locale:
default_encoding: utf-8
admin_encoding: utf-8
set_names: true

Php Information:

phpversion: 5.2.13
md5_function: An (Ja)
gd_version: 2
tempnam_function: An (Ja)
magic_quotes_runtime: Aus (Nein)
E_STRICT: 0
memory_limit: 128M
max_execution_time: 60
output_buffering: 4096
safe_mode: An (Ja)
file_uploads: An (Ja)
post_max_size: 8M
upload_max_filesize: 250M
session_save_path: Keine Prüfung, da eine "open basedir"-Beschränkung aktiviert ist
session_use_cookies: An (Ja)
xml_function: An (Ja)

Server Information:

Server Api: apache2handler
Server Db Type: MySQL (mysql)
Server Db Version: 5.0.67

----------------------------------------------
dlen
Forum Members
Forum Members
Posts: 67
Joined: Fri Apr 09, 2010 11:32 pm

Re: spontaneous "smarty error, unknown tag gallery"

Post by dlen »

Another observation:

If I look at it via -->contents -->file manager I see, that the directories in question have the owner "wwwrun", while all other directories have "ftp...". When I examine the content of the directories, all files in them have "root" as owner, "000" as permission code and "0" as size. The last two informations are erroneous, becaus with ftp, I can see normal file sizes and permission codes and can download normal files.

So it seems to boil down to the formidable "wwwrun problem". I only wonder why it occurred 7 weeks after module installation.

Via cmsms file manager I can change the permission of the directory to "777" but not of the contained files. Neither can I via ftp.

Now I downloaded the module directories, renamed them on the server, uploaded them again and alas! it works!
Post Reply

Return to “Modules/Add-Ons”