Module Manager broken after module install (2.2.15) Topic is solved

Have a question or a suggestion about a 3rd party addon module or plugin?
Let us know here.
Post Reply
d4creative
Forum Members
Forum Members
Posts: 56
Joined: Mon Nov 01, 2010 10:40 pm
Location: Sydney, Australia

Module Manager broken after module install (2.2.15)

Post by d4creative »

I just tried to install the CGBetterforms module (with CGExtensions) and it broke my module manager. The rest of the site seems to still be working, but the module manager gives me a plain screen with plain text that says:
Notice
The versions displayed here represent the latest XML files uploaded to the CMSMS module repository. They may or may not represent the latest available versions. Additionally, the module repository may only contain modules released within the last few months
Use at Your Own Risk

The modules displayed here are contributed by both the CMSMS Developers and independent third parties. We make no guarantees that the modules available here are functional, tested, or compatible with your system. You are encouraged to read the information found in the help and about links for each module before attempting the installation.
I don't know how to reverse the installation and try to repair whatever went wrong. Do I just delete the directories of the modules that were being installed when it broke? Is there anything else that gets changed when modules are installed?

Thanks in advance for any help or advice.


System info:


----------------------------------------------

Cms Version: 2.2.15

Installed Modules:

AdminSearch: 1.0.5
CMSContentManager: 1.1.9
CmsJobManager: 0.1.3
DesignManager: 1.1.9
FileManager: 1.6.12
FilePicker: 1.0.5
FormBuilder: 1.1.1
MenuManager: 1.50.3
MicroTiny: 2.2.5
ModuleManager: 2.1.8
Navigator: 1.0.9
News: 2.51.11
Search: 1.52


Config Information:

php_memory_limit:
max_upload_size: 2000000
url_rewriting: mod_rewrite
page_extension:
query_var: page
auto_alias_content: true
locale:
set_names: true
timezone: UTC
permissive_smarty: false


Php Information:

phpversion: 7.3.26
md5_function: On (True)
json_function: On (True)
gd_version: 2
tempnam_function: On (True)
magic_quotes_runtime: Off (False)
E_ALL: 32767
E_STRICT: 2048
E_DEPRECATED: 8192
test_file_timedifference: No time difference found
test_db_timedifference: No time difference found
create_dir_and_file: 1
memory_limit: 128M
max_execution_time: 30
register_globals: Off (False)
output_buffering: 4096
disable_functions:
open_basedir:
test_remote_url: Success
file_uploads: On (True)
post_max_size: 8M
upload_max_filesize: 2M
session_save_path: /opt/alt/php73/var/lib/php/session (0700)
session_use_cookies: On (True)
xml_function: On (True)
xmlreader_class: On (True)
check_ini_set: On (True)
curl: On


Performance Information:

allow_browser_cache: On (True)
browser_cache_expiry: 60
php_opcache: Off (False)
smarty_cache: Off (False)
smarty_compilecheck: Off (False)
auto_clear_cache_age: On (True)

Server Information:

Server Software: Apache
Server Api: litespeed
Server Os: Linux 3.10.0-962.3.2.lve1.5.27.el7.x86_64 On x86_64
Server Db Type: MySQL (mysqli)
Server Db Version: 10.3.27
Server Db Grants: Found a "GRANT ALL" statement that appears to be suitable


Permission Information:

tmp: /home/ifvocals/public_html/tmp (0755)
tmp_cache: /home/ifvocals/public_html/tmp/cache (0755)
templates_c: /home/ifvocals/public_html/tmp/templates_c (0755)
modules: /home/ifvocals/public_html/modules (0755)
uploads: /home/ifvocals/public_html/uploads (0755)
File Creation Mask (umask): /home/ifvocals/public_html/tmp/cache (0755)
config_file: 0440

----------------------------------------------
d4creative
Forum Members
Forum Members
Posts: 56
Joined: Mon Nov 01, 2010 10:40 pm
Location: Sydney, Australia

Re: Module Manager broken after module install (2.2.15)

Post by d4creative »

SO here's what I tried:

I deleted the installed folders of CGExtensions and CGBetterforms.
I also deleted the MenuManager module folder as I had previously uninstalled that one - it is marked as deprecated and not used in my current theme, so I assume that it should NOT be necessary.

Having removed those folders, the Module Manager started working properly again.

So I tried again to install CGExtensions module. And it failed, giving me a "405 Not Allowed" error.

Can anyone explain this for me?
d4creative
Forum Members
Forum Members
Posts: 56
Joined: Mon Nov 01, 2010 10:40 pm
Location: Sydney, Australia

Re: Module Manager broken after module install (2.2.15)

Post by d4creative »

Soooo...
I refreshed the site admin page and this time saw the module downloaded but not installed. So it installed correctly. Then CG Betterforms installed correctly also.

Maybe it is having issues with Firefox browser somehow timing out?
User avatar
velden
Dev Team Member
Dev Team Member
Posts: 3348
Joined: Mon Nov 28, 2011 9:29 am
Location: The Netherlands

Re: Module Manager broken after module install (2.2.15)

Post by velden »

Side note regarding the use of CG modules. If your building a new website consider using other modules for now.

https://www.cmsmadesimple.org/2021/03/S ... pdate-2021
https://www.cmsmadesimple.org/module-forking-project
d4creative
Forum Members
Forum Members
Posts: 56
Joined: Mon Nov 01, 2010 10:40 pm
Location: Sydney, Australia

Re: Module Manager broken after module install (2.2.15)

Post by d4creative »

velden wrote: Wed May 26, 2021 9:00 am Side note regarding the use of CG modules. If your building a new website consider using other modules for now.

https://www.cmsmadesimple.org/2021/03/S ... pdate-2021
https://www.cmsmadesimple.org/module-forking-project
So what is the best / recommended Form module to use now then? I couldn't see another obvious option?
User avatar
velden
Dev Team Member
Dev Team Member
Posts: 3348
Joined: Mon Nov 28, 2011 9:29 am
Location: The Netherlands

Re: Module Manager broken after module install (2.2.15)

Post by velden »

d4creative
Forum Members
Forum Members
Posts: 56
Joined: Mon Nov 01, 2010 10:40 pm
Location: Sydney, Australia

Re: Module Manager broken after module install (2.2.15)

Post by d4creative »

velden wrote: Wed May 26, 2021 9:24 am FormBuilder http://dev.cmsmadesimple.org/projects/formbuilder
I was under the impression that CGBetterforms was meant to be the replacement for Form Builder. I already had Form Builder installed so I'll just go back to that then. The lack of options in CMSMS is definitely the weak point. Or maybe it's better than the millions of plugins to sift through in WP. I dunno... :-\ ???

Thanks for the tips.
johnboyuk1
Forum Members
Forum Members
Posts: 117
Joined: Mon Nov 26, 2018 3:09 pm

Re: Module Manager broken after module install (2.2.15)

Post by johnboyuk1 »

Worth also clearing the site cache if you havent done so? (in System Maintenance)

CGBetterforms still works ok for me and I find it easier to customise (with Bootstrap) than FormBuilder

I dont think the replacement forked module for CGBetterForms is out yet (SmartForms) ... looks like it should be soon
d4creative
Forum Members
Forum Members
Posts: 56
Joined: Mon Nov 01, 2010 10:40 pm
Location: Sydney, Australia

Re: Module Manager broken after module install (2.2.15)

Post by d4creative »

I am an avid cache-clearer when doing development of new websites. 8)
Post Reply

Return to “Modules/Add-Ons”