• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Tiny MCE not uploading images
PostPosted: Mon Sep 18, 2017 5:15 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Sat Apr 18, 2009 10:09 pm
Posts: 1425
Location: Maidenhead, UK
Content > Pages > Edit page > Insert/edit image to insert a new image
Click "find file" icon
Click "upload" icon
Drop a small jpg into the window
It appears to upload OK and a thumbnail is shown with a "X" across it
(Directory into which I am trying to upload has permissions 755)
When I hover over the image I see the start of the HTML for a 404 error page in a bubble, see screenshot:

Attachment:
filemanager.jpg
filemanager.jpg [ 52.86 KiB | Viewed 1073 times ]


When I click "return to files list" my new image is not listed.

Same thing happens with main admin account and a lesser editor account.

What could be the cause of that?

This installation is quite a few years old and has been updated several times.

The other strange thing is the module manager shows "This module is awaiting upgrade" on many core modules. See screenshot:

Attachment:
modulemanager.jpg
modulemanager.jpg [ 219.14 KiB | Viewed 1073 times ]


Clicking "upgrade" on those gives error "The CMSMS core must be upgraded before this operation can succeed."

Have tried clearing CMSMS cache and refreshing the install.

----------------------------------------------
Cms Version: 2.2.3.1
Installed Modules:
AdminSearch: 1.0.2
CGCalendar: 2.4.4
CGExtensions: 1.55.6
CGSimpleSmarty: 2.1.6
CMSContentManager: 1.1.1
CMSMailer: 6.2.14
CustomGS: 3.1
DesignManager: 1.1.1
ECB2: 1.3.1
FileManager: 1.5.2
FrontEndUsers: 2.1.1
Gallery: 2.3.2
ListIt2: 1.4.1
ListIt2GovernorTeam: 1.4.1
MenuManager: 1.50.2
MicroTiny: 2.0.3
ModuleManager: 2.0.4
Navigator: 1.0.3
News: 2.50.5
Search: 1.50.2
Showtime2: 3.5.4
SimpleSiteInfo: 3.3
Statistics: 1.2.1.2
ThemeManager: 1.1.8
TinyMCE: 3.2-beta3
UsersGuide: 2.0

Config Information:
php_memory_limit:
max_upload_size: 2000000
url_rewriting: mod_rewrite
page_extension:
query_var: page
auto_alias_content: true
locale:
set_names: true
timezone: Europe/London
permissive_smarty: false

Php Information:
phpversion: 5.6.31
md5_function: On (True)
json_function: On (True)
gd_version: 2
tempnam_function: On (True)
magic_quotes_runtime: Off (False)
E_ALL: 32767
E_STRICT: 2048
E_DEPRECATED: 8192
test_file_timedifference: No time difference found
test_db_timedifference: No time difference found
create_dir_and_file: 1
memory_limit: 128M
max_execution_time: 30
register_globals: Off (False)
output_buffering: 4096
disable_functions:
open_basedir:
test_remote_url: Success
file_uploads: On (True)
post_max_size: 8M
upload_max_filesize: 2M
session_save_path: /tmp (0700)
session_use_cookies: On (True)
xml_function: On (True)
xmlreader_class: On (True)
check_ini_set: On (True)
curl: On

Performance Information:
allow_browser_cache: Off (False)
browser_cache_expiry: 60
php_opcache: On (True)
smarty_cache: Off (False)
smarty_compilecheck: Off (False)
auto_clear_cache_age: Off (False)
Server Information:
Server Software: Apache
Server Api: cgi-fcgi
Server Os: Linux 3.10.0-714.10.2.lve1.4.63.el7.x86_64 On x86_64
Server Db Type: MySQL (mysqli)
Server Db Version: 10.1.24
Server Db Grants: Found a "GRANT ALL" statement that appears to be suitable

Permission Information:
tmp: /home/stedward/public_html/tmp (0755)
tmp_cache: /home/stedward/public_html/tmp/cache (0755)
templates_c: /home/stedward/public_html/tmp/templates_c (0755)
modules: /home/stedward/public_html/modules (0755)
uploads: /home/stedward/public_html/uploads (0755)
File Creation Mask (umask): /home/stedward/public_html/tmp/cache (0755)
config_file: 0444
----------------------------------------------

_________________
To copy System Information to the forum:
https://docs.cmsmadesimple.org/troubles ... nformation

CMS Made Simple Geekmoots attended:
Nottingham, UK 2012 | Ghent, Belgium 2015 | Leicester, UK 2016


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Tiny MCE not uploading images
PostPosted: Tue Sep 19, 2017 9:03 am 
Offline
Forum Members
Forum Members
User avatar

Joined: Fri Dec 09, 2005 12:36 pm
Posts: 228
Location: Marlow, UK
There's a post here about the module upgrade issue. (Essentially try removing the moduleinfo.ini files from some modules to see you can then upgrade them).

Might be worth trying to do that first and see if that sorts the file upload issue.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Tiny MCE not uploading images
PostPosted: Tue Sep 19, 2017 4:26 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Sat Apr 18, 2009 10:09 pm
Posts: 1425
Location: Maidenhead, UK
Thank you scooper.

From that thread:
Quote:
PS: to be more precise, the files are named moduleinfo.ini and reside in each modules root folder.

I looked at my site, checked MenuManager, DesignManager, FileManager and AdminSearch all of which show "This module is awaiting upgrade" in Module Manager but none of them have this file. I am viewing hidden files too.

Here's /modules/AdminSearch:

Attachment:
adminsearch.jpg
adminsearch.jpg [ 42.34 KiB | Viewed 1039 times ]


???

_________________
To copy System Information to the forum:
https://docs.cmsmadesimple.org/troubles ... nformation

CMS Made Simple Geekmoots attended:
Nottingham, UK 2012 | Ghent, Belgium 2015 | Leicester, UK 2016


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Tiny MCE not uploading images
PostPosted: Tue Nov 14, 2017 1:36 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Sat Apr 18, 2009 10:09 pm
Posts: 1425
Location: Maidenhead, UK
Still wondering about this one.

I use cpanel File Manager in my hosting, and the option to show all files is "Show Hidden Files (dotfiles)" so I am wondering if files which are hidden but do not start with a dot are not shown?

Also checked with FTP - no moduleinfo.ini anywhere...

Why don't I have any moduleinfo.ini ???

_________________
To copy System Information to the forum:
https://docs.cmsmadesimple.org/troubles ... nformation

CMS Made Simple Geekmoots attended:
Nottingham, UK 2012 | Ghent, Belgium 2015 | Leicester, UK 2016


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Tiny MCE not uploading images
PostPosted: Fri Nov 17, 2017 5:15 pm 
Offline
Forum Members
Forum Members
User avatar

Joined: Sun Sep 05, 2010 6:11 am
Posts: 154
Location: Worcester, UK
Hi Paul, did you get to the bottom of this one? I also use cPanel and just found that if I go the the /modules dir and Search in 'Current Directory' for 'moduleinfo.ini' it seems to find them.

Although only 31/38 modules had moduleinfo.ini files

Note: a Search in 'All Your Files' didn't seem to find many at all!

_________________
Regards

Kiwi Chris
Web design Worcester & Sheffield, UK


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Tiny MCE not uploading images
PostPosted: Fri Dec 08, 2017 4:18 pm 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Sat Apr 18, 2009 10:09 pm
Posts: 1425
Location: Maidenhead, UK
Thanks Chris, a search in cpanel file manager does help find the moduleinfo.ini files. However in the same site as I mention above, it only finds 9 moduleinfo.ini files in 27 modules.

However, going back to the original post, when I deleted moduleinfo.ini for the modules showing "This module is awaiting upgrade" and which had a moduleinfo.ini file (e.g. CGCalendar, CustomGS), it made no difference to the end result when I tried clicking Upgrade - I still got "The CMSMS core must be upgraded before this operation can succeed" as before.

And a core upgrade to 2.2.4 has made it no better (or worse). So I'm no further forward. :-\

_________________
To copy System Information to the forum:
https://docs.cmsmadesimple.org/troubles ... nformation

CMS Made Simple Geekmoots attended:
Nottingham, UK 2012 | Ghent, Belgium 2015 | Leicester, UK 2016


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
A2 Hosting