[SOLVED] Javascript error in IE 7 when viewing "Content > Pages"

This is a FORK of the CMS Made Simple project and is not oficially supported in any way by the CMS Made Simple development team.
Locked
joecannes
Forum Members
Forum Members
Posts: 93
Joined: Mon Nov 26, 2007 5:00 pm
Location: Montreal, Quebec

[SOLVED] Javascript error in IE 7 when viewing "Content > Pages"

Post by joecannes »

Hi all,

I've just a fresh install of CMS MLE 1.5.2, using IE 7.

While still using IE 7, I login into the admin area, and click on Content > Pages, and that's where I get where I javascript error stating:

Error: Expected ')'

I dont get the error using Firefox.

If I delete all the pages and just keep the default page, the error is gone. But when i create a new page, the error reappears.

The error also appears when I go to Content > Printer Friendly Pages.

ANyone else getting this error in IE 7, and does anyone know how to fix this problem?

Thanks,

JC
Last edited by joecannes on Tue Jan 27, 2009 8:39 pm, edited 1 time in total.
joecannes
Forum Members
Forum Members
Posts: 93
Joined: Mon Nov 26, 2007 5:00 pm
Location: Montreal, Quebec

Re: Javascript error in IE 7 when viewing "Content > Pages"

Post by joecannes »

Just to follow up, it used to be that if I had an apostrophe in my menu text, then I would recieve this error.

I figured that out in CMSMS MLE 1.4.1. 

But I am not using any special characters for the menu text or title.
joecannes
Forum Members
Forum Members
Posts: 93
Joined: Mon Nov 26, 2007 5:00 pm
Location: Montreal, Quebec

[SOLVED] Javascript error in IE 7 when viewing "Content > Pages"

Post by joecannes »

After spending this morning looking into the problem, just figured it out:

I opened admin.inc.php  (using Dreamweaver) under:

admin > lang > en_US > admin.inc.php

and edited line 1146:

$lang['admin']['confirmdefault'] = 'Are you sure you want to set - %s - as the site\\\'s default page?';

and updated it to

$lang['admin']['confirmdefault'] = 'Are you sure you want to set - %s - as the site default page?';

and my javascript problem has gone away!


Second, for the Printer Friendly Pages, I opened the file called en_US.php (using Dreamweaver) under:

modules > Printing > lang > en_US.php

and edited line 13:

$lang["confirmresettemplate"]="Are you sure the template should be reset to it's default value?";

and updated it to:

$lang["confirmresettemplate"]="Are you sure the template should be reset to the default value?";



Alby, can this be updated for the next version of CMSMS MLE? (not the way I wrote the confirmation sentence, but the problem with the apostriphe " 's" )


Joe Cannes
Last edited by joecannes on Tue Jan 27, 2009 8:40 pm, edited 1 time in total.
RonnyK
Support Guru
Support Guru
Posts: 4963
Joined: Wed Oct 25, 2006 8:29 pm
Location: Raalte, the Netherlands

Re: [SOLVED] Javascript error in IE 7 when viewing "Content > Pages"

Post by RonnyK »

First one is fixed in SVN with revision 5409.

Ronny
RonnyK
Support Guru
Support Guru
Posts: 4963
Joined: Wed Oct 25, 2006 8:29 pm
Location: Raalte, the Netherlands

Re: [SOLVED] Javascript error in IE 7 when viewing "Content > Pages"

Post by RonnyK »

Second one is fixed in SVN as well with rev.78.

Ronny
SideshowBob
Forum Members
Forum Members
Posts: 80
Joined: Thu Sep 13, 2007 10:50 am
Location: Bristol, UK

Re: [SOLVED] Javascript error in IE 7 when viewing "Content > Pages"

Post by SideshowBob »

Just wanted to say thanks to JC for finding this one!

I was just about to start the debug process and your post saved me a lot of time.

Thanks of course to the awesome CMSMS team for fixing it too.

Bob
Locked

Return to “[locked] CMSMS MLE fork”