• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 5 posts ] 
Author Message
 Post subject: [SORTED] Error on NMS (2.2.2) running on a CMS Made Simple MLE version 1.5.2
PostPosted: Tue Jun 30, 2009 10:15 am 
Offline
Forum Members
Forum Members
User avatar

Joined: Mon Sep 03, 2007 8:02 am
Posts: 70
Location: Cascais
Hi all,

I'v just installed the last NMS (2.2.2) on a CMS Made Simple MLE version 1.5.2 "Caguas" runing on PHP 5.2.6 and I get the following error wen I go to Modules>NMS:

Fatal error: Call to a member function FetchRow() on a non-object in /home/becoach/public_html/2009/modules/NMS/function.utils.php on line 57

Thanks in advance

Paulo


Last edited by pgingao on Tue Jun 30, 2009 10:50 am, edited 1 time in total.

Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Error on NMS (2.2.2) running on a CMS Made Simple MLE version 1.5.2 "Caguas"
PostPosted: Tue Jun 30, 2009 10:32 am 
Offline
Support Guru
Support Guru
User avatar

Joined: Mon Jul 04, 2005 5:12 pm
Posts: 4809
Location: Ferrara, Italy
pgingao wrote:
Fatal error: Call to a member function FetchRow() on a non-object in /home/becoach/public_html/2009/modules/NMS/function.utils.php on line 57


Have you apply patch?

Alby

_________________
Former Italian Admin and Moderator
Multilingual: MLE is not CMSMS


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Error on NMS (2.2.2) running on a CMS Made Simple MLE version 1.5.2 "Caguas"
PostPosted: Tue Jun 30, 2009 10:33 am 
Offline
Forum Members
Forum Members
User avatar

Joined: Mon Sep 03, 2007 8:02 am
Posts: 70
Location: Cascais
Hi Alby,

sorry but what patch?

Thank you

Paulo


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Error on NMS (2.2.2) running on a CMS Made Simple MLE version 1.5.2 "Caguas"
PostPosted: Tue Jun 30, 2009 10:38 am 
Offline
Support Guru
Support Guru
User avatar

Joined: Mon Jul 04, 2005 5:12 pm
Posts: 4809
Location: Ferrara, Italy
pgingao wrote:
sorry but what patch?


Here, it's for 2.2
but you must substitute query (about) row #50:
Quote:
................
  $mypages = array();
  $parms = array('content');
//Start MLE
global $mleblock;
  $q = "SELECT content_id,content_name{$mleblock}
                FROM ".cms_db_prefix()."content
               WHERE type = ?
                 AND active = 1";
//End MLE

  if( $templateid != '' )
    {
.........


Alby

_________________
Former Italian Admin and Moderator
Multilingual: MLE is not CMSMS


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Error on NMS (2.2.2) running on a CMS Made Simple MLE version 1.5.2 "Caguas"
PostPosted: Tue Jun 30, 2009 10:47 am 
Offline
Forum Members
Forum Members
User avatar

Joined: Mon Sep 03, 2007 8:02 am
Posts: 70
Location: Cascais
Thanks a lot Alby, I've seen that topic but I didn't give it a try it because it was a bit old.

It's now running smooth with that patch and the change on the query.

Cheers

Paulo


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
A2 Hosting