Need to upgrade a simple plugin to V2

A place to make for-pay "CMS made simple" job offerings
Post Reply
SpringSummer
Forum Members
Forum Members
Posts: 10
Joined: Sun Jan 06, 2013 6:28 pm

Need to upgrade a simple plugin to V2

Post by SpringSummer »

Hello I have an old List Children plug-in that stopped working due to Smarty changes to version 2. of CMSMS. I need someone to spend a little time (paid) to change the code to conform to current Smarty requirements.
Payment via Paypal. Send PM with proposed rate for the project. I may have another plugin or two to fix as well.

Code: Select all

global $gCms;
$manager =& $gCms->GetHierarchyManager();
$thisPage = $gCms->variables['page_name'];
$currentNode = &$manager->sureGetNodeByAlias($thisPage);

$nodes = $currentNode->getChildren();

if ($currentNode->hasChildren()) {
  echo '<ul class="sectionlinks">';
  foreach ($nodes as $node) {
     $content= $node->getContent();
     $url = $content->GetURL();
    if ($url == "#") { /* section header has no link by default */
      $url = "index.php?page=".$content->Alias();
    }
    echo "<li><a href=\"".$url."\">".$content->MenuText()."</a> </li>";

  }
  echo "</ul>";
}
This code makes a listing of sub-children of the page (navigation wise), shown parent page whereever this is placed.
Curious2
New Member
New Member
Posts: 5
Joined: Mon Nov 02, 2020 8:27 pm

Re: Need to upgrade a simple plugin to V2

Post by Curious2 »

Send PMs to this account. I lost e-mail password for the older account, so I won't see your PM there.
I would prefer seasoned developers answering first. I don't want to see someone with 50 forum posts total.
Last edited by Curious2 on Mon Nov 02, 2020 8:38 pm, edited 2 times in total.
nan11
New Member
New Member
Posts: 1
Joined: Fri Jun 05, 2020 10:44 am

Re: Need to upgrade a simple plugin to V2

Post by nan11 »

I am interested to help you with this. Please PM me your email contact details.

Thanks
Curious2
New Member
New Member
Posts: 5
Joined: Mon Nov 02, 2020 8:27 pm

Re: Need to upgrade a simple plugin to V2

Post by Curious2 »

You don't meet the requirements of having 50 forum posts. I am not interested in a lurker who has no deep knowledge about CMSMS. Try to invest in the community first before snatching coding jobs.
Post Reply

Return to “Help Wanted (commercial)”