• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 2 posts ] 
Author Message
 Post subject: Consumo excesivo de espacio en disco... [SOLUCIONADO]
PostPosted: Fri Jun 19, 2015 10:39 pm 
Offline
Forum Members
Forum Members

Joined: Fri Oct 31, 2008 2:50 pm
Posts: 57
Hola a todos!

Mi proveedor de host me estuvo avisando estos días del alto incremento de uso de disco. Después de un análisis profundo de los directorios encontré que había un archivo error_log que ocupaba 63 Mb. Al borrar el contenido se solucionó provisionalmente el problema, pero es evidente que volverá a llenarse. El texto repetido infinidad de veces es semejante a este:

[19-Jun-2015 21:36:41 UTC] PHP Warning: Parameter 1 to cms_module_Lang() expected to be a reference, value given in /home/festum/public_html/lib/classes/class.module.inc.php on line 2012
[19-Jun-2015 21:36:41 UTC] PHP Warning: Parameter 1 to cms_module_Lang() expected to be a reference, value given in /home/festum/public_html/lib/classes/class.module.inc.php on line 2012
[19-Jun-2015 21:36:41 UTC] PHP Warning: Parameter 1 to cms_module_Lang() expected to be a reference, value given in /home/festum/public_html/lib/classes/class.module.inc.php on line 2012
[19-Jun-2015 21:36:41 UTC] PHP Warning: Parameter 1 to cms_module_Lang() expected to be a reference, value given in /home/festum/public_html/lib/classes/class.module.inc.php on line 2012

Googleando he visto que hay muchas webs a las que les pasa, pero no he logrado encontrar la manera de localizar el error y modificar el código.

¿alguna idea de cómo solucionar ese error?

Gracias!


Last edited by silvio on Sat Jun 20, 2015 12:33 am, edited 1 time in total.

Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Consumo excesivo de espacio... [SOLUCIONADO]
PostPosted: Sat Jun 20, 2015 12:32 am 
Offline
Forum Members
Forum Members

Joined: Fri Oct 31, 2008 2:50 pm
Posts: 57
Hola buenas!

Lo solucioné... al menos todo funciona.
Primero abrí el archivo donde estaba la línea que causaba el problema: class.module.inc.php y allí busqué la línea famosa, que contenía la expresión "cms_module_Lang"

Consideré que si el lenguaje de un módulo no funcionaba bien, no afectaría a la web, así que probé a desactivar esa frase con los modificadores /** y */ agregando un poco de texto para recordar posteriormente lo que hice, si algo fallaba.

Una vez guardado, volví a abrir la página y la hice recargar para evitar la caché, y navegué un rato por el sitio sin detectar ninguna anomalía, así que lo dejé tal cual.

No es la mejor solución, porque no sé lo que hice... pero para una emergencia funciona.

Si alguien me puede dar una idea mejor, lo voy a agradecer!

Saludos!


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Hosting Nation - Managed CMSMS Hosting