CMS Made Simple Forums
https://forum.cmsmadesimple.org/

CMSMS version 1 vs. CMSMS version 2
https://forum.cmsmadesimple.org/viewtopic.php?f=3&t=77712
Page 1 of 1

Author:  pixelita [ Tue Dec 12, 2017 10:44 pm ]
Post subject:  CMSMS version 1 vs. CMSMS version 2

I have a client whose site I developed many years ago and it's currently running CMSMS 1.11.7. It doesn't use a lot of complicated modules, just a calendar, contact form and media player.

I approached her about upgrading to CMSMS2 citing the fact that it's always best to have the latest versions of a script running on your server and that I wouldn't do anything other than upgrade it. Being cost-conscious, she's dragging her feet about upgrading. And seeing that there can be issues when one does an upgrade, even incrementally, as is suggested in the documentation, can cause things to break.

Just wondering if there are any other really good reasons to upgrade other than my biggie, web site security. From what I've read about CMSMS2, improvements have been made to speed it up and clean up the code.

I guess my question boils down to this: Are there an inherent dangers in staying with the older version, and at least upgrading her to the latest CMSMS1 version? Thanks all!

Joni Mueller
Pixelita Designs
https://www.pixelita.com

Author:  Tomek [ Thu Dec 14, 2017 9:50 am ]
Post subject:  Re: CMSMS version 1 vs. CMSMS version 2

Hi, in short:

Speed optimization: php7 is much faster, and only V2 supports this PHP version.

Security: V1.11.7 is outdated and insecure. Latest for V1 is 1.12.2. And there has been no more security fix (and will never be) on V1 for almost 2 years.

Nobrainer to me, the upgrade is quite simple (with few third party modules) if you're doing it right: first to 1.12.2, then get the latest installer (currently 2.2.4), and running upgrade.
You'll need to check / change some things in templates, mostly Menu -> Navigator.

Author:  pixelita [ Thu Dec 14, 2017 1:10 pm ]
Post subject:  Re: CMSMS version 1 vs. CMSMS version 2

That's what I suspected. I need to check her hosting. I believe she's using 5.6, but hopefully there's a way to change her version to PHP 7. Thanks

Author:  Tomek [ Thu Dec 14, 2017 1:23 pm ]
Post subject:  Re: CMSMS version 1 vs. CMSMS version 2

5.6 is still ok, but the next "big" CMSMS version 2.3 will support from PHP 7 only, see viewtopic.php?f=1&p=336191#p336191

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/