• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC

Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 2 posts ] 
Author Message
 Post subject: PHP 5.6 to 7.0 Error 500 issue
PostPosted: Wed Nov 01, 2017 9:24 am 
New Member
New Member

Joined: Thu Nov 19, 2015 11:10 pm
Posts: 7
Hello, I have upgrade from php 5.6 to php 7.0 and get some error 500 when I try to use the module manager. I can enter and see the modules but not upgrade or install new. Each time it brings me to the following error:
Server error!

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.

Error 500

Here is my system information:
Cms Version: 2.1.3
Installed Modules:
AdminSearch: 1.0.1
CGExtensions: 1.53.6
CGSmartImage: 1.21.3
CMSContentManager: 1.1
DesignManager: 1.1.1
FileManager: 1.5.2
Gallery: 2.3.2
MicroTiny: 2.0.3
ModuleManager: 2.0.2
Navigator: 1.0.3
News: 2.50.5
Search: 1.50.2
TinyMCE: 3.1.4

Config Information:
max_upload_size: 300000000
url_rewriting: mod_rewrite
query_var: page
auto_alias_content: true
set_names: true
timezone: Europe/Zurich
permissive_smarty: false

Php Information:
phpversion: 7.0.7
md5_function: On (True)
json_function: On (True)
gd_version: 2
tempnam_function: On (True)
magic_quotes_runtime: Off (False)
E_ALL: 32759
E_STRICT: 2048
test_file_timedifference: No time difference found
test_db_timedifference: No time difference found
create_dir_and_file: 1
memory_limit: 256M
max_execution_time: 60
register_globals: Off (False)
output_buffering: 20480
disable_functions: passthru, exec, system, popen, shell_exec, proc_open
test_remote_url: Success
file_uploads: On (True)
post_max_size: 300M
upload_max_filesize: 300M
session_save_path: /home/clients/c389a9272f447bd57005e45aeff9eb7a/tmp (3777)
session_use_cookies: On (True)
xml_function: On (True)
xmlreader_class: On (True)
check_ini_set: On (True)
curl: On

Performance Information:
allow_browser_cache: Off (False)
browser_cache_expiry: 60
php_opcache: Off (False)
smarty_cache: Off (False)
smarty_compilecheck: Off (False)
smarty_cache_udt: Off (False)
auto_clear_cache_age: On (True)
Server Information:
Server Software: Apache
Server Api: fpm-fcgi
Server Os: Linux 3.16.0-0.bpo.4-amd64 On x86_64
Server Db Type: MySQL (mysqli)
Server Db Version: 5.6.33
Server Db Grants: Could not find a suitable "GRANT ALL" permission, this does not necessarily lead to problems... But if you have problems installing/removing modules or adding and deleting items/pages this could be the cause!

Permission Information:
tmp: /home/clients/c389a9272f447bd57005e45aeff9eb7a/web/cms/tmp (2755)
tmp_cache: /home/clients/c389a9272f447bd57005e45aeff9eb7a/web/cms/tmp/cache (2755)
templates_c: /home/clients/c389a9272f447bd57005e45aeff9eb7a/web/cms/tmp/templates_c (2755)
modules: /home/clients/c389a9272f447bd57005e45aeff9eb7a/web/cms/modules (2755)
uploads: /home/clients/c389a9272f447bd57005e45aeff9eb7a/web/cms/uploads (2755)
File Creation Mask (umask): /home/clients/c389a9272f447bd57005e45aeff9eb7a/web/cms/tmp/cache (2755)
config_file: 0444

Looking at the cpanel from Infomaniak, I can see the following line:
$_SERVER['ORIG_SCRIPT_FILENAME'] /home/clients/c389a9272f447bd57005e45aeff9eb7a/.config/apache/WEBSITE/.fpm/php5.external
Is there something there that I should manually modify? If so, how?


Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: PHP 5.6 to 7.0 Error 500 issue
PostPosted: Mon Nov 13, 2017 12:29 am 
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Feb 25, 2009 4:25 am
Posts: 214
Location: Victoria, BC
I would try the following, test after each one:

  1. make sure you're using the latest version of cmsms
  2. confirm mod_security isn't enabled
  3. clear the cmsms cache
  4. check the system info to make sure you have all green checks, and resolve as necessary
  5. check .htaccess and php.ini for anything unusual (or temporarily remove them)

If you still can't get it to work, you'll need to examine the error logs and try to provide information to your host about possible missing extensions or something.

Not getting the answer you need? CMSMS support options

Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 2 posts ] 

All times are UTC

Who is online

Users browsing this forum: No registered users

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
HostPapa CMS Made Simple hosting