• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 5 posts ] 
Author Message
 Post subject: [Solved] CMSMS 2.1.3 php 7.0 Module Manager Error 500
PostPosted: Wed Nov 01, 2017 8:25 am 
Offline
New Member
New Member

Joined: Thu Nov 19, 2015 11:10 pm
Posts: 7
Good morning,

I just upgraded to php 7.0 and things seem to work properly except that I can't access the module manager anymore. I have the following error coming up:
-----------------------
Server error!

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.

Error 500
---------------------

Any ideas? I actually wanted to upgrade the formbuilder as it shows errors but can't do that now.

Here is my configuration:
----------------------------------------------
Cms Version: 2.1.3
Installed Modules:
AdminSearch: 1.0.1
CGExtensions: 1.53.6
CGSmartImage: 1.21.3
CMSContentManager: 1.1
CMSMailer: 6.2.14
DesignManager: 1.1.1
FileManager: 1.5.2
FormBuilder: 0.8.1.3
Gallery: 2.1.5
MenuManager: 1.50.2
MicroTiny: 2.0.3
ModuleManager: 2.0.2
Navigator: 1.0.3
News: 2.50.5
Search: 1.50.2
TinyMCE: 3.1.4

Config Information:
php_memory_limit:
max_upload_size: 300000000
url_rewriting: mod_rewrite
page_extension:
query_var: page
auto_alias_content: true
locale:
set_names: true
timezone: Europe/Zurich
permissive_smarty: false

Php Information:
phpversion: 7.0.7
md5_function: On (True)
json_function: On (True)
gd_version: 2
tempnam_function: On (True)
magic_quotes_runtime: Off (False)
E_ALL: 32759
E_STRICT: 2048
E_DEPRECATED: 8192
test_file_timedifference: No time difference found
test_db_timedifference: No time difference found
create_dir_and_file: 1
memory_limit: 256M
max_execution_time: 60
register_globals: Off (False)
output_buffering: 20480
disable_functions: passthru, exec, system, popen, shell_exec, proc_open
open_basedir:
test_remote_url: Success
file_uploads: On (True)
post_max_size: 300M
upload_max_filesize: 300M
session_save_path: /home/clients/c389a9272f447bd57005e45aeff9eb7a/tmp (3777)
session_use_cookies: On (True)
xml_function: On (True)
xmlreader_class: On (True)
check_ini_set: On (True)
curl: On

Performance Information:
allow_browser_cache: Off (False)
browser_cache_expiry: 60
php_opcache: Off (False)
smarty_cache: Off (False)
smarty_compilecheck: Off (False)
smarty_cache_udt: Off (False)
auto_clear_cache_age: On (True)
Server Information:
Server Software: Apache
Server Api: fpm-fcgi
Server Os: Linux 3.16.0-0.bpo.4-amd64 On x86_64
Server Db Type: MySQL (mysqli)
Server Db Version: 5.6.33
Server Db Grants: Could not find a suitable "GRANT ALL" permission, this does not necessarily lead to problems... But if you have problems installing/removing modules or adding and deleting items/pages this could be the cause!

Permission Information:
tmp: /home/clients/c389a9272f447bd57005e45aeff9eb7a/web/cms/tmp (2755)
tmp_cache: /home/clients/c389a9272f447bd57005e45aeff9eb7a/web/cms/tmp/cache (2755)
templates_c: /home/clients/c389a9272f447bd57005e45aeff9eb7a/web/cms/tmp/templates_c (2755)
modules: /home/clients/c389a9272f447bd57005e45aeff9eb7a/web/cms/modules (2755)
uploads: /home/clients/c389a9272f447bd57005e45aeff9eb7a/web/cms/uploads (2755)
File Creation Mask (umask): /home/clients/c389a9272f447bd57005e45aeff9eb7a/web/cms/tmp/cache (2755)
config_file: 0444
----------------------------------------------

Thanks for the help!


Last edited by vclack on Wed Nov 01, 2017 9:01 am, edited 1 time in total.

Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: CMSMS 2.1.3 upgrade to php 7.0 Module Manager Error 500
PostPosted: Wed Nov 01, 2017 9:00 am 
Offline
New Member
New Member

Joined: Thu Nov 19, 2015 11:10 pm
Posts: 7
Actually I solved it by going back to php 5.6, going to the module manager and removing the FormBuilder as well as the deprecated modules that I had there.
Went then back to setting php 7.0 again. Now I can access to the module manager all good.


Don't know why it worked but it did!


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: [Solved] CMSMS 2.1.3 php 7.0 Module Manager Error 500
PostPosted: Wed Nov 01, 2017 9:43 am 
Offline
New Member
New Member

Joined: Thu Nov 19, 2015 11:10 pm
Posts: 7
Actually I went a bit fast on this one... problem is not solved. Just made it possible to access the module manager but not to go further to install or upgrade anything.

Just put another post:
viewtopic.php?f=3&t=77547

Thanks for the help!


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: [Solved] CMSMS 2.1.3 php 7.0 Module Manager Error 500
PostPosted: Wed Nov 01, 2017 9:46 am 
Online
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7440
Location: The Netherlands
Latest CMSMS version is 2.2.3.1, so please upgrade your CMS first.

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return! [ Click here ]



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: [Solved] CMSMS 2.1.3 php 7.0 Module Manager Error 500
PostPosted: Wed Nov 01, 2017 10:13 am 
Offline
New Member
New Member

Joined: Thu Nov 19, 2015 11:10 pm
Posts: 7
Ok am trying to and now get a Server error
----------------------
Server error!

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.

Error 500

----------------

When I click upgrade after opening the relevant php install file on the web.
Error log shows:
stm-ac.ch 188.61.117.26 - - [01/Nov/2017:11:12:07 +0100] "GET /cms/cmsms-2.2.3.1-install.php/index.php?mbd5ada6e=3 HTTP/1.1" 500 1035 "http://www.stm-ac.ch/cms/cmsms-2.2.3.1-install.php/index.php?mbd5ada6e=2" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"

FastCGI: incomplete headers (0 bytes) received from server "/home/clients/c389a9272f447bd57005e45aeff9eb7a/.config/apache/stm-ac.ch/.fpm/php5.external", referer: http://stm-ac.ch/cms/cmsms-2.2.3.1-inst ... =2?debug=1

What next?!?


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
A2 Hosting