• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Non funzionano più i link
PostPosted: Fri Dec 16, 2011 3:19 pm 
Offline
New Member
New Member

Joined: Fri Dec 16, 2011 3:14 pm
Posts: 3
salve,
premetto che sono molto inesperto....

un amico mi ha messo in piedi un sito con CMS www.itlug.org
E andava tutto bene, mi modificavo le mie paginette, ecc.

A seguito di una intrusione sul server sono stati inseriti alcuni sistemi di protezione (?)
Adesso per entrare nel pannello di amministrazione passo da www.itlug.org/docs e metto le mie credenziali

Il problema è che, del mio sito si vede solo la Home Page, tutti i link non funzionano! Come posso fare?

Grazie


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Non funzionano più i link
PostPosted: Sat Dec 17, 2011 11:40 am 
Offline
Power Poster
Power Poster

Joined: Sun Dec 28, 2008 12:15 pm
Posts: 448
Location: Roma, Italy
Il file .htaccess è ancora presente nella root del sito e contiene le istruzioni corrette per il mod_rewrite?
Il problema è nella riscrittura degli URl. Infatti se provi http://www.itlug.org/index.php?page=glossario la pagina si vede

Ti consiglio di cambiare il nome alla cartella /docs/ che contiene l'accesso al pannello di amministrazione (scegliendone uno non facile da indovinare) e, quindi, di non divulgare il nuovo nome sul forum. È una delle tante precauzioni che dovresti prendere per rendere più difficile la vita a chi cerca di violare il tuo sito.

Leggi queste guide:
- How to Secure CMSMS system - Small Guide (in inglese)

- Messa in sicurezza del sito (in italiano)


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Non funzionano più i link
PostPosted: Thu Dec 22, 2011 8:40 am 
Offline
New Member
New Member

Joined: Fri Dec 16, 2011 3:14 pm
Posts: 3
nervino wrote:
Il file .htaccess è ancora presente nella root del sito e contiene le istruzioni corrette per il mod_rewrite?


ehmm, come faccio a saperlo? :'(

Quote:
Il problema è nella riscrittura degli URl. Infatti se provi http://www.itlug.org/index.php?page=glossario la pagina si vede


Si questo lo so...... ma posso risolverlo io, da inesperto?

Grazie per gli altri consigli


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Non funzionano più i link
PostPosted: Thu Dec 22, 2011 9:22 am 
Offline
Power Poster
Power Poster

Joined: Sun Dec 28, 2008 12:15 pm
Posts: 448
Location: Roma, Italy
Se nel file config.php hai impostato il mod_rewrite, nella root del sito deve essere presente un file ".htaccess". Un file di questo tipo lo dovresti trovare nela cartella "doc" che c'è nella distribuzione di cmsms.
Dai un'occhiata a questo post: http://forum.cmsmadesimple.org/viewtopic.php?f=29&t=43792&p=207862&hilit=pretty.


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
A2 Hosting