• twitter image
  • facebook image
  • youtube image
  • linkedin image
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple Netherlands

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Multiple backend failures... are they connected?
PostPosted: Mon Oct 23, 2017 5:46 am 
Offline
Forum Members
Forum Members

Joined: Sun Oct 28, 2007 4:14 am
Posts: 207
Location: Australia
I have Heart's Content 2.2.2

I have a clutch of problems which have developed in the past week. I am wondering if, or how much, they are related. Perhaps someone can see some connections. I'd be grateful for any help.

1. I can't upgrade to 2.2.3.1
2. CGFeeback posts from readers cannot be edited
3. NMS jobs are not showing up in Calguy's Job Processing Module
4. Intermittent failures when editing pages.

DETAIL 1: I can't upgrade to 2.2.3.1
I get the error "Fatal Error Invalid config value for dest - not a directory, or not writable"
I noted this in the Forum on Oct 17, and have yet to solve it.

DETAIL 2: In preparing to update to 2.2.3.1, I updated CGFeedback, which I think also meant upgrading CGExtensions.
I found later that CGFeeback posts from readers could not be edited by me; that is, I could edit them in the backend, but when I submitted the changes they were not saved. (Noted in the Modules Forum October 20, and I've not yet had time to address it again)

I have uninstalled CGFeedback and reinstalled it in the past, so I guess I could even roll it back to the earlier version, but it's a somewhat scary process because of the large number of posts it has, and always leaves me wondering if I will lose them as I restore the database table to the new install. So it's not an ideal way to try to fix the issue.

DETAIL 3: NMS jobs are not showing up in Calguy's Job Processing Module
Today, after writing my weekly post, I used NMS to create a notification to my readers. I sent a test email to my own address, which worked fine. However, I cannot create a job to my mailing list.

Or, rather, the job is created and visible in NMS, but does not show up in Calguy's job processing manager. It is visible in the Background Job Manager as having been sent, but Calguys Job Processing Manager tells me there are no jobs...

I uninstalled Calguys Job Processing Manager and reinstalled it, deleted the NMS job and created another one (several times) but it does not make it to the Calguys Job Processing Manager.

I'm wondering how much of all this might be connected.

Detail 4: Editing problems.
Added to all this, I had intermittent errors editing content pages a couple of days ago.
I would click on submit or Apply and the page would go to my page not found page, leaving the backend altogether.

On this site, ever since the host installed Mod Security many months ago, several Mod Security settings had been white listed for my site. I'm well aware of the problems mod security can cause, and indeed found that turning it off fixed my recent editing problems, I assume the white listing had been removed in some sort of upgrade work by them.

So I have completely disabled Mod Security, which seems to have fixed the editing issue. And always turned it off if upgrading anything.

Regardless of this, I cannot upgrade to 2.2.3.1, nor can I send to mail lists, and nor can I edit CGFeedback posts.

I'd be most grateful if anyone has any suggestions of how to proceed.

Other Details and Configuration, plus some logs:

I have also noted my Admin log has pages 1-5 and then nothing until page 305-310 then 611-616, which is not what I expect to see.


The site itself has some 1450 pages

Details:
----------------------------------------------
Cms Version: 2.2.2
Installed Modules:
AceEditor2: 1.05
AdminSearch: 1.0.4
Album: 1.11
CGActionBar: 1.1.2
CGExtensions: 1.57.1
CGFeedback: 2.1
CGJobMgr: 1.3.6
CGSimpleSmarty: 2.1.7
CMSContentManager: 1.1.5
CMSMailer: 6.2.14
Captcha: 0.5.5
CmsJobManager: 0.1
DesignManager: 1.1.3
FileManager: 1.6.3
FilePicker: 1.0
JQueryTools: 1.4.0.3
MenuManager: 1.50.3
MicroTiny: 2.2
ModuleManager: 2.1.1
NMS: 2.13
Navigator: 1.0.7
News: 2.51.2
Printing: 1.1.2
Search: 1.51.2
Showtime2: 3.5.4
SiteMapMadeSimple: 1.2.8
ThemeManager: 1.1.8
nuSOAP: 1.0.2

Config Information:
php_memory_limit:
max_upload_size: 16000000
url_rewriting: mod_rewrite
page_extension: .html
query_var: page
auto_alias_content: true
locale:
set_names: false
timezone: Australia/Adelaide
permissive_smarty: true

Php Information:
phpversion: 5.6.31
md5_function: On (True)
json_function: On (True)
gd_version: 2
tempnam_function: On (True)
magic_quotes_runtime: Off (False)
E_ALL: 32767
E_STRICT: 2048
E_DEPRECATED: 8192
test_file_timedifference: No time difference found
test_db_timedifference: No time difference found
create_dir_and_file: 1
memory_limit: 128M
max_execution_time: 120
register_globals: Off (False)
output_buffering: 4096
disable_functions: show_source, system, shell_exec, passthru, exec, popen, proc_open
open_basedir:
test_remote_url: Success
file_uploads: On (True)
post_max_size: 32M
upload_max_filesize: 16M
session_save_path: /tmp (0700)
session_use_cookies: On (True)
xml_function: On (True)
xmlreader_class: On (True)
check_ini_set: On (True)
curl: On

Performance Information:
allow_browser_cache: Off (False)
browser_cache_expiry: 30
php_opcache: On (True)
smarty_cache: Off (False)
smarty_compilecheck: Off (False)
auto_clear_cache_age: On (True)
Server Information:
Server Software: Apache
Server Api: cgi-fcgi
Server Os: Linux 3.10.0-714.10.2.lve1.4.61.el7.x86_64 On x86_64
Server Db Type: MySQL (mysqli)
Server Db Version: 5.6.37
Server Db Grants: Found a "GRANT ALL" statement that appears to be suitable

Permission Information:
tmp: /home/BLAH/public_html/tmp (0755)
tmp_cache: /home/BLAH/public_html/tmp/cache (0755)
templates_c: /home/BLAH/public_html/tmp/templates_c (0755)
modules: /home/BLAH/public_html/modules (0755)
uploads: /home/BLAH/public_html/uploads (0775)
File Creation Mask (umask): /home/mansweb/public_html/tmp/cache (0755)
config_file: 0444
----------------------------------------------

And from the admin log:

CmsJobManager
Cleared 3 bad jobs
23 Oct. 2017 15:40:35
203.122.240.177
BLAH
45
NMS
Job entitled: Quick job: First Impressions: The Unlearning of Love - Matthew 22:34-46 created
23 Oct. 2017 15:16:55
203.122.240.177
BLAH
44
NMS
Deleted Job entitled: Quick job: First Impressions: The Unlearning of Love - Matthew 22:34-46
23 Oct. 2017 15:15:03
203.122.240.177
BLAH
 
CGJobMgr
No Verification Data: Cannot verify integrity of CGJobMgr. There is no checksum data
23 Oct. 2017 15:14:25
203.122.240.177
BLAH
 
Module
Installed CGJobMgr version 1.3.6
23 Oct. 2017 15:14:08
203.122.240.177
BLAH
 
Module
Uninstalled module CGJobMgr
23 Oct. 2017 15:13:12
203.122.240.177
BLAH
44
NMS
Job entitled: Quick job: First Impressions: The Unlearning of Love - Matthew 22:34-46 created
23 Oct. 2017 14:45:24
203.122.240.177
BLAH
43
NMS
Deleted Job entitled: Quick job: First Impressions: The Unlearning of Love - Matthew 22:34-46
23 Oct. 2017 14:44:26
203.122.240.177
BLAH
1
Admin Username: BLAH
Logged In
23 Oct. 2017 14:43:39


 
Admin Username:
Logged Out
23 Oct. 2017 14:43:11
203.122.240.177
BLAH
1
Admin Username: BLAH
Logged Out
23 Oct. 2017 14:43:06
203.122.240.177
BLAH
 
System maintenance
Cache cleared
23 Oct. 2017 14:41:42
203.122.240.177
BLAH
43
NMS
Job entitled: Quick job: First Impressions: The Unlearning of Love - Matthew 22:34-46 created
23 Oct. 2017 14:40:24


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Multiple backend failures... are they connected?
PostPosted: Mon Oct 23, 2017 8:31 am 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7561
Location: The Netherlands
Quote:
DETAIL 1: I can't upgrade to 2.2.3.1
I get the error "Fatal Error Invalid config value for dest - not a directory, or not writable"
I noted this in the Forum on Oct 17, and have yet to solve it.
...

Are you using the extended installer? And perhaps entered a wrong website destination/folder... Better try the regular installer from the working directory.

Quote:
DETAIL 2: In preparing to update to 2.2.3.1, I updated CGFeedback, which I think also meant upgrading CGExtensions.
I found later that CGFeeback posts from readers could not be edited by me; that is, I could edit them in the backend, but when I submitted the changes they were not saved. (Noted in the Modules Forum October 20, and I've not yet had time to address it again)

I have uninstalled CGFeedback and reinstalled it in the past, so I guess I could even roll it back to the earlier version, but it's a somewhat scary process because of the large number of posts it has, and always leaves me wondering if I will lose them as I restore the database table to the new install. So it's not an ideal way to try to fix the issue.
...
I haven't upgraded the module yet at my websites, but I have read similar post at the forum. So I suspect a simple but annoying bug in the code. Deinstalling the module will not help here. Beside that it will destroy your data. Like you write you could put back the dbase tables but the chance something goes wrong is... :-/
Better post a bug report for the module developer in the Forge.

Quote:
Detail 4: Editing problems.
Added to all this, I had intermittent errors editing content pages a couple of days ago.
I would click on submit or Apply and the page would go to my page not found page, leaving the backend altogether.

On this site, ever since the host installed Mod Security many months ago, several Mod Security settings had been white listed for my site. I'm well aware of the problems mod security can cause, and indeed found that turning it off fixed my recent editing problems, I assume the white listing had been removed in some sort of upgrade work by them.
....
Mod Security can (will) have nasty side effects. Effects that are not always visible for the regular user. If you use the latest CMSMS releases you really won't need it.

Hope this helps you a bit.

Grtz. Rolf

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return! [ Click here ]



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Multiple backend failures... are they connected?
PostPosted: Mon Oct 23, 2017 8:34 am 
Offline
Dev Team Member
Dev Team Member
User avatar

Joined: Wed Apr 23, 2008 7:53 am
Posts: 7561
Location: The Netherlands
Quote:
Multiple backend failures... are they connected?
No, just bad luck it all happens at the same time here as far as I can see...

_________________
Image

Did my post help you solving a problem at your (customers) website and it saved you many hours of work? Great!! Consider buying me a cup of coffee in return! [ Click here ]



Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Multiple backend failures... are they connected?
PostPosted: Mon Oct 23, 2017 9:09 am 
Offline
Forum Members
Forum Members

Joined: Sun Oct 28, 2007 4:14 am
Posts: 207
Location: Australia
Rolf, thank you for your replies.

I have found the upgrade problem. Host had turned off the php phar extension in the maybe 1 hour slot between updating one website on the same server and then getting to this one! So I've updated and learned a lesson. So that's all good.

Now to look at the other stuff.

Andrew


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
 Post subject: Re: Multiple backend failures... are they connected? SOLVED
PostPosted: Tue Oct 24, 2017 11:32 am 
Offline
Forum Members
Forum Members

Joined: Sun Oct 28, 2007 4:14 am
Posts: 207
Location: Australia
Fixed NMS by exporting my NMS mail list, removing the module and installing the old version. Then reimport mail.

Fixed CGFeedback by exporting comments table,
removed and reinstalled... could not get to work, settings would not save. Went back to 2.0.1 and worked my way up. By the time I got back to 2.1 I could save settings and test comments worked.

Removed comments table, installed backup. All good


Top
  Profile  
 
Share On:
Share on Facebook Share on Twitter Share on Google+
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
A2 Hosting